XFCE doesn't understand X-GNOME-Gettext-Domain

Bug #1583264 reported by Ilya Bizyaev
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Simple Scan
Fix Released
Medium
Unassigned
libxfce4util (Ubuntu)
Incomplete
Undecided
Unassigned

Bug Description

That is invisible in Unity, but noticeable in Xfce.
I attach the modified simple-scan.desktop file with the translation.

Tags: patch i18n
Revision history for this message
Ilya Bizyaev (bizyaev-game-deactivatedaccount) wrote :
Revision history for this message
Robert Ancell (robert-ancell) wrote :

The translations are done using gettext, so they should work. This suggests that Unity is not reading them correctly perhaps.

Revision history for this message
Robert Ancell (robert-ancell) wrote :

I tried here enabling Russian and the translations show correctly - what version of Ubuntu are you using?

Changed in simple-scan:
status: New → Incomplete
Revision history for this message
Ilya Bizyaev (bizyaev-game-deactivatedaccount) wrote :

Maybe I have not expressed myself correctly. The application name and description are translated properly in Unity, but are in English in Xfce.
I am using Ubuntu 16.04.

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Could you edit /usr/share/applications/simple-scan.desktop and change the last line:

X-GNOME-Gettext-Domain=simple-scan

to:

X-Ubuntu-Gettext-Domain=gedit

And then restart XFCE? It might be that XFCE doesn't support X-GNOME-Gettext-Domain. You could also try shotwell as this also uses X-GNOME-Gettext-Domain instead of X-Ubuntu-Gettext-Domain.

Revision history for this message
Ilya Bizyaev (bizyaev-game-deactivatedaccount) wrote :

I have inspected all the applications installed on my computer and their translations to Russian in XFce and Unity. Here are the results:

1) Shotwell simply does not provide Russian translation for its shortcut, so, it's in English both in XFce an Unity.
2) Remmina's shortcut is in Russian in Unity and in English in XFce, although there's no Russian translation in remmina.desktop. So, Unity seems to have its own message catalogs!
Same with the Simple Scan.

Then I tried your advice.
Replacing the last line with:
"X-Ubuntu-Gettext-Domain=simple-scan" fixed the issue!
I attach the result.

Revision history for this message
Robert Ancell (robert-ancell) wrote :

OK, so the issue is XFCE doesn't understand X-GNOME-Gettext-Domain - I've linked the XFCE package (libxfce4util) that should do this.

However, given this is not a commonly used feature, I'll drop this from simple-scan so it works anyway. Ubuntu automatically adds X-Ubuntu-Gettext-Domain when the package is built.

Changed in simple-scan:
status: Incomplete → Fix Committed
importance: Undecided → Medium
summary: - Russian translation for the .desktop file is missing
+ XFCE doesn't understand X-GNOME-Gettext-Domain
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Provides Russian translation" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in simple-scan:
milestone: none → 3.21.90
status: Fix Committed → Fix Released
Revision history for this message
Sean Davis (bluesabre) wrote :

Is this still an issue with Xfce/Xubuntu in a recent supported release (focal, impish, jammy)?

Changed in libxfce4util (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers