Race condition in libXext

Bug #519576 reported by Lei Zhang on 2010-02-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libxext (Ubuntu)
Undecided
Unassigned

Bug Description

There's a race condition in libXext that causes apps that use the X shared memory extensions to occasionally crash. [1][2] This has been fixed upstream with a small patch. [3] Can we cherrypick this for all affected releases? (Hardy to Karmic)

[1] http://lists.freedesktop.org/archives/xcb/2009-October/005102.html
[2] http://crbug.com/25324
[3] http://cgit.freedesktop.org/xorg/lib/libXext/commit/?id=956fd30e1046e5779ac0b6c07ec4f0e87250869a

Bryce Harrington (bryce) wrote :

Hi thestig-google,

Please attach the output of `lspci -vvnn` and `dmesg`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you're using a custom /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Lei Zhang (thestig-google) wrote :

Hi, the requested logs are irrelevant because I cannot reproduce the race condition on my machine. I only know about it because the aggregated reports from Google Chrome's crash logger show this crash happening.

This affects any application that calls XShmAttach(). The fix is pretty clear. Please apply the trivial patch [3] from upstream.

Lei Zhang (thestig-google) wrote :

FYI, this patch may fix all the crashes for xcb_io.c:378: _XAllocID: Assertion. There's many instances of this bug in the Ubuntu bug database, i.e. bug 458989.

Timo Aaltonen (tjaalton) wrote :

Fixed on lucid already.

Changed in libxext (Ubuntu):
status: New → Fix Released
Lei Zhang (thestig-google) wrote :

Umm, I know it's fixed in Lucid, which is why this bug report is asking for the fix to be backported to Hardy - Karmic.

Lei Zhang (thestig-google) wrote :

Ping. Please reopen. I realize Lucid is almost out, but Hardy will be supported for a while longer. Please at least backport this to Hardy.

Lei Zhang (thestig-google) wrote :

Can someone reopen this please?

Dan Kegel (dank) wrote :

I'm hitting this with Karmic + wine + steam a lot on my new i7.

Happily, I can move to Lucid beta, but there are a lot of Karmic users out there who can't...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers