libxext fills up .xsession-errors log files

Bug #1400730 reported by Jonathan Riddell on 2014-12-09
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
libxext (Ubuntu)
Undecided
Unassigned
Utopic
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

libxext can write debug output, and it can write so much of it that it fills up .xsession-errors t be several GB and fill up the hard disk (or the equivalent file with lightdm).

error is "_xgeWireToEvent: Unknown extension 148, this should never happen"

[TEST CASE]
Install Plasma 5 on utopic
Use it for a while
Notice that ~/.xsession-errors is filling up saying "_xgeWireToEvent: Unknown extension 148, this should never happen"

with the new packages this will not happen

Jonathan Riddell (jr) wrote :
Changed in libxext (Ubuntu Vivid):
status: New → Fix Released
Jonathan Riddell (jr) wrote :

Uploaded 1.3.2-1ubuntu0.1 to utopic-proposed, awaiting approval from ~ubuntu-sru. It applies the patch in the diff above.

Jonathan Riddell (jr) wrote :

Steam bug is bug 1369113

tags: added: kubuntu
Jonathan Riddell (jr) wrote :
description: updated
tags: added: utopic vivid
Jonathan Riddell (jr) wrote :

ping

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libxext (Ubuntu Utopic):
status: New → Confirmed
Jonathan Riddell (jr) wrote :

ping ping?

Ruman Gerst (ruman-gerst) wrote :

Herrlich, resolved for Vivid.
Should I put the Vivid alpha on my parent's laptop? May I start telling them to install and configure everything?

Is there any solution for Utopic?

Jayesh Bhoot (bhoot-jayesh) wrote :

Is there any solution for 14.10? I am not too willing to switch to Vivid Alpha at the moment, but this bug has become annoying now.

Andres Gomez (Tanty) (tanty) wrote :

I'm suffering the same problem and I've applied the suggested upstream patch in my personal PPA:
https://launchpad.net/~tanty/+archive/ubuntu/ppa/+packages

However, I don't think this is a proper fix for the problem I'm observing.

When the problem was happening and tons of

error is "_xgeWireToEvent: Unknown extension 148, this should never happen"

messages were spitted, everything was going much slower in the affected application.

With the fix, the application now is mute about this problem but it is still clearly slower. Hence, the error is still happening it is just that we are not seeing the error messages any more.

Is this error a regression in libXext ?

In my case, I'm specially seeing it in a custom compilation of epiphany, the GNOME Browser, from upstream. It seems to be affecting webkitgtk+ ...

I've just upgraded from Trusty and I was not suffering this problem before with the same custom compilation of epiphany.

Andres Gomez (Tanty) (tanty) wrote :

It seems I'm hitting 2 bugs at the same time since some of my performance problems with WebKitGTK+ seems to be caused because of this bug:
https://bugs.freedesktop.org/show_bug.cgi?id=85064

Brian Murray (brian-murray) wrote :

I've uploaded this again to the utopic proposed queue.

Hello Jonathan, or anyone else affected,

Accepted libxext into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libxext/2:1.3.2-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libxext (Ubuntu Utopic):
status: Confirmed → Fix Committed
tags: added: verification-needed
netb2c (netb2c) on 2015-01-22
Changed in libxext (Ubuntu Utopic):
status: Fix Committed → Fix Released
Changed in libxext (Ubuntu Utopic):
status: Fix Released → Fix Committed
Torsten Römer (dode) wrote :

Sorry if it is obvious, but is the fix included in 5.2? The problem is still present there.

Jonathan Riddell (jr) wrote :

I installed kubuntu plasma 5
I installed kdm and set it as default login manager (so it would output to .xsession-errors)
I installed libxext6 from utopic-proposed
I rebooted and logged in
.xsession-errors was pleasinly free of spamming error messages

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libxext - 2:1.3.2-1ubuntu0.1

---------------
libxext (2:1.3.2-1ubuntu0.1) utopic; urgency=medium

  * Remove warning messages about missing Xge extension event translations.
    (LP: #1400730)
 -- Brian Murray <email address hidden> Fri, 16 Jan 2015 15:35:09 -0800

Changed in libxext (Ubuntu Utopic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libxext has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.