Comment 41 for bug 87947

charly4711 (karl-h-beckers) wrote :

"Why can't we just remove the XCB infection/bridge layer from libX11 and revert it to the stock libX11 module? Let old libX11 programs use that, and new ones use XCB."

Far as I understand the issue, it is because some apps (e. g. compiz) don't work without.
I think the ideal short term solution for hardy would be to provide both versions of libX11. Make the non-xcb version the default and make apps which need xcb depend on the xcb enabled version placed in a different directory, then compile them with a runtime linker path pointing to that alternative xcb-enabled library.
I have just tested Bryce's non-xcb libs by simply extracting the debs to a given directory, unsetting LIBXCB_ALLOW_SLOPPY_LOCK, setting LD_LIBRARY_PATH to the directory with the the non-xcb libX11 and starting an app I was previously having problems with on hardy but none on gutsy. And, of course, everything worked like a charm.