Add alias for ru_UA.utf8 to /usr/share/X11/locale/locale.alias

Bug #601308 reported by olksy on 2010-07-03
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libx11 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libx11-data

I selected system language Russian (Ukraine), so that

$ locale
LANG=ru_UA.utf8
LANGUAGE=ru_UA:ru
LC_CTYPE="ru_UA.utf8"
LC_NUMERIC="ru_UA.utf8"
LC_TIME="ru_UA.utf8"
LC_COLLATE="ru_UA.utf8"
LC_MONETARY="ru_UA.utf8"
LC_MESSAGES="ru_UA.utf8"
LC_PAPER="ru_UA.utf8"
LC_NAME="ru_UA.utf8"
LC_ADDRESS="ru_UA.utf8"
LC_TELEPHONE="ru_UA.utf8"
LC_MEASUREMENT="ru_UA.utf8"
LC_IDENTIFICATION="ru_UA.utf8"
LC_ALL=

But /usr/share/X11/locale/locale.alias does not contain ru_UA.utf8. Hovewer, it contains ru_RU.utf8 alias as

ru_RU.utf8 ru_RU.UTF-8

Can someone, who know how locale works, explain why ru_UA.utf8 is missed from alias file?

I confused with this problem, because if I use ru_UA.utf8 locale, wine does not allow to type in cyrillic. If I use ru_RU.UTF-8, that is all ok.

Cyrillic in wine gets broken for ru_UA.utf8 locale after upgrading to Lucid.

olksy (noface) on 2010-07-03
description: updated
Bryce Harrington (bryce) wrote :

Hi olksy,

        Please attach the output of `lspci -vvnn` too.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in libx11 (Ubuntu):
status: New → Incomplete
olksy (noface) wrote :
olksy (noface) wrote :

I've attached /var/log/Xorg.0.log and 'lspci -vvnn' output

Bryce Harrington (bryce) on 2010-07-04
tags: removed: needs-xorglog
tags: removed: needs-lspci-vvnn
Changed in libx11 (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2010-07-04
tags: added: hardy
Bryce Harrington (bryce) on 2010-07-10
tags: added: lucid
divan (ivan-daniluk) wrote :

Confirm this in lucid. Cyrillic input in Picasa and wine do not work with ru_UA.utf8, only if set manually to ru_UA.UTF-8 or aliased.

Alexey Korop (akorop) wrote :

This bug produce aolso two problems:

1) in xterm (utf8 mod) cyrillic characters don't display properly;
2) in Lazarus IDE editor copy to clipboard don't work properly: this text may not be pasted outside the IDE.

Adding alias ru_UA.utf8 -> ru_UA.UTF-8 solve the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers