Mathematica does not work (doesn't find XKeysymDB, X11 locales)

Bug #25097 reported by Sebastian Kapfer on 2005-11-07
10
Affects Status Importance Assigned to Milestone
libx11 (Ubuntu)
Medium
Ubuntu-X

Bug Description

My Mathematica 5.0 doesn't work properly on Breezy. It spews a lot of warnings
(stuff like:

  Warning: translation table syntax error: Unknown keysym name: osfCancel
  Warning: ... found while parsing '<Key>osfCancel:ManagerParentCancel()'

and crashes when doing trivial UI-related things such as invoking the Help Browser.

The following commands make it run as before:

  cd /usr/X11R6/lib/X11
  rmdir locale # empty dir on my system
  ln -s /usr/share/X11/XKeysymDB .
  ln -s /usr/share/X11/locale/ .

Is there any chance to get such compatibility symlinks into the default install?

P.S.: I know this is probably not a Breezy bug per se, but supporting common
commercial (albeit buggy) software doesn't hurt.

Daniel Stone (daniels) wrote :

we're going to grow compatibility symlinks for dapper

Sebastian Kapfer (caci) wrote :

The XKeysymDB one works fine, the other one still doesn't:

../../../lib/X11/locale

That directory does not exist, it should be "share", not "lib".

Thanks for your help. :-)

Daniel Stone (daniels) on 2006-03-16
Changed in libx11:
assignee: daniels → ubuntu-x-swat

Still not solved in Edgy.

Changed in libx11:
status: Rejected → Unconfirmed
Sebastian Kapfer (caci) wrote :

XKeysymDB and locale compat symlinks went missing again in edgy. :-(

Fabián Rodríguez (magicfab) wrote :

Here is a list of supported platforms for Mathematica:
http://www.wolfram.com/products/mathematica/platforms/

Ubuntu is not listed there. Perhaps it would be a good idea to ask Wolfram if they intend to package Mathematica for Ubuntu ?

Sebastian Kapfer (caci) wrote :

That would be a great idea, although it's really a different issue. 5.0 is a legacy version, and I don't really have hope that they care about fixing it. Later versions of Mathematica seem to cope with the new X.org-style directories. Still, Mmca is an expensive product, and I expect many installations of 5.0 are in use even now (mine is). Also, we're discussing the addition of two symlinks (!) here, which is IMHO well worth the increased compatibility with past versions of Debian/Ubuntu.

Timo Aaltonen (tjaalton) wrote :

please update your Mathematica.. 5.2 works fine at least on dapper.

Changed in libx11:
status: Unconfirmed → Rejected
Sebastian Kapfer (caci) wrote :

Yes, updating a $1000 software package because of a missing symlink sounds like a reasonable plan.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.