gnome-panel crashed with signal 5 in _XReply()

Bug #1293252 reported by Ron Affeldt on 2014-03-16
182
This bug affects 27 people
Affects Status Importance Assigned to Milestone
libwnck3 (Ubuntu)
Medium
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
Vivid
Medium
Unassigned

Bug Description

[Impact]

* Games using the Unity engine (like KSP) cause gnome-panel to crash, making things like flashback unusable.

[Test Case]

* Run gnome-panel (like in gnome flashback).

* Launch Kerbal Space Program. Not sure whether there's a simpler test case for those without KSP.

[Regression Potential]

* The patch for the bug suggests the possibility of weirdly colored icons where crashes used to occur.

[Other Info]

* libwnck3 (3.14.0-1) allows gnome-panel to continue running in 14.10.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: gnome-panel 1:3.8.0-1ubuntu9
ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
Uname: Linux 3.13.0-17-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Mar 16 23:53:20 2014
ExecutablePath: /usr/bin/gnome-panel
GsettingsChanges:

InstallationDate: Installed on 2014-02-28 (16 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140224)
ProcCmdline: gnome-panel
ProcEnviron:
 LANGUAGE=de_DE
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: gnome-panel
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 _XReply () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 XSync () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libcairo.so.2
Title: gnome-panel crashed with signal 5 in _XReply()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Ron Affeldt (ronsnews) wrote :

StacktraceTop:
 XSync (dpy=0x125ed20, discard=discard@entry=0) at ../../src/Sync.c:44
 sync (display=0x1375200, display=0x1375200) at /build/buildd/cairo-1.13.0~20140204/src/cairo-xlib-surface-shm.c:461
 _cairo_xlib_surface_update_shm (surface=surface@entry=0x1d33c00) at /build/buildd/cairo-1.13.0~20140204/src/cairo-xlib-surface-shm.c:952
 _cairo_xlib_surface_get_shm (surface=surface@entry=0x1d33c00, overwrite=overwrite@entry=0) at /build/buildd/cairo-1.13.0~20140204/src/cairo-xlib-surface-shm.c:1045
 _cairo_xlib_surface_acquire_source_image (abstract_surface=0x1d33c00, image_out=0x7fff95a544e0, image_extra=<optimized out>) at /build/buildd/cairo-1.13.0~20140204/src/cairo-xlib-surface.c:1394

Changed in gnome-panel (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Dmitry Shachnev (mitya57) wrote :

Thanks for your report. Do you know a way to reproduce this issue? Did you get it several times?

The stacktrace is good, but it looks like the error is not in gnome-panel itself, but probably in cairo.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Colombo (jirka678) wrote :

Reported too:
https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/1361848

I don't know if this in cairo, but it is old bug thats been there for a year or more but was not properly reported.

It affect a lot of people and is easy to reproduce. It also happens every time one runs unity-based game.

tags: added: utopic
Andrew Skalski (askalski) wrote :

Is there anything I can do to help troubleshoot this? I purchased Kerbal Space Program "early access" on Steam this morning, and gnome-panel crashes with this error whenever I try to run the game. This does not happen with the KSP demo, only the full version. A web search suggests this may affect any game that uses the Unity engine, not just KSP.

While KSP is running, any attempt to start up gnome-panel results in an immediate crash with this error output:

(gnome-panel:7495): Gdk-ERROR **: The program 'gnome-panel' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 2047 error_code 8 request_code 62 (core protocol) minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap

I use "gnome-session-flashback" as my desktop environment on Ubuntu 14.10. The default desktop environment does not seem to be affected by this (I tried in a Guest session), but even in the Guest session you can still reproduce the error by attempting to execute "gnome-panel" in a terminal window while KSP is running.

If I install libcairo2-dbg and run gnome-panel with the GDK_SYNCHRONIZE environment variable, the crash occurs on line 905 of cairo-1.13.0~20140204/src/cairo-xlib-surface-shm.c when _cairo_xlib_surface_update_shm calls XCopyArea(). According to the XCopyArea docs at www.x.org, "The drawables must have the same root and depth, or a BadMatch error results." Unfortunately I am not versed in X programming, so I don't know what to try next.

1. Remove window-list applet from bottom panel.
2. Try to launch game.

If gnome-panel does not crash then this might be bug in libwnck.

Andrew Skalski (askalski) wrote :

I still get the crash even after removing the window-list applet. I actually just finished building libwnck3-3.4.7 with this line commented out in libwnck/xutils.c in the try_pixmap_and_mask() function, and it successfully prevents the crash. I haven't noticed any side-effects other than some errors logged to my terminal:

  if (mask_surface)
    {
      //XXX cairo_mask_surface (cr, mask_surface, 0, 0);
      cairo_surface_destroy (mask_surface);
    }
  else
    cairo_paint (cr);

*** BUG ***
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug

Then you can try to remove workspace switcher and/or show desktop applets - they are libwnck applets too.

Can you report this bug upstream?
https://bugzilla.gnome.org/enter_bug.cgi?product=libwnck

pixman errors are fixed in git master:
https://git.gnome.org/browse/libwnck/commit/?id=2fc0f058f00daf76c06e485c9d39491513f48345

affects: gnome-panel (Ubuntu) → libwnck3 (Ubuntu)

Well this might be fixed upstream:
https://git.gnome.org/browse/libwnck/commit/?id=5f88636284154e76611012c8a7c7495b9d917bd7

Can you build libwnck from git master and test if error is fixed?

Andrew Skalski (askalski) wrote :

The libwnck git master works perfectly.

I can also confirm that specific commit (5f88636284154e76611012c8a7c7495b9d917bd7) constitues the fix: applying the diff to libwnck3_3.4.7-3.debian fixes the crash; conversely, reverting the diff on git master reintroduces the crash.

Dmitry can you patch libwnck to fix this bug in vivid?

1) https://git.gnome.org/browse/libwnck/commit/?id=5f88636284154e76611012c8a7c7495b9d917bd7
2) https://git.gnome.org/browse/libwnck/commit/?id=eddfee28c623fd7f4a0b6e38373798f96121e445

And maybe backport all patches from vivid to utopic?
1) Fix for this bug
2
) Fix for pixman errors
3) Fix for missing icons

Thank you, you are wonderful!
On 19/11/14 10:01, Andrew Skalski wrote:
> The libwnck git master works perfectly.
>
> I can also confirm that specific commit
> (5f88636284154e76611012c8a7c7495b9d917bd7) constitues the fix: applying
> the diff to libwnck3_3.4.7-3.debian fixes the crash; conversely,
> reverting the diff on git master reintroduces the crash.
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libwnck3 - 3.14.0-1

---------------
libwnck3 (3.14.0-1) experimental; urgency=medium

  * New upstream release.
    - Fixes crash when running some OpenGL apps (LP: #1293252).
  * Drop two patches from the previous upload, applied upstream.
  * Bump Standards-Version to 3.9.6, no changes needed.

 -- Dmitry Shachnev <email address hidden> Mon, 24 Nov 2014 17:01:23 +0300

Changed in libwnck3 (Ubuntu):
status: Confirmed → Fix Released
description: updated
Jackson Doak (noskcaj) on 2015-01-31
description: updated
description: updated
Jackson Doak (noskcaj) on 2015-01-31
description: updated
Jackson Doak (noskcaj) wrote :

A fixed version can be obtained by installing ppa:noskcaj/libwnck3-sru . Can someone please test that?

Jackson Doak (noskcaj) wrote :
Jackson Doak (noskcaj) wrote :
William Leiserson (willtor) wrote :

I tested with your PPA on 14.10, and it works fine (no crash, no funky colors).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libwnck3 (Ubuntu Trusty):
status: New → Confirmed
Changed in libwnck3 (Ubuntu Utopic):
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

I have now uploaded the debdiffs for Trusty and Utopic, thanks Jackson and sorry for the delay.

(This bug was not in the sponsoring queue because the SRU tasks were missing.)

Changed in libwnck3 (Ubuntu Trusty):
status: Confirmed → In Progress
Changed in libwnck3 (Ubuntu Utopic):
status: Confirmed → In Progress

Hello Ron, or anyone else affected,

Accepted libwnck3 into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libwnck3/3.4.7-3ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libwnck3 (Ubuntu Utopic):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Ron, or anyone else affected,

Accepted libwnck3 into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libwnck3/3.4.7-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libwnck3 (Ubuntu Trusty):
status: In Progress → Fix Committed
Juha Erkkilä (juha-erkkila) wrote :

Tested the following packages on Trusty from trusty-proposed:

ii libwnck-3-0:i386 3.4.7-0ubuntu3.1 i386 Window Navigator Construction Kit - runtime files
ii libwnck-3-common 3.4.7-0ubuntu3.1 all Window Navigator Construction Kit - common files

Those fix this bug for us, thank you!

tags: added: verification-done
removed: verification-needed
tags: added: verification-done-trusty verification-needed
removed: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libwnck3 - 3.4.7-0ubuntu3.1

---------------
libwnck3 (3.4.7-0ubuntu3.1) trusty; urgency=medium

  * Add git_support_non-standard_depths_for_icon_pixmaps.patch,
    git_correctly_link_against_libXrender.patch:
    - fixes a crash when using non-standard depths. LP: #1293252
 -- Jackson Doak <email address hidden> Sat, 31 Jan 2015 13:34:28 +1100

Changed in libwnck3 (Ubuntu Trusty):
status: Fix Committed → Fix Released
Dmitry Shachnev (mitya57) wrote :

Can anybody test the fix on Utopic (14.10) please?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers