Ubuntu

Regression in window list applet (wnck-applet) behavior

Reported by Oded Arbel on 2011-01-04
606
This bug affects 120 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
libwnck (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-panel

While using wnck-applet 2.32.1 in Natty, there are some missing features in the window list that were available in Maverick:

1. The buttons for windows in the window list can no longer be rearranged using drag and drop. As the order of the buttons on the window list is quite arbitrary (determined by launch time) having the ability to reorder the buttons in a way that makes spatial sense (for example - by desktop) is an important feature - that no longer works in Natty. (for reference, the original behavior was introduced by the fix to this GNOME bug: https://bugzilla.gnome.org/show_bug.cgi?id=302398 )

2. The buttons for windows in the window list no longer respond for dragging things on top of them by activating the corresponding window. This is a very useful feature that was introduced in GNOME 2 (after being broken by the initial GNOME 2 release) by fixing GNOME bug https://bugzilla.gnome.org/show_bug.cgi?id=80736.

Note - this issue relates to the "Ubuntu Classical Desktop" - I'm pretty sure its not relevant to the new default Unity desktop.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-panel 1:2.32.1-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
Uname: Linux 2.6.37-11-generic x86_64
Architecture: amd64
Date: Tue Jan 4 20:00:42 2011
GConfNonDefault:
 /apps/panel/general/applet_id_list=[applet_10,applet_6,applet_1,fast_user_switch_applet,trash_applet,workspace_switcher,window_list,systray,clock,gnote,applet_4,applet_12,applet_0,applet_2,applet_3,applet_5,applet_7,applet_8]
 /apps/panel/general/object_id_list=[object_6,object_5,object_4,object_2,object_3,object_1,object_0,email_launcher,web_launcher,menu_bar]
 /apps/panel/general/toplevel_id_list=[top_panel,bottom_panel]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100701)
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
SourcePackage: gnome-panel

Oded Arbel (oded-geek) wrote :
joopbraak (joopbraak) wrote :

Agreed, these are both very useful features that should be restored.

Vladimir Bezobiuk (dedoogun) wrote :

Yes, this is really annoying difference since i actively used that. I'm desperate waiting for fixes...

joopbraak (joopbraak) wrote :

Actually, with the latest compiz bug fixes, it works again on my machine.

Using unity-window-decorator.

Benjamin Drung (bdrung) on 2011-03-12
tags: added: regression-release
Vladimir Bezobiuk (dedoogun) wrote :

joopbraak, where do i get latest compiz fixes? there are no such updates to system yet

Oded Arbel (oded-geek) wrote :

With my system fully up to date, and with compiz running, the listed problem still happen.

Benjamin Drung (bdrung) wrote :

Even with the latest compiz version (1:0.9.4-0ubuntu4), the problem still exist.

joopbraak (joopbraak) wrote :

Yes, you are all right, it doesn't work. It seemed to work for a short while (maybe I was using a different window manager then, I can't remember). Anyway, with the latest compiz patches, the problem still exists.

Anders Kaseorg (anders-kaseorg) wrote :

‘compiz --replace’ temporarily fixes the window list drag-and-drop behavior for me. Then ‘gnome-panel --replace’ breaks it again.

Changed in gnome-panel (Ubuntu):
status: New → Confirmed

Also, everything works correctly in metacity, even after ‘gnome-panel --replace’. So this bug happens when gnome-panel is started after compiz.

Jesse Palser (jessepalser) wrote :

I have these problems with Gnome Panel too. These are important features and should be fixed.

Jesse Palser (jessepalser) wrote :

Can someone PLEASE fix this BEFORE Beta 1 - This is the only issue I have with Alpha 3 fully updated to today

kris (chevhq-gmail) wrote :

It affects me too.
The kiwi

joopbraak (joopbraak) wrote :

Only comment if you have any relevant new information please.

Jesse Palser (jessepalser) wrote :

Can someone please explain
what typing "compiz --replace" in terminal does?

It does indeed fixed this terribly annoying bug in panels,
but I don't understand what it does.

When I type the command in terminal, I get this:
----------------------------------------------------------------------------------------------
jezlee@Dell-XPS420-JetFire:~$ compiz --replace
Backend : gconf
Integration : true
Profile : default
Adding plugins
Initializing core options...done
Initializing bailer options...done
Initializing detection options...done
Initializing composite options...done
Initializing opengl options...done
Initializing decor options...done
Initializing place options...done
Initializing blur options...done
Initializing vpswitch options...done
Initializing resize options...done
Initializing gnomecompat options...done
Initializing grid options...done
Initializing move options...done
Initializing animation options...done
Initializing session options...done
Initializing mousepoll options...done
Initializing workarounds options...done
Initializing wall options...done
Initializing wobbly options...done
Initializing expo options...done
Initializing ezoom options...done
Initializing staticswitcher options...done
Initializing fade options...done
Initializing scale options...done
Setting Update "blur_speed"
Setting Update "alpha_blur_match"
Setting Update "filter"
Setting Update "gaussian_radius"
Setting Update "mipmap_lod"
Setting Update "independent_tex"
Setting Update "left_button"
Setting Update "right_button"
Setting Update "run_command_terminal_key"
Setting Update "fullscreen_visual_bell"

Jesse: It restarts Compiz (your window manager). If you need more help, try asking on https://answers.launchpad.net/ or http://ubuntuforums.org/ ; this bug is for discussion by Ubuntu developers.

steubens (steubens) wrote :

this is fixed for me as of the beta. advise on how to change status

No, I just tested with all current updates; this is not fixed.

(Keep in mind that running ‘compiz --replace’ is a workaround that gets it working temporarily, but that does not mean that it’s fixed.)

(Similarly, if compiz _crashes_, it will automatically restart itself, which also gets this working temporarily. This obviously also doesn’t mean that it’s fixed.)

Xhacker Liu (xhacker) wrote :

That workaround works for me too, thanks.

And there is another issue...
When you move a window to another workspace by right click the window title in the window list, it still appears in current workspace's window list. Only after you repeat this operation the window disappears in the list.

Jesse Palser (jessepalser) wrote :

There is a better temporary fix for this issue.
Just right-click panel then pick Properties->Background
and quickly change it and change it back.
(this seems to reload the panel)

I'm still hoping a proper fix can be implemented before final release!

Still in the final release with no fix. Thankfully the workaround in #21 isn't too onerous.

Peshko R. (peshko-us) wrote :

I agree that the comment should be kept for relevant information. Si since the bug was opened in the alpha 3 version, can somebody update the status and provide timeline. IMHO this is the most relevant information for everyone waiting on the bug to be fixed. Surprisingly, Nutty was officially released with still bugs in it ?!?!?!

steubens (steubens) wrote :

sebastien i love you! but this bug doesn't apply just to wnck-applet, but the entire panel; create a launcher and try dropping a file on it when the window switcher doesn't work, it's the same thing, could the title or the initial message be amended to include this? you've marked the other bugs that actually hilight the problem as a duplicate of this one, which is just one of the symptoms (the one that catches me all the time is dropping things on icons, the window switcher is just a small annoyance)

jbirdjavi (jbirdjavi) wrote :

The comment #21 workaround doesn't work for me.

I tried using Unity for a few days but after the 3rd lockup I went back to classic. Sadly it's not as good as it was...

Florentin (elmophp) wrote :

A temporary fix that works for me is to right-click the panel and click Properties, then select and deselect "Show hide buttons"

shorty (matthias.kurz) wrote :

Thanks Florentin! This works for me as well!

For me it doesn't.

axeoth (axeoth) wrote :

@Sebastian Bugiu
Neither for me.

axeoth (axeoth) wrote :

However, workaround presented in #21 seems to work for me.

lores (lores000) wrote :

Same here. #26 works as a tmp fix.

rafael (bomber-man) wrote :

Workaround #21 doesn't seem to work here, neither #26
But checking and unchecking "Expand" does work

Fabrizio Marcolini (fmarcoz) wrote :

Checking and unchecking "Expand" works for me.

limpangel (limpangel) wrote :

#26 works as a temp fix. Thanks Florentin.

Thanks Florentin (#26), that worked for me, too.

lores (lores000) wrote :

Also, changing the size to another value and back to the original is a tmp fix.

In my case, when the bug is in effect, the "Show Desktop" icon is as small as if the panel had the size of 21 px, although it is 24 px. Changing the size to e. g. 23 px and back corrects this.

Michał Gołębiowski (mgol) wrote :

@lores
That's true - the "show desktop" icon is smaller, I haven't noticed it before...

lores: So does your show desktop icon change it size from time to time from small to big? I ask because I have noticed the same bug on my machine, it boots small but after a while gets big, after changing the resolution by entering a game for example. I need to test this more before I get a definite answer but this is how I see it until now.

lores (lores000) wrote :

@Sebastian Bugiu: the icon reverts to the correct size as soon as I do sth. to my panel in order to work around the bug (e. g. change it's size to 25 px and back to 24 px; check and uncheck "show hide buttons" etc.). So I think your behaviour could very well be caused by 3rd factors, e. g. games/resolution.

Charalampos (charpour) wrote :

Happened to me too.. please fix it

MyTh (stiffmaster88) wrote :

Any news here? Or isn't it interesting because of Unity's priority?

lores (lores000) wrote :

Too bad there seems to be no progress whatsoever...

Fabrizio Marcolini (fmarcoz) wrote :

I can see my progress: abandon Ubuntu and install Fedora 15 with Gnome 3 in 9 days. Probably much better option than the choice of Unity (I don't like it plus it's full of bugs) or Ubuntu Classic (seemingly deprecated).

Yeah...right now Ubuntu lacks a good interface. The old one is full of bugs and the new one is unusable. Great progress! But you can still try KDE and xfce....

xtknight (xt-knight) wrote :

This is a core compiz problem in Natty (not even a problem with the window-decorator) from what I can tell.

I was using a Natty VM and selectively replaced some components from Maverick's compiz. Here are the results.

Natty Compiz and Natty Decorator: this bug.
Natty Compiz and Maverick Decorator: segfault.
Maverick Compiz and Maverick Decorator: perfect.
Maverick Compiz and Natty Decorator: works awful, but does not exhibit this particular bug.

I looked at libwnck, metacity, and gnome-panel too, including diffing the source code between the two, but when I tried the different compiz packages I was convinced that these three aforementioned packages were not at fault. I didn't even think metacity was used at all during compiz, but I just wanted to make sure.

My conclusion is that something in the core of Natty's compiz is an issue. Doing a diff between the two is difficult because it looks like they moved from C to C++ in at least some of the source code!

I'm not so concerned about correlation, causation, and interaction between all these problems. As far as I'm concerned someone who updated compiz broke it and caused a regression and that's about it. Don't make major changes unless it's a major version update. I will try to limit it down to a specific commit but right now that's looking difficult and I might just throw in the towel and install Maverick's compiz back on my Natty system because there are definitely other compiz problems with this version, too.

Rachid (rachidbm) on 2011-05-18
summary: - regression in window list applet (wnck-applet) behavior
+ Regression in window list applet (wnck-applet) behavior
Bogdan Yurov (nick4fake) wrote :

I hate such behaviour in windows (impossibility of dragging icons on taskbar). It was extreemly convenient to rearrange buttons as you want.

Changed in gnome-panel (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
rafael (bomber-man) wrote :

this bug doesn't seem to affect Ubutu Classic with no effects here

joopbraak (joopbraak) wrote :

It effects Ubuntu classic if you use Compiz instead of Metacity.

affects: gnome-panel (Ubuntu) → libwnck (Ubuntu)
Flair (aurelz) wrote :

I am also experiencing this bug.

Workaround suggested Florentin wrote on 2011-05-03: #26 worked.

Thanks.

MyTh (stiffmaster88) wrote :

#26 thanks florentin, this also works it around here! :)

Yeah. #26 works, also resize the panel, also change the panel background, etc

But come on, those are not a solutions...!!
Are there fixes to this?

Matthew (moose-b) wrote :

This bug affects me. The only workaround that works for me is the changing-background one. Something else to add that no one else seems to have noticed: The window buttons automatically rearrange themselves in order of activity - if you use a window more, its button moves rightwards in the list. This is not caused by a Compiz plugin - I disabled plugins in turn and still experienced the behaviour. As a side note, the trigger for the workaround stopping working is the buttons rearranging themselves...

mxyzptlk (mxyzptlk) wrote :

Actually, you can add compiz --replace to your Startup Applications and not have to think about this bug until it gets fixed. That's a trick I had to use in past releases, and it still works today. I can drag and drop in Ubuntu 11.04 Classic Desktop without a second thought -- and it was one of the things that was holding me back, because I use that feature quite a bit.

Go to:

System > Preferences > Startup Applications

Click on Add

In the dialog box that pops up,
 ?field.comment=Actually, you can add compiz --replace to your Startup Applications and not have to think about this bug until it gets fixed. That's a trick I had to use in past releases, and it still works today. I can drag and drop in Ubuntu 11.04 Classic Desktop without a second thought -- and it was one of the things that was holding me back, because I use that feature quite a bit.

Go to:

System > Preferences > Startup Applications

Click on Add

In the dialog box that pops up, add the following (see the screenshot); the most important bit is having compiz --replace under the command section -- the can write whatever gibberish you choose for the rest:

Name: Compiz Fix
Command: compiz --replace
Comment: Fixes gnome-panel drag-and-drop

mxyzptlk (mxyzptlk) wrote :

(I should have noted that the compiz --replace startup fix is if you're using the classic Gnome desktop, and not Unity.)

lores (lores000) wrote :

Note that "compiz --replace" does not "fix" the other issue with gnome-panel manifesting in the icons' being very small (notably the "show desktop" icon). This can be "fixed" by changing the size of the panel back and forth (e. g. from 24 px to 25 px and back to 24 px).

alienn (spamme-ubuntu) wrote :

For me the tmp fix was #36. Is there any progress in this case?

Nech (gerard-guadall) wrote :

Today I work well!

Lonco (nachomezzadra-gmail) wrote :

Even though #26 works as a work-around, #53 worked like a charm! I like #53 better cause with #26 you have to do it every time you reboot..

I've had to use #53 workaround for compiz not starting ever since 10.4. It doesn't do anything regarding the gnome-panel bug for me, so I guess there's something else going on.

dhenry (tfc-duke) wrote :

Seems to be fixed with latest updates (natty-proposed repository enabled).

ponteaus (dean-l-lewis) wrote :

I'm suffering the same bug. However, I noticed that minimizing and maximizing windows changes the list order. To demonstrate this, click the show-desktop button, then restore the left-most window in the list; it will move to the right-most position! As with others, 'compiz --replace' fixes the issue. Is anyone else seeing this reordering behavior? To me, this is even worse than the original bug because the list becomes disorganized even if I carefully open all my windows in the order I want them.

JKL (jkl102001) wrote :

I can confirm that this is fixed in natty-proposed. Specifically, upgrading compiz-core fixes it. It seems likely that the fix for bug 767095 also fixes this one.

Information about installing packages from the "proposed" set is below.

https://wiki.ubuntu.com/Testing/EnableProposed

Changed in compiz (Ubuntu):
status: New → Fix Committed

I can confirm that I too have recently observed windows deliberately moving to the right-most position and that it had something to do with minimization. I could not reproduce the bug according to your description at this moment, though.

steubens (steubens) wrote :

still dunno why this is targeting libwnck; it's a change in drag behaviour with the wm, dragging stuff onto quick launch icons are also broken when this behaviour is observed, try it

JKL (jkl102001) wrote :

Please try upgrading compiz-core from natty-proposed. That should fix quick launch icons also.

Changed in libwnck (Ubuntu):
status: Triaged → Invalid
lores (lores000) wrote :

The "fix" in natty-proposed doesn't actually fix the problem with small (as if the panel size were set to 24 px; corrected after toggling the size forth and back) icons (v. #55).

Changed in compiz (Ubuntu):
status: Fix Committed → Confirmed

The last Compiz update fix the problem!

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
lores (lores000) wrote :

Not entirely (In my case) - the fix doesn't solve the problem with small icons (as if the panel size were set to 21 px; corrected after toggling the size forth and back) (see #55).

steubens (steubens) wrote :

lores: you might try and file another bug for that, this one is already pretty messy and that's a separate thing, the original problem (though the title has been changed) is attributed to compiz and does appear to be fixed here.

I still have a bug where when I open a window maximized I still need to focus it so it gets right in the center of the screen. It's as if it starts 2-3 pixels to the right or left (on the other side I get white lines or garbage) and only when I refocus i get the window to move to center position and take the whole screen correctly. If you take a look at the attachment you will see two white lines on the left and right of the window going up to the tab menu. Should I report a new bug or is it still in this regression?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers