Ubuntu

workspace-switcher needs to work with dualhead setup

Reported by coburn ingram on 2007-04-29
56
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libwnck
New
Medium
libwnck (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-panel

I'm using U-6.06 and a Nvidia FX5200 card with a couple of digital VGA monitors, which I just got configured.

In /etc/X11/xorg.conf I have separate entries for each output, monitor, and screen, and Xinerama is ##OFF##.

I don't want to use Xinerama or Twinview as they are Not Ready.

Flaws like distorted wallpaper, stretched panels, bad video, and stumbling drunk apps that can't decide where or how big to open make using either of those uncomfortable for me. But I really like the straightforward discrete-monitor setup. It Just Works. The only thing you can't do is drag windows across the two screens.

Is it possible to configure the workspace-switcher applet to recognize the dual monitors, and allow moving of apps from a workspace on one monitor to another workspace on the other?

Thanks,

Coby

Sebastien Bacher (seb128) wrote :

Thank you for your bug. To confirm by somebody with a similar configuration, likely an upstream bug

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Sami Nybacka (sapeny) wrote :

While above actually seems to be feature request (allow transport windows to one display/screen to another), here's bug report of current Ubuntu Gutsy Workspace Switcher with dual screen setup.

Workspace Switcher 2.20.0.1 on most current 7.10.

I have dual screen setup (no xinerama or similar). Screen 0 is laptop builtin screen. Screen 1 is external LCD. I have Workspace Switcher (WS) with 12 workspaces and 3 rows on both screen's gnome-panels.

Problem: screen1 WS is showing windows from screen0, and acts like it is attached to screen0: when using mouse or keyboard shortcuts to switch workspace on screen1, it changes workspace on screen0.

When I remove WS from screen1 gnome-panel and add it again, everything works fine on both screens/WS's. But after a logout/login, screen1 WS is again attached to screen0.

This happens also on another computer at work. Only difference is that there primary screen's WS works, but secondary screen's WS doesn't. And again: when I remove WS from secondary screen's gnome-panel and add it again, everything works ok on both screens, until the next logout.

It seems that both screen's Workspace Switchers work normally if there's only 1 row of workspaces. When using for example 3 rows, screen0 or screen1 WS starts following the other (wrong) screen (on next login).

Previous Ubuntu did not have this problem.

Pedro Villavicencio (pedro) wrote :

Is this still an issue for you with Hardy? May you forward it upstream at bugzilla.gnome.org? For forwarding instructions please have a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; leaving this as incomplete until it gets forwarded, thanks for your help!.

Changed in gnome-panel:
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to 'New'. Thanks again!

Changed in gnome-panel:
status: Incomplete → Invalid
Andruk (andruk) wrote :

I would like to report that workspace-switcher gets messed up with two monitors running separate X servers (Xinerama is off). Whenever I change the number of workspaces on the second monitor (X server 1), the workspaces on the first monitor (X server 0) change! Therefore, the number of workspaces on the second X server (by default is 2) is unchangeable.

I have reported upstream to the Gnome devs here: http://bugzilla.gnome.org/show_bug.cgi?id=552744

I am running 8.04, with Compiz, using nvidia-settings to setup the two monitors on my GeForce FX 5500.

If you need anymore information, don't hesitate to ask.

zurgutt (zurgutt) wrote :

In addition to my report on #139676

The behaviour described there happened when Visual Effects were set to Normal.

With visual effects set to none the behaviour is same as in previous versions of ubuntu: after starting gnome on dual screen the switcher on first screen works correctly with 3x2 matrix but switcher on screen 2 shows 1x6 matrix and actually controls screen1.

When switcher on screen 2 is deleted and re-added, it will start controlling screen 2, however second row must be added each time also from rightclick-preferences to get 3x2 matrix. There changes are fully lost during X restart, forcing re-adding switcher on screen 2 every time. Quite annoying. Is there a persistent manual workaround perhaps?

zurgutt (zurgutt) wrote :

I have verified it to be valid bug and attached relevant screenshots.

Changed in gnome-panel:
status: Invalid → Confirmed
Changed in gnome-panel:
status: Confirmed → Triaged

I had the same workspace-switcher problem on an 8.04 install and it still exists after upgrading to 8.10. From what I can see, there is a gconf config entry for "workspace_switcher_screen0" but not for "workspace_switcher_screen1". Other applets have separate config entries for each screen.

Hi Mark

Im not familiar with gconf. Can this be fixed somehow by creating
setting, without modifying program?

cheers, zrg

2008/11/1 Mark Nysen <email address hidden>:
> I had the same workspace-switcher problem on an 8.04 install and it
> still exists after upgrading to 8.10. From what I can see, there is a
> gconf config entry for "workspace_switcher_screen0" but not for
> "workspace_switcher_screen1". Other applets have separate config
> entries for each screen.
>
> --
> workspace-switcher needs to work with dualhead setup
> https://bugs.launchpad.net/bugs/110899
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Imre Gergely (cemc) wrote :

I can't really add anything new, just confirm that on 8.04 with a Nvidia 7600GS, two separate screens on two monitors.

There is one other thing I observed. It seems when there are two workspace switchers with separate configs (for example one showing the workspaces in two rows, and the other one in one row), it seems to be working just fine. Only when the two configurations are the same it gets messed up (ie. the switcher on screen0 controls everything, and the other switcher controls nothing).

I have set up some shortcuts to change the workspaces (like Ctrl+1, Ctrl+2...), so i'm actually not clicking on any switcher, i'm just using the shortcuts, it still has the same problem described above.

I looked at gconf, and did a search for workspace_switcher but i can't find anything with screen0 OR screen1, just plain workspace_switcher. I tried removing and re-adding both switchers, but the same thing happens.

Peter Adolphs (futzilogik) wrote :

Are the later comments refering to the same bug as the original post? The original bug description is not very clear. Is it ok to update it so it only includes the description of the actual bug all the comments seem to refer to (workspace switcher/libwnck is not able to handle dual head setups)? The feature request ("allow moving of apps from a workspace on one monitor to another workspace on the other") should be filed separately.

zurgutt (zurgutt) wrote :

Yes, its about the very annoying workspace switching bug. I have to delete and recreate them every time computer is started. Must be some very trivial bug..

Moving apps from one screen to other is something else entirely and probably too hard anyhow as they run on separate X servers.

Peter Adolphs (futzilogik) wrote :

@zurgutt: Ok, but reading it again, I think the original post here is actually really only about this very feature request, namely, using the Workspace Switcher to display both screens and use it to move applications from one screen to another.

@Andruk: The number of workspaces is a general window manager setting. I agree it's confusing (see also http://bugzilla.gnome.org/show_bug.cgi?id=441658), but I think it's a separate issue for which you should open a separate Launchpad bug report if there is none already.

I suggest to reopen one of the duplicates, e.g. bug #139676 or bug #152091, for the issue that the workspace switcher on screen :1 is displaying screen :0 because it's a different issue. I've also created a new upstream bug for this: http://bugzilla.gnome.org/show_bug.cgi?id=563974 which should be linked with the reopened bug #139676 or bug #152091. As mentioned above, I also think the upstream bug gnome-bugs #552744 linked here is about something else (I haven't seen an upstream bug for the feature request). And this bug here could be closed, if noone has an interest in the feature requested.

Changed in libwnck:
status: Unknown → New
Changed in libwnck:
status: New → Invalid
Changed in libwnck:
status: Invalid → New
Vincent Gerris (vgerris) wrote :

Might this be related to the glibc bug?
http://bugzilla.gnome.org/show_bug.cgi?id=580103

A patch is supplied at the bottom.
I do not know how to get it applied to current 9.04 package, anyone?

Changed in libwnck:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.