wibble CMake tests fail in LD_LIBRARY_PATH setting command

Bug #667952 reported by Todd Vierling on 2010-10-28
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libwibble (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

When trying to build an updated libept, I found that the test step did this:

cd "/build/buildd/libept-1.0.4~duh1/obj-x86_64-linux-gnu/ept" && "LD_LIBRARY_PATH=/build/buildd/libept-1.0.4~duh1/obj-x86_64-linux-gnu/ept" /build/buildd/libept-1.0.4~duh1/obj-x86_64-linux-gnu/ept/ept-test
/bin/sh: LD_LIBRARY_PATH=/build/buildd/libept-1.0.4~duh1/obj-x86_64-linux-gnu/ept: not found

The problem is that the syntax for setting an env variable here is incorrect -- the quotes make sh assume this is a command, not a pre-command variable setting.

This has been fixed in libwibble 0.1.26, but attached to this bug is a fix specifically for only this issue culled from that diff.

Todd Vierling (duh) wrote :
Todd Vierling (duh) wrote :

Bah, forgot to mention this is for Lucid, which has libwibble-dev 0.1.24.

tags: added: patch
Daniel T Chen (crimsun) on 2011-07-27
Changed in libwibble (Ubuntu Oneiric):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in libwibble (Ubuntu Lucid):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers