Hardy projectM doesn't work

Bug #193968 reported by sibidiba on 2008-02-21
54
This bug affects 14 people
Affects Status Importance Assigned to Milestone
projectM
Fix Released
Wishlist
libvisual-projectm (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libvisual-projectm

On current Hardy projectM visualization is broken.

If I start the projectM visualization as a libvisual plugin (in amarok or audacious), then I either get a blank white or black projectm window, or just with a very basic effect (e.g. the current song's title appears).

There are no more effects nor visualization. There are also no configuration options available: the F1 menu appears, but for example if I press F4 to change the rendering settings, nothing happens.

If I put it to full screen and back, the screen resolution isn't reset, the display gets corrupted.

H.i.M (hir-i-mogul-gmail) wrote :

same problem here on hardy.

visualization-window disappears after selecting projectm in libvisuals after 1 second.

Changed in libvisual-projectm:
status: New → Confirmed
Miguel Yarza (miguel-yarza) wrote :
Download full text (3.8 KiB)

I get a white projectm window in amarok and mythmusic in gutsy backports with :
libvisual-projectm 1.0-1~gutsy1
libprojectm1 1.01-3~gutsy1

I don't know if it is related but in mythmusic if projectm is the default visualization plugin I get the white window, but if I cycle the plugins, when projectm is selected again I get a floating point exception with the following trace:

Program received signal SIGFPE, Arithmetic exception.
[Switching to Thread -1261446304 (LWP 12313)]
0xaad99f29 in SOIL_internal_create_OGL_texture () from /usr/lib/libprojectM.so.1
(gdb) bt
#0 0xaad99f29 in SOIL_internal_create_OGL_texture () from /usr/lib/libprojectM.so.1
#1 0xaad98b90 in SOIL_load_OGL_texture_from_memory () from /usr/lib/libprojectM.so.1
#2 0xaad951ea in TextureManager::TextureManager () from /usr/lib/libprojectM.so.1
#3 0xaad8ba7c in Renderer::Renderer () from /usr/lib/libprojectM.so.1
#4 0xaad58791 in projectM::projectM_init () from /usr/lib/libprojectM.so.1
#5 0xaad5a47c in projectM::readConfig () from /usr/lib/libprojectM.so.1
#6 0xaad5b456 in projectM::projectM () from /usr/lib/libprojectM.so.1
#7 0xaafa793b in lv_projectm_init () from /usr/lib/libvisual-0.4/actor/libprojectM_libvisual.so
#8 0xb244c6ac in visual_plugin_realize () from /usr/lib/libvisual-0.4.so.0
#9 0xb2446cd8 in visual_actor_realize () from /usr/lib/libvisual-0.4.so.0
#10 0xb244ac1d in visual_bin_realize () from /usr/lib/libvisual-0.4.so.0
#11 0xafab04b0 in LibVisualPlugin::switchToPlugin () from /usr/lib/mythtv/plugins/libmythmusic.so
#12 0xafab169e in LibVisualPlugin::LibVisualPlugin () from /usr/lib/mythtv/plugins/libmythmusic.so
#13 0xafab1af8 in LibVisualFactory::create () from /usr/lib/mythtv/plugins/libmythmusic.so
#14 0xaf9d971a in MainVisual::setVisual () from /usr/lib/mythtv/plugins/libmythmusic.so
#15 0xaf9f4fb2 in PlaybackBoxMusic::CycleVisualizer () from /usr/lib/mythtv/plugins/libmythmusic.so
#16 0xaf9faeab in PlaybackBoxMusic::keyPressEvent () from /usr/lib/mythtv/plugins/libmythmusic.so
#17 0xb62838a3 in QWidget::event () from /usr/lib/libqt-mt.so.3
#18 0xb61e3af0 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#19 0xb61e5ac0 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#20 0xb617627d in QApplication::sendSpontaneousEvent () from /usr/lib/libqt-mt.so.3
#21 0xb6166c69 in QETWidget::translateKeyEvent () from /usr/lib/libqt-mt.so.3
#22 0xb617304f in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#23 0xb618a1a4 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#24 0xb61fe1ce in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#25 0xb6bead27 in MythDialog::exec () from /usr/lib/libmyth-0.21.so.0
#26 0xaf9d0022 in startPlayback () from /usr/lib/mythtv/plugins/libmythmusic.so
#27 0xaf9d213a in runMusicPlayback () from /usr/lib/mythtv/plugins/libmythmusic.so
#28 0xb6a53775 in MythMainWindow::ExitToMainMenu () from /usr/lib/libmythui-0.21.so.0
#29 0xb6a53c56 in MythMainWindow::customEvent () from /usr/lib/libmythui-0.21.so.0
#30 0xb624bf95 in QObject::event () from /usr/lib/libqt-mt.so.3
#31 0xb62835b3 in QWidget::event () from /usr/lib/libqt-mt.so.3
#32 0xb61e3af0 in QApplication::internalNotify () from /usr/li...

Read more...

dixonstalbert (dixonjnk) wrote :

Hello

ProjectM from Hardy repository runs stable but "achingly slow" on pentiumM with Integrated Intel 915G graphics. Cannot get it past 2 fps, cpu runs at 100%, whole system slows down but is stable; all function keys work properly. Changing .projectM/config.inp doesnt have any effect...

ProjectM in Gutsy Backports runs perfectly called from Amarok on AthlonXP desktop with Nvidia FX5200 graphics. I got 35 fps and cpu stays at <30% usage running on dual monitors and didnt have to change any config settings!

See https://bugs.launchpad.net/bugs/177492. ProjectM appears to be sensitive to what hardware/graphics driver you are using.

I can't find projectM listed as a visualization in Rhythmbox and cannot manually start projectM from the command line.
Running libvisual-projectm 1.0-1, libprojectm1 1.05, rhythmbox 0.11.5 on Hardy AMD64.

The repository version of projectM is completely outdated anyway. Version 1.1 has been released, and 1.2 is coming up: http://projectm.sourceforge.net/ - So somebody should probably work on getting 1.1/1.2 working instead of messing around with 1.0/1.01/1.02.

projectM seems like the much needed proper audio visualization solution for Linux. An update of this would really raise the level of multimedia experience on Ubuntu.

It actually seems like the latest versions are compatible with Ubuntu: http://ubuntuforums.org/showthread.php?t=749793

JoePub (joepubber) wrote :

I have ran through this in gdb myself which had the same stack trace. The error was because a call to glGetintegerv asking for GL_MAX_TEXTURE_SIZE was returning 0 which caused a floating point exception when trying to calculate the texture width. I added a check to the source code inside SOIL.c to see if it was 0 and if it was forced it to 4096 which worked (which seems to be a common max texture size), although I am not sure of the proper solution to this.

This was with the latest projectM 1.1, the funny thing is projectM-test seems to work fine, which I believe uses the same engine code

drdaz (drdaz7) wrote :

JoePub: I would be interested in seeing what you've done; I have added a check in SOIL.c and set the variable max_supported_size to 4096. Unfortunately, it doesn't change the outcome (at least not in the mythmusic context - I've not experienced problems elsewhere).

That said, I'm not a C programmer, and I'm not familiar with the code I'm looking at, so I'd really like to see what you did :-).

Changed in projectm:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Changed in projectm:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.