libvirtd crashes immediately after starting when udev_log=debug

Bug #968930 reported by Ivan Nestlerode on 2012-03-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libvirt (Ubuntu)
Medium
Unassigned

Bug Description

Starting some time in February libvirtd started crashing immediately at startup. This is not in response to running any specific VM; it is just starting up at boot time and crashing. I noticed this when I went to run virt-manager and it said that libvirtd was not running. Attempts to start libvirtd manually also crash. I did not make any specific change to my machine to cause this (it probably got automatic updates from Ubuntu and nothing else).

I don't remember the exact date that this started happening, but my VM images have modification time stamps of February 2, 2012. So it was some time after that.

I tried downgrading python-libvirt, libvirt-bin, and libvirt0 back to 0.9.2-4ubuntu15.1 but this did not fix the problem. This is on a Lenovo ThinkPad W520 if that is important. I will attach libvirtd.log.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libvirt-bin 0.9.2-4ubuntu15.2
ProcVersionSignature: Ubuntu 3.0.0-17.30-generic 3.0.22
Uname: Linux 3.0.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Fri Mar 30 02:04:24 2012
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libvirt
UpgradeStatus: No upgrade log present (probably fresh install)

Ivan Nestlerode (inestlerode) wrote :
Changed in libvirt (Ubuntu):
importance: Undecided → High
Serge Hallyn (serge-hallyn) wrote :

Hi,

in the log file I see:

22:50:10.419: 6618: error : udev_set_log_fn:336 : custom logging function 0x7fffb6001958 registered

Caught Segmentation violation dumping internal log buffer:

Could you please post your /etc/libvirt/libvirtd.conf file? Could you post the output of 'dpkg -l | grep udev'?

Changed in libvirt (Ubuntu):
status: New → Incomplete
Ivan Nestlerode (inestlerode) wrote :

I don't think I have ever modified anything in /etc/libvirt/libvirtd.conf. Here it is with comments and blank lines removed:

$ grep -v -E -e '^#' -e '^$' /etc/libvirt/libvirtd.conf
unix_sock_group = "libvirtd"
unix_sock_rw_perms = "0770"
auth_unix_ro = "none"
auth_unix_rw = "none"

Here is the version of udev related packages (minus package comments that caused crazy looking formatting):
$ dpkg -l|grep udev
ii libgudev-1.0-0 1:173-0ubuntu4.2
ii libudev0 173-0ubuntu4.2
ii python-pyudev 0.12-1
ii system-config-printer-udev 1.3.6+20110831-0ubuntu9.4
ii udev 173-0ubuntu4.2

In terms of the fact that this started in February this may have been when I modified my udev configuration (/etc/udev.conf) to turn on debug logging. I haven't filed the bug yet in Launchpad, but I am chasing down what seems to be a bug in udev that makes my machine hang about half of the time when it boots. I was trying to gather information to file that bug report, but maybe I will attempt to undo that if it is related to this libvirtd crash (I have no ability to use any of my VMs currently which is very bad).

Here is /etc/udev.conf:
# The initial syslog(3) priority: "err", "info", "debug" or its
# numerical equivalent. For runtime debugging, the daemons internal
# state can be changed with: "udevadm control --log-priority=<value>".
udev_log="debug"

Serge Hallyn (serge-hallyn) wrote :

Thanks for that info. Confirmed! When I set udev_log=debug, libvirt crashes immediately, even uptodate upstream git.

Dropping priority to medium because there is a workaround.

Changed in libvirt (Ubuntu):
status: Incomplete → Confirmed
importance: High → Medium
summary: - libvirtd crashes immediately after starting
+ libvirtd crashes immediately after starting when udev_log=debug
Serge Hallyn (serge-hallyn) wrote :

Seems safe to assume this must be fixed by now, please ping if it is still happening.

Changed in libvirt (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers