internal error creation of non-raw images is not supported without qemu-img

Bug #368084 reported by Jamin W. Collins on 2009-04-27
54
This bug affects 7 people
Affects Status Importance Assigned to Milestone
libvirt (Ubuntu)
Medium
Unassigned
Declined for Jaunty by Mathias Gug
Declined for Karmic by Mathias Gug

Bug Description

Binary package hint: virt-manager

Attempting to create a qcow2 20G disk for a VM inside a defined libvirt storage pool results in the following:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/createvol.py", line 190, in _async_vol_create
    self.vol.install(meter=meter)
  File "/usr/lib/python2.6/dist-packages/virtinst/Storage.py", line 904, in install
    (self.name, str(e)))
RuntimeError: Couldn't create storage volume 'winxp.img': 'internal error creation of non-raw images is not supported without qemu-img'

$ which qemu-img
/usr/bin/qemu-img

$ dpkg -S /usr/bin/qemu-img
qemu: /usr/bin/qemu-img

$ apt-cache policy qemu
qemu:
  Installed: 0.10.0-1ubuntu1
  Candidate: 0.10.0-1ubuntu1
  Version table:
 *** 0.10.0-1ubuntu1 0
        500 http://us.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia ath_hal
Package: virt-manager 0.6.1-1ubuntu4 [modified: usr/share/virt-manager/virtManager/details.py]
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: virt-manager
Uname: Linux 2.6.28-11-generic x86_64

Jamin W. Collins (jcollins) wrote :
Brazen (jdinkel) wrote :

I'm having this problem also, on an amd64 system. I have qemu-img available, plus it should also be able to use kvm-img.

Jamin W. Collins (jcollins) wrote :

Based on Brazen's findings I rebuilt with qemu installed, this fixes the problem I'm seeing. The attached debdiff should accomplish this.

Brian Murray (brian-murray) wrote :

Jamin - your debdiff is showing package version 0.6.1-1ubuntu6 however I don't see ubuntu5 anywhere. Additionally, if you'd want this to be an SRU the package version should actually be 0.6.1-1ubuntu4.1 so if ubuntu5 were to appear in Karmic it would supercede this package version.

Jamin W. Collins (jcollins) wrote :

The debdiff showed 0.6.1-0ubuntu6, not 0.6.1-1ubuntu6.

Not sure how you're not finding 0.6.1-0ubuntu5 as it's the current version in Jaunty.
https://launchpad.net/ubuntu/+source/libvirt/0.6.1-0ubuntu5

I've altered the number in the debdiff to be 0.6.1-0ubuntu5.1 and attached.

Doug Goldstein (cardoe) wrote :

The issue is that several distros install the KVM patched version of qemu-img as kvm-img. The upstream package has a hardcoded build time check for qemu-img so unless you install qemu, it will error for you on those distros. In Gentoo, we handled this with a patch that makes the check run-time and looks for kvm-img (KVM), qemu-img (QEMU) and qcow-create (Xen). The patch will be merged upstream in libvirt-0.6.5. I urge the maintainers to merge something like this for Jaunty.

Brazen (jdinkel) wrote :

So now why hasn't this been fixed?

Aptitude says I have libvirt-bin version 0.6.1-0ubuntu5.1, but I still get this error :(

Brazen (jdinkel) wrote :

This bug also appears to be in Karmic, libvirt-bin version 0.6.4-1ubuntu2

Tim 'Shaggy' Bielawa (tbielawa) wrote :

virt-manager is not at fault

affects: virt-manager (Ubuntu) → libvirt (Ubuntu)
Thierry Carrez (ttx) on 2010-01-13
Changed in libvirt (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Dustin Kirkland  (kirkland) wrote :

Tested this in Lucid, looks to be fixed.

Changed in libvirt (Ubuntu):
status: Confirmed → Fix Released
Dustin Kirkland  (kirkland) wrote :

Please reopen if you can recreate this.

Dustin Kirkland  (kirkland) wrote :

Confirmed qemu-kvm is now in the build deps.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers