Empty NUMA topology in machines with high number of CPUs

Bug #1915811 reported by Victor Tapia on 2021-02-16
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
Stein
Undecided
Unassigned
Train
Undecided
Unassigned
Ussuri
Undecided
Unassigned
libvirt (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned

Bug Description

[impact]

libvirt fails to populate its NUMA topology when the machine has a large number of CPUs assigned to a single node. This happens when the number of CPUs fills the bitmask (all to one), hitting a workaround introduced to build the NUMA topology on machines that have non contiguous node ids. This has been already fixed upstream in the commits listed below.

[scope]

The fix is needed for Xenial, Bionic, Focal and Groovy.

It's fixed upstream with commits 24d7d85208 and 551fb778f5 which are included in v6.8, so both are already in hirsute.

[test case]

On a machine like the EPYC 7702P, after setting the NUMA config to NPS1 (single node per processor), or just a VM with 128 CPUs, "virsh capabilities" does not show the NUMA topology:

# virsh capabilities | xmllint --xpath '/capabilities/host/topology' -

<topology>
      <cells num="0">
      </cells>
    </topology>

When it should show (edited to shorten the description):

<topology>
      <cells num="1">
        <cell id="0">
          <memory unit="KiB">5027820</memory>
          <pages unit="KiB" size="4">1256955</pages>
          <pages unit="KiB" size="2048">0</pages>
          <distances>
            <sibling id="0" value="10"/>
          </distances>
          <cpus num="128">
            <cpu id="0" socket_id="0" core_id="0" siblings="0"/>
            ....
            <cpu id="127" socket_id="127" core_id="0" siblings="127"/>
          </cpus>
        </cell>
      </cells>
    </topology>

[Where problems could occur]

Any regression would likely involve a misconstruction of the NUMA topology, in particular for machines with non contiguous node ids.

Thanks for the report. I've subscribed Christian, who will look into this issue when possible.

Changed in libvirt (Ubuntu):
status: New → Fix Released
tags: added: server-next

To be clear on next steps, so I asked Victor and he said he'll drive this to completion.
But feel free to ping if you need me ...

tags: removed: server-next
Victor Tapia (vtapia) wrote :
Victor Tapia (vtapia) wrote :
Victor Tapia (vtapia) wrote :
Victor Tapia (vtapia) wrote :
Victor Tapia (vtapia) wrote :

Hello Victor, or anyone else affected,

Accepted libvirt into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libvirt/6.0.0-0ubuntu8.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libvirt (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed verification-needed-focal
Changed in libvirt (Ubuntu Groovy):
status: New → Fix Committed
tags: added: verification-needed-groovy
Timo Aaltonen (tjaalton) wrote :

Hello Victor, or anyone else affected,

Accepted libvirt into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libvirt/6.6.0-1ubuntu3.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Timo Aaltonen (tjaalton) wrote :

Hello Victor, or anyone else affected,

Accepted libvirt into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libvirt/1.3.1-1ubuntu10.31 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libvirt (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial

Hello Victor, or anyone else affected,

Accepted libvirt into ussuri-proposed. The package will build now and be
available in the Ubuntu Cloud Archive in a few hours, and then in the
-proposed repository.

Please help us by testing this new package. To enable the -proposed
repository:

  sudo add-apt-repository cloud-archive:ussuri-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested, and change the tag
from verification-ussuri-needed to verification-ussuri-done. If it
does not fix the bug for you, please add a comment stating that, and
change the tag to verification-ussuri-failed. In either case, details
of your testing will help us make a better decision.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
advance!

tags: added: verification-ussuri-needed
no longer affects: cloud-archive/victoria
Victor Tapia (vtapia) wrote :

#VERIFICATION FOCAL

Using the test case described in the description, where a VM has 128 vcpus assigned, the version in -updates does not list the topology:

$ dpkg -l | grep libvirt
ii libvirt-clients 6.0.0-0ubuntu8.7 amd64 Programs for the libvirt library
ii libvirt-daemon 6.0.0-0ubuntu8.7 amd64 Virtualization daemon
ii libvirt-daemon-driver-qemu 6.0.0-0ubuntu8.7 amd64 Virtualization daemon QEMU connection driver
ii libvirt-daemon-driver-storage-rbd 6.0.0-0ubuntu8.7 amd64 Virtualization daemon RBD storage driver
ii libvirt0:amd64 6.0.0-0ubuntu8.7 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
<topology>
      <cells num="0">
      </cells>
    </topology>

The package in -proposed fixes the issue (output shortened):

$ dpkg -l | grep libvirt
ii libvirt-clients 6.0.0-0ubuntu8.8 amd64 Programs for the libvirt library
ii libvirt-daemon 6.0.0-0ubuntu8.8 amd64 Virtualization daemon
ii libvirt-daemon-driver-qemu 6.0.0-0ubuntu8.8 amd64 Virtualization daemon QEMU connection driver
ii libvirt-daemon-driver-storage-rbd 6.0.0-0ubuntu8.8 amd64 Virtualization daemon RBD storage driver
ii libvirt0:amd64 6.0.0-0ubuntu8.8 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
<topology>
      <cells num="1">
        <cell id="0">
          <memory unit="KiB">5027836</memory>
          <pages unit="KiB" size="4">1256959</pages>
          <pages unit="KiB" size="2048">0</pages>
          <distances>
            <sibling id="0" value="10"/>
          </distances>
          <cpus num="128">
            <cpu id="0" socket_id="0" core_id="0" siblings="0"/>
            ...
            <cpu id="127" socket_id="127" core_id="0" siblings="127"/>
          </cpus>
        </cell>
      </cells>
    </topology>

tags: added: verification-done-focal
removed: verification-needed-focal
Victor Tapia (vtapia) wrote :

Hello Victor, or anyone else affected,

Accepted libvirt into train-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:train-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-train-needed to verification-train-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-train-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-train-needed

Hello Victor, or anyone else affected,

Accepted libvirt into stein-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:stein-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-stein-needed to verification-stein-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-stein-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-stein-needed
Brian Murray (brian-murray) wrote :

Hello Victor, or anyone else affected,

Accepted libvirt into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libvirt/4.0.0-1ubuntu8.19 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libvirt (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Victor Tapia (vtapia) wrote :

#VERIFICATION BIONIC

Using the test case described in the description, where a VM has 128 vcpus assigned, the version in -updates does not list the topology:

$ dpkg -l |grep libvirt
ii libvirt-bin 4.0.0-1ubuntu8.17 amd64 programs for the libvirt library
ii libvirt-clients 4.0.0-1ubuntu8.17 amd64 Programs for the libvirt library
ii libvirt-daemon 4.0.0-1ubuntu8.17 amd64 Virtualization daemon
ii libvirt-daemon-driver-storage-rbd 4.0.0-1ubuntu8.17 amd64 Virtualization daemon RBD storage driver
ii libvirt-daemon-system 4.0.0-1ubuntu8.17 amd64 Libvirt daemon configuration files
ii libvirt0:amd64 4.0.0-1ubuntu8.17 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
XPath set is empty

The package in -proposed fixes the issue (output shortened):

$ dpkg -l |grep libvirt
ii libvirt-bin 4.0.0-1ubuntu8.19 amd64 programs for the libvirt library
ii libvirt-clients 4.0.0-1ubuntu8.19 amd64 Programs for the libvirt library
ii libvirt-daemon 4.0.0-1ubuntu8.19 amd64 Virtualization daemon
ii libvirt-daemon-driver-storage-rbd 4.0.0-1ubuntu8.19 amd64 Virtualization daemon RBD storage driver
ii libvirt-daemon-system 4.0.0-1ubuntu8.19 amd64 Libvirt daemon configuration files
ii libvirt0:amd64 4.0.0-1ubuntu8.19 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
<topology>
      <cells num="1">
        <cell id="0">
          <memory unit="KiB">5047560</memory>
          <pages unit="KiB" size="4">1261890</pages>
          <pages unit="KiB" size="2048">0</pages>
          <distances>
            <sibling id="0" value="10"/>
          </distances>
          <cpus num="128">
            <cpu id="0" socket_id="0" core_id="0" siblings="0"/>
            ...
            <cpu id="127" socket_id="127" core_id="0" siblings="127"/>
          </cpus>
        </cell>
      </cells>
    </topology>

tags: added: verification-done-bionic
removed: verification-needed-bionic
Victor Tapia (vtapia) wrote :

#VERIFICATION STEIN

Using the test case described in the description, where a VM has 128 vcpus assigned, the version in -updates does not list the topology:

$ dpkg -l |grep libvirt
ii libvirt-clients 5.0.0-1ubuntu2.6~cloud1 amd64 Programs for the libvirt library
ii libvirt-daemon 5.0.0-1ubuntu2.6~cloud1 amd64 Virtualization daemon
ii libvirt-daemon-driver-storage-rbd 5.0.0-1ubuntu2.6~cloud1 amd64 Virtualization daemon RBD storage driver
ii libvirt-daemon-system 5.0.0-1ubuntu2.6~cloud1 amd64 Libvirt daemon configuration files
ii libvirt0:amd64 5.0.0-1ubuntu2.6~cloud1 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
XPath set is empty

The package in -proposed fixes the issue (output shortened):

$ dpkg -l |grep libvirt
ii libvirt-clients 5.0.0-1ubuntu2.6~cloud2.1 amd64 Programs for the libvirt library
ii libvirt-daemon 5.0.0-1ubuntu2.6~cloud2.1 amd64 Virtualization daemon
ii libvirt-daemon-driver-storage-rbd 5.0.0-1ubuntu2.6~cloud2.1 amd64 Virtualization daemon RBD storage driver
ii libvirt-daemon-system 5.0.0-1ubuntu2.6~cloud2.1 amd64 Libvirt daemon configuration files
ii libvirt0:amd64 5.0.0-1ubuntu2.6~cloud2.1 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
<topology>
      <cells num="1">
        <cell id="0">
          <memory unit="KiB">5047560</memory>
          <pages unit="KiB" size="4">1261890</pages>
          <pages unit="KiB" size="2048">0</pages>
          <distances>
            <sibling id="0" value="10"/>
          </distances>
          <cpus num="128">
            <cpu id="0" socket_id="0" core_id="0" siblings="0"/>
            ...
            <cpu id="127" socket_id="127" core_id="0" siblings="127"/>
          </cpus>
        </cell>
      </cells>
    </topology>

Victor Tapia (vtapia) wrote :

#VERIFICATION TRAIN

Using the test case described in the description, where a VM has 128 vcpus assigned, the version in -updates does not list the topology:

$ dpkg -l |grep libvirt
ii libvirt-clients 5.4.0-0ubuntu5.4~cloud0 amd64 Programs for the libvirt library
ii libvirt-daemon 5.4.0-0ubuntu5.4~cloud0 amd64 Virtualization daemon
ii libvirt-daemon-driver-storage-rbd 5.4.0-0ubuntu5.4~cloud0 amd64 Virtualization daemon RBD storage driver
ii libvirt-daemon-system 5.4.0-0ubuntu5.4~cloud0 amd64 Libvirt daemon configuration files
ii libvirt0:amd64 5.4.0-0ubuntu5.4~cloud0 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
XPath set is empty

The package in -proposed fixes the issue (output shortened):

$ dpkg -l |grep libvirt
ii libvirt-clients 5.4.0-0ubuntu5.4~cloud1.1 amd64 Programs for the libvirt library
ii libvirt-daemon 5.4.0-0ubuntu5.4~cloud1.1 amd64 Virtualization daemon
ii libvirt-daemon-driver-storage-rbd 5.4.0-0ubuntu5.4~cloud1.1 amd64 Virtualization daemon RBD storage driver
ii libvirt-daemon-system 5.4.0-0ubuntu5.4~cloud1.1 amd64 Libvirt daemon configuration files
ii libvirt0:amd64 5.4.0-0ubuntu5.4~cloud1.1 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
<topology>
      <cells num="1">
        <cell id="0">
          <memory unit="KiB">5047560</memory>
          <pages unit="KiB" size="4">1261890</pages>
          <pages unit="KiB" size="2048">0</pages>
          <distances>
            <sibling id="0" value="10"/>
          </distances>
          <cpus num="128">
            <cpu id="0" socket_id="0" core_id="0" siblings="0"/>
            ...
            <cpu id="127" socket_id="127" core_id="0" siblings="127"/>
          </cpus>
        </cell>
      </cells>
    </topology>

Victor Tapia (vtapia) wrote :

#VERIFICATION USSURI

Using the test case described in the description, where a VM has 128 vcpus assigned, the version in -updates does not list the topology:

$ dpkg -l |grep libvirt
ii libvirt-clients 6.0.0-0ubuntu8.7~cloud0 amd64 Programs for the libvirt library
ii libvirt-daemon 6.0.0-0ubuntu8.7~cloud0 amd64 Virtualization daemon
ii libvirt-daemon-driver-qemu 6.0.0-0ubuntu8.7~cloud0 amd64 Virtualization daemon QEMU connection driver
ii libvirt-daemon-driver-storage-rbd 6.0.0-0ubuntu8.7~cloud0 amd64 Virtualization daemon RBD storage driver
ii libvirt-daemon-system 6.0.0-0ubuntu8.7~cloud0 amd64 Libvirt daemon configuration files
ii libvirt-daemon-system-systemd 6.0.0-0ubuntu8.7~cloud0 amd64 Libvirt daemon configuration files (systemd)
ii libvirt0:amd64 6.0.0-0ubuntu8.7~cloud0 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
<topology>
      <cells num="0">
      </cells>
    </topology>

The package in -proposed fixes the issue (output shortened):

$ dpkg -l |grep libvirt
ii libvirt-clients 6.0.0-0ubuntu8.8~cloud0 amd64 Programs for the libvirt library
ii libvirt-daemon 6.0.0-0ubuntu8.8~cloud0 amd64 Virtualization daemon
ii libvirt-daemon-driver-qemu 6.0.0-0ubuntu8.8~cloud0 amd64 Virtualization daemon QEMU connection driver
ii libvirt-daemon-driver-storage-rbd 6.0.0-0ubuntu8.8~cloud0 amd64 Virtualization daemon RBD storage driver
ii libvirt-daemon-system 6.0.0-0ubuntu8.8~cloud0 amd64 Libvirt daemon configuration files
ii libvirt-daemon-system-systemd 6.0.0-0ubuntu8.8~cloud0 amd64 Libvirt daemon configuration files (systemd)
ii libvirt0:amd64 6.0.0-0ubuntu8.8~cloud0 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
<topology>
      <cells num="1">
        <cell id="0">
          <memory unit="KiB">5047560</memory>
          <pages unit="KiB" size="4">1261890</pages>
          <pages unit="KiB" size="2048">0</pages>
          <distances>
            <sibling id="0" value="10"/>
          </distances>
          <cpus num="128">
            <cpu id="0" socket_id="0" core_id="0" siblings="0"/>
            ...
            <cpu id="127" socket_id="127" core_id="0" siblings="127"/>
          </cpus>
        </cell>
      </cells>
    </topology>

tags: added: verification-stein-done verification-train-done verification-ussuri-done
removed: verification-stein-needed verification-train-needed verification-ussuri-needed
Victor Tapia (vtapia) wrote :

#VERIFICATION XENIAL

Using the test case described in the description, where a VM has 128 vcpus assigned, the version in -updates does not list the topology:

$ dpkg -l | grep libvirt
ii libvirt-bin 1.3.1-1ubuntu10.30 amd64 programs for the libvirt library
ii libvirt0:amd64 1.3.1-1ubuntu10.30 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
XPath set is empty

The package in -proposed fixes the issue (output shortened):

$ dpkg -l | grep libvirt
ii libvirt-bin 1.3.1-1ubuntu10.31 amd64 programs for the libvirt library
ii libvirt0:amd64 1.3.1-1ubuntu10.31 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
<topology>
      <cells num="1">
        <cell id="0">
          <memory unit="KiB">4998464</memory>
          <pages unit="KiB" size="4">1249616</pages>
          <pages unit="KiB" size="2048">0</pages>
          <pages unit="KiB" size="1048576">0</pages>
          <distances>
            <sibling id="0" value="10"/>
          </distances>
          <cpus num="128">
            <cpu id="0" socket_id="0" core_id="0" siblings="0"/>
     ...
            <cpu id="127" socket_id="127" core_id="0" siblings="127"/>
          </cpus>
        </cell>
      </cells>
    </topology>

NOTE: if the machine is running a 4.4 kernel, numa_all_cpus_ptr->size (used to set max_n_cpus in libvirt) is 512 instead of 128 and the issue cannot be triggered (libvirt max vcpu is 255). Any newer kernel, such as HWE, sets the value to 128, triggering the issue.

Victor Tapia (vtapia) wrote :

#VERIFICATION GROOVY

Using the test case described in the description, where a VM has 128 vcpus assigned, the version in -updates does not list the topology:

$ dpkg -l | grep libvirt
ii libvirt-clients 6.6.0-1ubuntu3.3 amd64 Programs for the libvirt library
ii libvirt-daemon 6.6.0-1ubuntu3.3 amd64 Virtualization daemon
ii libvirt-daemon-driver-qemu 6.6.0-1ubuntu3.3 amd64 Virtualization daemon QEMU connection driver
ii libvirt-daemon-system 6.6.0-1ubuntu3.3 amd64 Libvirt daemon configuration files
ii libvirt-daemon-system-systemd 6.6.0-1ubuntu3.3 amd64 Libvirt daemon configuration files (systemd)
ii libvirt0:amd64 6.6.0-1ubuntu3.3 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
<topology>
      <cells num="0">
      </cells>
    </topology>

The package in -proposed fixes the issue (output shortened):

$ dpkg -l | grep libvirt
ii libvirt-clients 6.6.0-1ubuntu3.4 amd64 Programs for the libvirt library
ii libvirt-daemon 6.6.0-1ubuntu3.4 amd64 Virtualization daemon
ii libvirt-daemon-driver-qemu 6.6.0-1ubuntu3.4 amd64 Virtualization daemon QEMU connection driver
ii libvirt-daemon-system 6.6.0-1ubuntu3.4 amd64 Libvirt daemon configuration files
ii libvirt-daemon-system-systemd 6.6.0-1ubuntu3.4 amd64 Libvirt daemon configuration files (systemd)
ii libvirt0:amd64 6.6.0-1ubuntu3.4 amd64 library for interfacing with different virtualization systems

$ virsh capabilities | xmllint --xpath '/capabilities/host/topology' -
<topology>
      <cells num="1">
        <cell id="0">
          <memory unit="KiB">5023436</memory>
          <pages unit="KiB" size="4">1255859</pages>
          <pages unit="KiB" size="2048">0</pages>
          <distances>
            <sibling id="0" value="10"/>
          </distances>
          <cpus num="128">
            <cpu id="0" socket_id="0" die_id="0" core_id="0" siblings="0"/>
            ...
            <cpu id="127" socket_id="127" die_id="0" core_id="0" siblings="127"/>
          </cpus>
        </cell>
      </cells>
    </topology>

tags: added: verification-done verification-done-groovy verification-done-xenial
removed: verification-needed verification-needed-groovy verification-needed-xenial

The verification of the Stable Release Update for libvirt has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvirt - 6.6.0-1ubuntu3.4

---------------
libvirt (6.6.0-1ubuntu3.4) groovy; urgency=medium

  * d/p/lp1915811-*: Fix NUMA topology population for machines with high number
  of CPUs (LP: #1915811)

 -- Victor Manuel Tapia King <email address hidden> Mon, 22 Feb 2021 12:23:53 +0100

Changed in libvirt (Ubuntu Groovy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvirt - 6.0.0-0ubuntu8.8

---------------
libvirt (6.0.0-0ubuntu8.8) focal; urgency=medium

  * d/p/lp1915811-*: Fix NUMA topology population for machines with high number
  of CPUs (LP: #1915811)

 -- Victor Manuel Tapia King <email address hidden> Fri, 19 Feb 2021 17:15:56 +0100

Changed in libvirt (Ubuntu Focal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvirt - 4.0.0-1ubuntu8.19

---------------
libvirt (4.0.0-1ubuntu8.19) bionic; urgency=medium

  * d/p/lp1915811-fix-numa-topology.patch: Fix NUMA topology population for
    machines with a high number of CPUs (LP: #1915811)

libvirt (4.0.0-1ubuntu8.18) bionic; urgency=medium

  * Improve flaky smoke-lxc test (LP: #1899180)
    - d/t/control, d/t/smoke-lxc: retry service restart and skip test if
      failing; This was flaky on some release/architectures
    - d/t/smoke-lxc: retry check_domain being flaky on arm64

 -- Victor Manuel Tapia King <email address hidden> Thu, 18 Feb 2021 17:40:38 +0100

Changed in libvirt (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvirt - 1.3.1-1ubuntu10.31

---------------
libvirt (1.3.1-1ubuntu10.31) xenial; urgency=medium

  * d/p/lp1915811-fix-numa-topology.patch: Fix NUMA topology population for
    machines with a high number of CPUs (LP: #1915811)

 -- Victor Manuel Tapia King <email address hidden> Mon, 22 Feb 2021 13:44:48 +0100

Changed in libvirt (Ubuntu Xenial):
status: Fix Committed → Fix Released
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for libvirt has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package libvirt - 5.4.0-0ubuntu5.4~cloud1.1
---------------

 libvirt (5.4.0-0ubuntu5.4~cloud1.1) bionic-train; urgency=medium
 .
   * d/p/lp1915811-*: Fix NUMA topology population for machines with high number
     of CPUs (LP: #1915811)

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package libvirt - 6.0.0-0ubuntu8.8~cloud0
---------------

 libvirt (6.0.0-0ubuntu8.8~cloud0) bionic-ussuri; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 libvirt (6.0.0-0ubuntu8.8) focal; urgency=medium
 .
   * d/p/lp1915811-*: Fix NUMA topology population for machines with high number
   of CPUs (LP: #1915811)

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for libvirt has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package libvirt - 5.0.0-1ubuntu2.6~cloud2.1
---------------

 libvirt (5.0.0-1ubuntu2.6~cloud2.1) bionic-stein; urgency=medium
 .
   * d/p/lp1915811-*: Fix NUMA topology population for machines with high number
     of CPUs (LP: #1915811)

Changed in cloud-archive:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers