[19.04 FEAT] KVM: zPCI passthrough support for KVM

Bug #1799446 reported by bugproxy on 2018-10-23
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
High
Canonical Server Team
libvirt (Ubuntu)
Undecided
Christian Ehrhardt 

Bug Description

Enable KVM on System z to pass control over any kind of zPCI host device (a Virtual Function) to a KVM virtual server. This passthrough has to be supported in a hot plug/unplug fashion, too. Of course, the implementation has to be device type agnostic to support future PCI devices without having to adjust the underlying hypervisor. In support of cross CEC migration the translation of the Virtual Function ID has to be supported, too.

Function already available within kernel 4.11 and qemu 2.11.
Now new version of libvirt >= 4.9 will finalize the item

bugproxy (bugproxy) on 2018-10-23
tags: added: architecture-s39064 bugnameltc-172539 severity-high targetmilestone-inin1904
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → libvirt (Ubuntu)
Changed in ubuntu-z-systems:
importance: Undecided → High
assignee: nobody → Canonical Server Team (canonical-server)

------- Comment From <email address hidden> 2018-10-23 09:10 EDT-------
Updated version levels, typo :(

Function already available within
- kernel 4.14
- qemu 2.11

Now new version of libvirt >= 4.9 will finalize the item

I planned for libvirt 5.0 so far.
you can never be sure, but >=4.9 it should be eventually.

Added a tag for tracking.

Can we mark that bug public at least towards the actual release of libvirt 4.9?

tags: added: libvirt-19.04
Frank Heimes (frank-heimes) wrote :

Glad to hear that v5.0 is the target.
Sure, ticket can be changed to public with the release of 4.9 - or even if work on this gets started in general.

Changed in ubuntu-z-systems:
status: New → Triaged
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-12-04 11:13 EDT-------
*** Bug 173808 has been marked as a duplicate of this bug. ***

Changed in libvirt (Ubuntu):
status: New → In Progress
assignee: Skipper Bug Screeners (skipper-screen-team) → Christian Ehrhardt  (paelzer)
Changed in ubuntu-z-systems:
status: Triaged → In Progress
Frank Heimes (frank-heimes) wrote :

in between libvirt 5.0.0 landed in disco's release pocket.
Hence changing status to Fix Released and closing.

information type: Private → Public
Changed in libvirt (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-z-systems:
status: In Progress → Fix Released
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2019-02-05 02:37 EDT-------
IBM Bugzilla status-> closed, Fix Released with Disco

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers