virt-manager unable to connect to xen domain

Bug #1319773 reported by glisignoli
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libvirt (Ubuntu)
Fix Released
High
Stefan Bader

Bug Description

On Ubuntu 14.04, server with Xen kernel and virt-manager (all dependencies installed). I get the following error when trying to connect to my XEN domain (localhost) using virt-manager:

Unable to connect to libvirt.

internal error: libxenlight state driver is not active

Verify that:
 - A Xen host kernel was booted
 - The Xen service has been started

Libvirt URI is: xen:///

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 1027, in _open_thread
    self.vmm = self._try_open()
  File "/usr/share/virt-manager/virtManager/connection.py", line 1009, in _try_open
    flags)
  File "/usr/lib/python2.7/dist-packages/libvirt.py", line 105, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: internal error: libxenlight state driver is not active

Package versions that might be relevent:
virt-manager:
  Installed: 0.9.5-1ubuntu3

xen-hypervisor-4.4-amd64:
  Installed: 4.4.0-0ubuntu5

libvirt-bin:
  Installed: 1.2.2-0ubuntu13.1

Changed in libvirt (Ubuntu):
assignee: nobody → Stefan Bader (smb)
Revision history for this message
Serge Hallyn (serge-hallyn) wrote :

Hi Stefan,

has this been fixed by now?

Changed in libvirt (Ubuntu):
importance: Undecided → High
status: New → Incomplete
Revision history for this message
glisignoli (glisignoli) wrote : Re: [Bug 1319773] Re: virt-manager unable to connect to xen domain

Yes, Please close this.

On Fri, Jan 16, 2015 at 8:30 AM, Serge Hallyn <email address hidden>
wrote:

> Hi Stefan,
>
> has this been fixed by now?
>
> ** Changed in: libvirt (Ubuntu)
> Importance: Undecided => High
>
> ** Changed in: libvirt (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1319773
>
> Title:
> virt-manager unable to connect to xen domain
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/1319773/+subscriptions
>

Revision history for this message
Serge Hallyn (serge-hallyn) wrote :

Thanks for the update.

Changed in libvirt (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
Marietto (marietto2008) wrote :

I have the same problem,but I don't know how to fix it because you haven't explained how to fix that.

Revision history for this message
Lucas Kanashiro (lucaskanashiro) wrote :

Hi Marietto,

This bug is marked as Fix Released, ideally if you are using the latest updates in Xenial it should work. Could you share with us which version of the mentioned packages you're using?

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

He is on a much newer release @Lucas - let's stick to bug 1889064 which is the new one.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers