macvtap not working on wifi device

Bug #1174036 reported by Carlos Perelló Marín on 2013-04-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libvirt (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I tried to setup a libvirt + kvm host connected to the main network using macvtap with the wlan0 device, however the virtual host was not able to get any IP address using DHCP.

If I set the IP address manually, it still doesn't work, however with tcpdump I'm able to see from the physical host some traffic comming from a ping running inside the virtual host to the external network.

macvtap works without problems on a cable device. Also, virtualbox is able to setup a bridge like interface over wifi, so seems like is not a limitation on the wifi driver.

If you tell me about the debugging information you would need to fix this issue, I will be happy to provide it attached to this bug report.

Description: Ubuntu 13.04
Release: 13.04

libvirt0:
  Installed: 1.0.2-0ubuntu11
  Candidate: 1.0.2-0ubuntu11
  Version table:
 *** 1.0.2-0ubuntu11 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

Thanks

Serge Hallyn (serge-hallyn) wrote :

I don't believe macvlan is supported on wifi devices at all. Whenever I try, not only does the macvtap device not work, but my host's wifi connection needs to be reset.

I can mark this as affecting the kernel, but this is not a qemu bug and I suspect that in the kernel it is simply not supported, just like bridging the wifi device.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1174036

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: raring
Changed in libvirt (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for libvirt (Ubuntu) because there has been no activity for 60 days.]

Changed in libvirt (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers