[raring] No ip assigned to bridge and no routes added for virtual networks

Bug #1099155 reported by Roman Yepishev on 2013-01-13
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libvirt (Ubuntu)
Critical
Unassigned
lxc (Ubuntu)
Critical
Unassigned
network-manager (Ubuntu)
Critical
Mathieu Trudel-Lapierre

Bug Description

I migrated network configuration from my 12.04 LTS host:
<network connections='1'>
  <name>vm100</name>
  <uuid>38ffbbe2-0e06-4233-b7c7-1f672401d434</uuid>
  <forward dev='eth0' mode='route'>
    <interface dev='eth0'/>
  </forward>
  <bridge name='virbr1' stp='on' delay='0' />
  <mac address='52:54:00:B7:10:21'/>
  <ip address='192.168.100.1' netmask='255.255.255.0'>
    <dhcp>
      <range start='192.168.100.2' end='192.168.100.254' />
    </dhcp>
  </ip>
</network>

Upon defining and start virbr1 is created but it has no IP address, subsequently there are no IP routes to the network. After adding the ip address and routes to the interface my machine (naturally) started to be able to communicate with the world.

I feel this is a regression since there was no additional configuration involved with 12.04 to get this up and running.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: libvirt-bin 1.0.0-0ubuntu4
ProcVersionSignature: Error: [Errno 2] No such file or directory: '/proc/version_signature'
Uname: Linux 3.8.0-030800rc2-generic x86_64
ApportVersion: 2.8-0ubuntu1
Architecture: amd64
Date: Sun Jan 13 19:31:17 2013
InstallationDate: Installed on 2013-01-04 (9 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130104)
MarkForUpload: True
SourcePackage: libvirt
UpgradeStatus: No upgrade log present (probably fresh install)

Roman Yepishev (rye) wrote :
Serge Hallyn (serge-hallyn) wrote :

Thanks for reporting this bug. To make sure this is the bug I"m thinking of, can you confirm that this is a desktop system with network manager running?

Changed in libvirt (Ubuntu):
status: New → Incomplete
Roman Yepishev (rye) wrote :

Yes, the 13.04 was a desktop system.

Roman Yepishev (rye) wrote :

The original system (from where I took the VM) was 12.04 w/o network manager and unfortunately I have not tested it with network-manager installed.

Changed in libvirt (Ubuntu):
status: Incomplete → New
Serge Hallyn (serge-hallyn) wrote :

Thanks, Roman. network-manager in precise would not have been a problem, but as of raring it tries to take control of virtual interfaces. This has also been confirmed by stgraber and myself in lxc.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Changed in lxc (Ubuntu):
status: New → Confirmed
Changed in libvirt (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in lxc (Ubuntu):
importance: Undecided → Critical
Changed in network-manager (Ubuntu):
importance: Undecided → Critical
Changed in libvirt (Ubuntu):
importance: High → Critical
Roman Yepishev (rye) wrote :

So, it looks like not only custom libvirt network is affected but the standard default too effectively rendering libvirt machines in a desktop session without any kind of network.

summary: - [raring] No ip assigned to bridge and no routes added for routed network
+ [raring] No ip assigned to bridge and no routes added for virtual
+ networks
Changed in network-manager (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.6.0+git201301021750.e78c3e8-0ubuntu2

---------------
network-manager (0.9.6.0+git201301021750.e78c3e8-0ubuntu2) raring; urgency=low

  * debian/patches/bridge_ignore_without_connections.patch: Ignore bridge
    devices that don't have configured connections, so as not to compete with
    lxc or libvirt and trample their config. (LP: #1099155)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 18 Jan 2013 15:20:08 -0500

Changed in network-manager (Ubuntu):
status: In Progress → Fix Released
Changed in lxc (Ubuntu):
status: Confirmed → Invalid
Changed in libvirt (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers