Unable to build libv8 on arm64

Bug #1435432 reported by Micheal Waltz on 2015-03-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libv8-3.14 (Ubuntu)
Undecided
Unassigned

Bug Description

Building the package libv8 fails on the arm64 architecture. Attempted to build on both Trusty and Vivid and have the same results.

lsb_release -a:
Distributor ID: Ubuntu
Description: Ubuntu 14.04.2 LTS
Release: 14.04
Codename: trusty

uname -a:
Linux tael 3.13.0-46-generic #77-Ubuntu SMP Mon Mar 2 18:27:27 UTC 2015 aarch64 aarch64 aarch64 GNU/Linux

Using dget command to re-build source from .dsc, It appears that arm64 is not defined as an architecture::
dget --allow-unauthenticated --build https://launchpad.net/ubuntu/+archive/primary/+files/libv8-3.14_3.14.5.8-5ubuntu2.dsc

Exit error is (full dpkg-buildpackage log attached):
make: Nothing to be done for `build'.
 fakeroot debian/rules binary
make: Nothing to be done for `binary'.
 dpkg-genchanges -b >../libv8-3.14_3.14.5.8-5ubuntu2_arm64.changes
dpkg-genchanges: error: cannot read files list file: No such file or directory
dpkg-buildpackage: error: dpkg-genchanges gave error exit status 2

Micheal Waltz (ecliptik) wrote :
Micheal Waltz (ecliptik) wrote :

After updating the control and rules files to include arm64 continues up until v8 fails to compile since it does not recognize the arm64 architecture, here's the last error, and attaching full error log.

In file included from ../src/allocation.h:31:0,
                 from ../src/allocation.cc:28:
../src/globals.h:102:2: error: #error Host architecture was not detected as supported by v8
 #error Host architecture was not detected as supported by v8
  ^
../src/globals.h:134:2: error: #error Target architecture arm is only supported on arm, ppc and ia32 host
 #error Target architecture arm is only supported on arm, ppc and ia32 host
  ^
make[2]: *** [/var/tmp/nodejs/libv8-3.14-3.14.5.8/out/arm.release/obj.target/preparser_lib/src/allocation.o] Error 1

It appears that v8 has added arm64 in newer versions of V8 per this commit: https://github.com/v8/v8-git-mirror/commit/8ef8f58bae44a9db7d7b18780ef162777ece019e

Updating the version of V8 to a newer one should fix this and I'll attempt to re-build the package with a newer version.

Micah Gersten (micahg) on 2015-03-23
tags: added: ftbfs
Micheal Waltz (ecliptik) on 2015-03-23
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers