Problem during configuring (wrong path)

Bug #1542030 reported by Michael on 2016-02-04
100
This bug affects 25 people
Affects Status Importance Assigned to Milestone
libutempter (Debian)
Fix Released
Unknown
libutempter (Ubuntu)
High
Unassigned

Bug Description

While updating from 14.04 to 16.04, I got error messaging that /usr/lib/utempter isn't existing. On my install (x64), I've only /usr/lib/x86_64-linux-gnu/utempter .

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libutempter (Ubuntu):
status: New → Confirmed
Michael (3-ueuntu-4) on 2016-02-13
tags: added: xenial
Changed in libutempter (Ubuntu):
importance: Undecided → High
Andrey Bondarenko (abone) wrote :

This is bug in libutempter0.postinst script

it should either check existence of /usr/lib/utempter directory or create it before changing ownership. Manual creation of the directory solves the issue:

sudo mkdir /usr/lib/utempter
sudo dpkg --configure libutempter0

Other question is why directory /usr/lib/utempter may not exist after package install?

Andrey Bondarenko (abone) wrote :

This bug may be related to bug 1508677.

Version 1.1.6 from 16.04 compiled with multiarch support, so utempter is installed into /usr/lib/<arch>/utempter not in /usr/lib/utempter.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1542030

tags: added: iso-testing
Andrey Bondarenko (abone) wrote :

The bug is fixed in Debian package version 1.1.6-3

Changed in libutempter (Debian):
status: Unknown → Fix Released
Peter Schüller (schueller-p) wrote :

As a workaround to allow installation, I made a symlink:

# cd /usr/lib
# ln -s /usr/lib/x86_64-linux-gnu/utempter
# apt-get install libutempter0

-> installation can finish however it might be good to remove the symlink afterwards (?)

Timo Aaltonen (tjaalton) wrote :

This bug was fixed in the package libutempter - 1.1.6-3

---------------
libutempter (1.1.6-3) unstable; urgency=medium

  * Team upload.
  * Drop the postinst script, the files that were getting chowned are in a
    different location now, no chown needed. (Closes: #814647) Thanks to
    Andreas Beckmann for reporting.

 -- Maximiliano Curia <email address hidden> Thu, 18 Feb 2016 19:47:33 +0100

libutempter (1.1.6-2) unstable; urgency=medium

  * Team upload.
  * Merge with Ubuntu. (Closes: #812956)

 -- Maximiliano Curia <email address hidden> Tue, 09 Feb 2016 19:43:36 +0100

libutempter (1.1.6-1ubuntu1) xenial; urgency=medium

  * Multiarchify the library packages.

 -- Matthias Klose <email address hidden> Thu, 28 Jan 2016 03:34:45 +0100

Changed in libutempter (Ubuntu):
status: Confirmed → Fix Released

thankyou so much, will check the same

*Regards, Sandeep Shetty netCORE Solution Pvt. Ltd. EMM Support*
* +91 22 66628080 *

On Fri, Mar 11, 2016 at 6:24 PM, Timo Aaltonen <email address hidden> wrote:

> This bug was fixed in the package libutempter - 1.1.6-3
>
> ---------------
> libutempter (1.1.6-3) unstable; urgency=medium
>
> * Team upload.
> * Drop the postinst script, the files that were getting chowned are in a
> different location now, no chown needed. (Closes: #814647) Thanks to
> Andreas Beckmann for reporting.
>
> -- Maximiliano Curia <email address hidden> Thu, 18 Feb 2016 19:47:33 +0100
>
> libutempter (1.1.6-2) unstable; urgency=medium
>
> * Team upload.
> * Merge with Ubuntu. (Closes: #812956)
>
> -- Maximiliano Curia <email address hidden> Tue, 09 Feb 2016 19:43:36 +0100
>
> libutempter (1.1.6-1ubuntu1) xenial; urgency=medium
>
> * Multiarchify the library packages.
>
> -- Matthias Klose <email address hidden> Thu, 28 Jan 2016 03:34:45 +0100
>
> ** Changed in: libutempter (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1545906).
> https://bugs.launchpad.net/bugs/1542030
>
> Title:
> Problem during configuring (wrong path)
>
> Status in libutempter package in Ubuntu:
> Fix Released
> Status in libutempter package in Debian:
> Fix Released
>
> Bug description:
> While updating from 14.04 to 16.04, I got error messaging that
> /usr/lib/utempter isn't existing. On my install (x64), I've only
> /usr/lib/x86_64-linux-gnu/utempter .
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/libutempter/+bug/1542030/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.