Hangs in pthread_join in libusb_exit

Bug #1203655 reported by Lars Karlitski on 2013-07-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libusbx (Debian)
Fix Released
Unknown
libusbx (Ubuntu)
High
Unassigned

Bug Description

Upower hangs and doesn't respond to any messages on the bus. This results in `upower -d` not working and the panel not showing the power indicator at all.

Several people have reported this issue, but we don't know how to reproduce it yet.

Lars Karlitski (larsu) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upower (Ubuntu):
status: New → Confirmed
Alexander Sack (asac) wrote :

after debugging on IRC with pitti this might also cause that closing lid does not suspend anymore (on my x220)

Lars Karlitski (larsu) wrote :

Alexander: I can confirm that. My system doesn't suspend when I close the lid when upower hangs like described above. Suspending from the session menu works, though.

Martin Pitt (pitti) wrote :
affects: upower (Ubuntu) → libusbx (Ubuntu)
Changed in libusbx (Ubuntu):
status: Confirmed → Fix Released
importance: Undecided → High
Changed in libusbx (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.