Ubuntu

Unity should provide an "active" signal on a per lens basis

Reported by David Callé on 2011-12-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libunity
Medium
Michal Hruby
libunity (Ubuntu)
Undecided
Unassigned

Bug Description

The current notify::active signal is sent when the dash is opened, closed or when any lens is displayed.

Lens developers using remote APIs need to be cautious with the number of API calls they send. When they need to display a default set of results when a lens is opened, they use this signal despite of it being sent a lot more than needed and triggering a lot of unwanted API calls.

Unity should provide an "active" signal on a per lens basis.

Michal Hruby (mhr3) on 2011-12-09
affects: unity → libunity
Changed in libunity:
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → Medium
status: New → In Progress
Didier Roche (didrocks) on 2012-02-01
Changed in unity:
status: New → In Progress
Changed in libunity (Ubuntu):
status: New → In Progress
Omer Akram (om26er) on 2012-08-03
Changed in unity:
status: In Progress → Confirmed
Changed in libunity:
status: In Progress → Confirmed
Changed in libunity (Ubuntu):
status: In Progress → Confirmed
Michal Hruby (mhr3) wrote :

Marking as invalid since the latest scope API doesn't have a active property, plus together with TTL of result set this should be considered fixed.

no longer affects: unity
Changed in libunity (Ubuntu):
status: Confirmed → Fix Released
Changed in libunity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers