Snapped applications using ubuntu launcher integration needs desktop update

Bug #1747814 reported by Marco Trevisan (Treviño) on 2018-02-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libunity (Ubuntu)
Medium
Marco Trevisan (Treviño)
Xenial
Undecided
Unassigned

Bug Description

[ Impact ]

Launching a snapped application with ubuntu launcher icon integration doesn't properly work as the desktop ID does not use the proper namespace.

Also, a snapped app could decorate other apps outside the snap scope.

[ Test case ]

git clone https://github.com/3v1n0/ubuntu-launcher-integration-snap.git
cd ubuntu-launcher-integration-snap
snapcraft prime
snap try prime

Then launch those (you might do it from dash/activities to get proper matching):
 ubuntu-launcher-integration-snap.ubuntu-launcher
 ubuntu-launcher-integration-snap.ubuntu-launcher-2nd
 ubuntu-launcher-integration-snap.ubuntu-launcher-hardcoded

All these apps should get an icon in the launcher with emblems (of different values when they're launched together).

[ Regression potential ]

Application with SNAP environments could point to wrong desktop-file to decorate

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 7.1.4+18.04.20180207.2-0ubuntu1

---------------
libunity (7.1.4+18.04.20180207.2-0ubuntu1) bionic; urgency=medium

  * UnityLauncher: Prepend snap namespace to desktop file or desktop-id
    (LP: #1737835, #1747814)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 07 Feb 2018 12:31:27 +0000

Changed in libunity (Ubuntu):
status: In Progress → Fix Released
description: updated
Łukasz Zemczak (sil2100) wrote :

I'm wondering if it makes sense to also get this released for artful? Unity is not the default experience but the package is still available, so in theory someone upgrading from xenial to artful and insisting on staying with Unity as his shell might experience a regression.

What do you think? I'll accept it for now, but maybe it's worth considering?

Changed in libunity (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial

Hello Marco, or anyone else affected,

Accepted libunity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libunity/7.1.4+16.04.20180207-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Hi Lukasz,

While for bug #1747802 this would indeed make sense, for this specific not really, since this affects mostly the snapcrafter's (as these fixes will apply to apps running inside snaps built in a xenial-based distro), and snapcraft isn't supporting artful anyway.

Łukasz Zemczak (sil2100) wrote :

Hello Marco, or anyone else affected,

Accepted libunity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libunity/7.1.4+16.04.20180209.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Generated Snap with libunity 7.1.4+16.04.20180209.1-0ubuntu1, launcher integration works just fine.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 7.1.4+16.04.20180209.1-0ubuntu1

---------------
libunity (7.1.4+16.04.20180209.1-0ubuntu1) xenial; urgency=medium

  * UnityLauncher: Prepend snap namespace to desktop file or desktop-id
    (LP: #1747814)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 09 Feb 2018 15:48:43 +0000

Changed in libunity (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libunity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers