Removing libunity9 also removes nautilus and other packages

Bug #1224621 reported by Fred on 2013-09-12
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libunity
Confirmed
Undecided
Unassigned
libunity (Ubuntu)
Undecided
Unassigned

Bug Description

$ apt-get -s remove libunity9
The following packages will be REMOVED:
  brasero brasero-cdrkit deja-dup
  deja-dup-backend-gvfs deja-dup-backend-ubuntuone empathy
  indicator-appmenu indicator-sound libbrasero-media3-1
  libunity9 mcp-account-manager-uoa nautilus nautilus-sendto nautilus-sendto-empathy
  nautilus-share rhythmbox-plugin-cdrecorder shotwell telepathy-indicator xchat-indicator

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: libunity9 6.90.2daily13.04.05-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-30.44-generic 3.8.13.6
Uname: Linux 3.8.0-30-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.4
Architecture: amd64
Date: Thu Sep 12 20:05:10 2013
InstallationDate: Installed on 2011-10-21 (692 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MarkForUpload: True
SourcePackage: libunity
UpgradeStatus: Upgraded to raring on 2013-01-20 (234 days ago)

Fred (eldmannen+launchpad) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libunity (Ubuntu):
status: New → Confirmed
Michal Hruby (mhr3) wrote :

Nautilus and other packages are patched to support integration with Unity launcher, that's why they link with libunity.

Changed in libunity (Ubuntu):
status: Confirmed → Invalid
Fred (eldmannen+launchpad) wrote :

This means you can't use Brasero, Dejadup and Nautilus without having libunity installed?

Yuck!
Good system architecture should be highly cohesive, loosely coupled.
This is tightly coupled. :(

Not everyone like Unity, and not everyone wants Unity installed.

vgeloven (vgeloven) on 2015-11-06
Changed in libunity (Ubuntu):
status: Invalid → New
status: New → Confirmed
Pander (pander) wrote :

Nautilus, is the official file manager for the GNOME desktop, so it might suggest Unity packages but it should not depend on them. The implementation can be made in such way that when Unity is not installed, there should not be a problem.

Same goes for empathy and thunderbird-gnome-support. Ubunty should give its users more freedom in choosing that to install and not push Unity (I have seen too many hard dependencies) or it is going to loose users to e.g. Debian.

tags: added: 15.10 packaging unity
Pander (pander) wrote :

# dpkg -P libunity9:amd64
dpkg: dependency problems prevent removal of libunity9:amd64:
 nautilus depends on libunity9 (>= 3.8.4).
 thunderbird-gnome-support depends on libunity9.
 empathy depends on libunity9 (>= 3.4.6).

Changed in libunity:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers