libunity9 now depends on unity-common which depends on compiz

Bug #1062099 reported by Jeremy Bicha on 2012-10-05
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libunity
Fix Released
High
Michal Hruby
6.0
Fix Released
High
Unassigned
libunity (Ubuntu)
Undecided
Łukasz Zemczak

Bug Description

[Test Case]
Ensure that libunity9 can be installed without the need of installing compiz-gnome.

[Regression Potential]
Errors/warnings due to missing schemas.

Original description:

Originally reported at http://ubuntuforums.org/showpost.php?p=12278363&postcount=45

To fix bug 1055019, libunity 9 now depends on unity-common.

This is a serious issue for the Ubuntu GNOME Remix because core apps like deja-dup, empathy, nautilus, and shotwell depend on libunity9. unity-common depends on compiz but we do not ship compiz.

http://paste.ubuntu.com/1261477/

If we take into account bug 1036752, shipping GNOME Classic with Compiz means that the GNOME Classic session is broken. (That is also a critical bug for Edubuntu).

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: libunity9 6.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Uname: Linux 3.5.0-16-generic x86_64
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
Date: Fri Oct 5 03:58:23 2012
SourcePackage: libunity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) on 2012-10-05
description: updated
tags: added: rls-mgr-q-incoming
Łukasz Zemczak (sil2100) wrote :

It seems that the dependency to compiz-gnome in unity-common is caused by the complicated migration mechanisms and gsettings settings both depend on. A very troublesome issue indeed...

Sebastien Bacher (seb128) wrote :

One easy workaround is to update the code to handle the case where the schemas is missing and drop the depends

Michal Hruby (mhr3) on 2012-10-05
Changed in libunity:
status: New → In Progress
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → High
Changed in libunity (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libunity (Ubuntu):
status: New → Confirmed
Changed in libunity:
status: In Progress → Fix Committed
milestone: none → 7.0.0
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 6.8.0-0ubuntu2

---------------
libunity (6.8.0-0ubuntu2) quantal; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * Cherry-picked from upstream.
    - libunity9 now depends on unity-common which depends on compiz
      (LP: #1062099)
    - Build failure: be tolerant of missing GSettings (LP: #973518)
  * debian/control:
    - Remove dependency to unity-common, as now we're more fault-tolerant
      about missing schemas

  [ Didier Roche ]
  * debian/control:
    - Actually, downgrade it rather to suggests.
 -- Didier Roche <email address hidden> Fri, 05 Oct 2012 15:49:08 +0200

Changed in libunity (Ubuntu):
status: Confirmed → Fix Released
description: updated
Michal Hruby (mhr3) on 2013-09-02
Changed in libunity:
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2014-05-04
no longer affects: libunity (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers