Dependency on webbrowser-app seems ill-advised

Bug #1280337 reported by Doug McMahon on 2014-02-14
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
BAMF
Medium
Alexandre Abreu
WebApps: libunity-webapps
Undecided
Unassigned
bamf (Ubuntu)
Undecided
Unassigned
libunity-webapps (Ubuntu)
Critical
Robert Bruce Park

Bug Description

So if a user decides to uninstall webbrowser-app then they will basically destroy their install. If done thru software-center there is no real indication of what is about to happen. (Bug 1278869 )
If done thru the Dash even a bit worse as the uninstall(s) are done silently in the background

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity-webapps-service 2.5.0~+14.04.20140205-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-8.28-generic 3.13.2
Uname: Linux 3.13.0-8-generic x86_64
ApportVersion: 2.13.2-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Feb 14 10:12:33 2014
SourcePackage: libunity-webapps
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doug McMahon (mc3man) wrote :
David Barth (dbarth) wrote :

Robert: can that dependency be turned into a recommend? The underlying code should be able to fallback to another webcontainer (like chrome) if available.

Changed in libunity-webapps (Ubuntu):
assignee: nobody → Robert Bruce Park (robru)
Doug McMahon (mc3man) wrote :

Just to note -
Not sure what was up with the Dash before but "uninstall" on apps is now working.
So in the case of webbrowser-app the uninstall option is front & center & will silently proceed to uninstall unity, ect. along with webbrowser-app package

description: updated
Robert Bruce Park (robru) wrote :

David, didn't we just rip out the support for firefox & chrome as containers this cycle? I thought the whole point of this dependency is that webbrowser-app is *the* container for doing webapps.

Doug McMahon (mc3man) wrote :

Well if you're getting rid of bamf this cycle then you can ignore this bug, otherwise you can't have your only available session depend on the installation of an easily removed web browser application
I'm sure there is a better, safer way to achieve your purposes.

Robert Bruce Park (robru) wrote :

Whoa now, I didn't say anything about bamf. You're right that uninstalling webbrowser-app should not remove unity, but my understanding is that webapps are completely dead without webbrowser-app. So absolutely uninstalling webbrowser-app should pull out all webapps...

I think the solution to this looks more along the lines of "make unity stop depending on webapps" and less along the lines of "make webapps stop depending on webbrowser-app".

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libunity-webapps (Ubuntu):
status: New → Confirmed

It severely affects packages beyond the one that causes the flaw.

Changed in libunity-webapps (Ubuntu):
importance: Undecided → Critical
Robert Bruce Park (robru) wrote :

The dependency chain here looks like this:

unity -> bamfdaemon -> libunity-webapps0 -> unity-webapps-service -> webapp-container -> webbrowser-app.

My initial feeling was that bamfdaemon just shouldn't depend on libunity-webapps0, because we dropped a bunch of webapps code from bamf following the switch to the container, however upon looking at the code there it seems bamf and libunity-webapps are tightly integrated, so that seemed like a nontrivial task to split.

Then I started looking at the chain and it wasn't clear to me whether unity-webapp-service should stop depending on webapp-container, or whether webapp-container stop depending on webbrowser-app.

David Barth (dbarth) wrote :

I think you are right: we could get rid of the bamf / libunity-webapps link, or at least loosen the dependency between bamf and webapps.

tags: added: webapps-hotlist
Robert Bruce Park (robru) wrote :

If anybody is interested in helping to test this, the fix is available in this PPA for the time being:

https://launchpad.net/~ci-train-ppa-service/+archive/landing-011

(make sure to disable this PPA after installing, because later on this PPA will contain other, unrelated components that might break your system).

I used the PPA and upgraded bamf. This solved the problem and Unity isn't removed when uninstalling webbrowser-app but as you mentioned in comment #6 the webapps are dead.

$ sudo apt remove webbrowser-app

Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie... Gotowe
Następujące pakiety zostaną USUNIĘTE (REMOVED):
  libunity-webapps0 unity-webapps-common unity-webapps-deezer
  unity-webapps-service webapp-container webbrowser-app xul-ext-unity
  xul-ext-websites-integration
0 aktualizowanych, 0 nowo instalowanych, 8 usuwanych i 0 nieaktualizowanych.
Po tej operacji zostanie zwolnione 3411 kB miejsca na dysku.

David Barth (dbarth) wrote :

Works. +1 for landing

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.5.1+14.04.20140407.1-0ubuntu1

---------------
bamf (0.5.1+14.04.20140407.1-0ubuntu1) trusty; urgency=low

  [ CI bot ]
  * Resync trunk

  [ Alexandre Abreu ]
  * Rip out vestigial webapps code (LP: #1280337) (LP: #1280337)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Mon, 07 Apr 2014 23:42:28 +0000

Changed in bamf (Ubuntu):
status: New → Fix Released
Robert Bruce Park (robru) wrote :

Erk, it seems we have a small goofup here. Nobody bothered to rebuild the silo after Alex pushed more commits, so when I woke up today I saw dbarth's approval and published the silo. Then *after* I did the publish I saw that there were more commits, so I rebuilt and republished.

So, the above version (0.5.1+14.04.20140407.1-0ubuntu1) contains only commit 598 from Alex's branch, which means that (according to Marco) "chromium web-apps will stop working". So the real fix, with all commits included, is coming soon as package version (0.5.1+14.04.20140408-0ubuntu1)

David Barth (dbarth) on 2014-04-14
Changed in bamf:
status: New → Fix Released
Changed in libunity-webapps:
status: New → Fix Released
Changed in libunity-webapps (Ubuntu):
status: Confirmed → Fix Released
Changed in bamf:
importance: Undecided → Medium
assignee: nobody → Alexandre Abreu (alexabreu-abreu)
milestone: none → 0.5.1
status: Fix Released → Fix Committed

Fix Released in bamf BAMF 0.5.1 "The Trusty BAMF".

Changed in bamf:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers