No album art displayed when webapp plays from u1ms player

Bug #1166219 reported by Dave Morley on 2013-04-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libunity-webapps (Ubuntu)
Undecided
Unassigned

Bug Description

Description:
If I open U1MS webapp it defaults to the store if I play a sample file I get Album art as expected, however if I change to the player tab and select some music that I own the album art doesn't display in the aound indicator or notifictaions.

Service:
U1 MS/Player + Webapp using Firefox 19.0.2
https://one.ubuntu.com/music-store/
https://one.ubuntu.com/music/player/#view=my-songs

Steps:
/!\ Pre-requiste: You must have at least 1 track purchased from Ubuntu one

1. Click on the u1ms webapp launcher
2. Click on the play button beside the top single
3. Note what you see in the indicator and in the notifications
4. Change to the music player linnk above
5. Again click on play for the top track
6. Once more note the indicator and notifications for this track.

Expected Results:
I expect to see albume art always

Actual Results:
I see album art for the store but not in the player.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: libunity-webapps0 2.5.0~daily13.03.18-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-16.26-generic 3.8.5
Uname: Linux 3.8.0-16-generic x86_64
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
Date: Mon Apr 8 14:48:49 2013
InstallationDate: Installed on 2013-04-02 (6 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130402)
MarkForUpload: True
SourcePackage: libunity-webapps
UpgradeStatus: No upgrade log present (probably fresh install)

Dave Morley (davmor2) wrote :
Will Cooke (willcooke) wrote :

Thanks Dave.

From the initial checking I've done, I see that the value for the album art is being set correctly.

One thing it *might* be is that the URL for the art is returned as type "application/JSON", maybe that's enough to confuse it?
Also, the return picture is pretty large, at least 800x600 - again, this *might* be something to do with it.

We'll need to do some more checking.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers