Firefox ends up with 2 different copies of sqlite loaded in to memory

Bug #1068492 reported by Chris Coulson on 2012-10-19
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
WebApps: libunity-webapps
High
Maxim Ermilov
libunity-webapps (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

Firefox contains its own copy of sqlite which is updated in regular updates. Currently, libunity-webapps links against the system libsqlite causing 2 copies of it to be mapped in to memory at the same time. This results in symbol collisions and probably only currently works because the wind is blowing in the right direction. As the copy of sqlite shipped with Firefox changes in regular updates, this is likely to go wrong at some point in a future update.

chr1s@farnsworth:~$ cat /proc/`pidof firefox`/maps | grep sqlite
7f7b043f8000-7f7b04400000 rw-s 00000000 08:01 1361137 <snip>/places.sqlite-shm
7f7b0c6bf000-7f7b0c764000 r-xp 00000000 08:01 4330249 /usr/lib/x86_64-linux-gnu/libsqlite3.so.0.8.6
7f7b0c764000-7f7b0c964000 ---p 000a5000 08:01 4330249 /usr/lib/x86_64-linux-gnu/libsqlite3.so.0.8.6
7f7b0c964000-7f7b0c966000 r--p 000a5000 08:01 4330249 /usr/lib/x86_64-linux-gnu/libsqlite3.so.0.8.6
7f7b0c966000-7f7b0c968000 rw-p 000a7000 08:01 4330249 /usr/lib/x86_64-linux-gnu/libsqlite3.so.0.8.6
7f7b276ab000-7f7b2772c000 r-xp 00000000 08:01 4459255 /usr/lib/firefox/libmozsqlite3.so
7f7b2772c000-7f7b2792c000 ---p 00081000 08:01 4459255 /usr/lib/firefox/libmozsqlite3.so
7f7b2792c000-7f7b2792e000 r--p 00081000 08:01 4459255 /usr/lib/firefox/libmozsqlite3.so
7f7b2792e000-7f7b27930000 rw-p 00083000 08:01 4459255 /usr/lib/firefox/libmozsqlite3.so
7f7b28a09000-7f7b28a11000 rw-s 00000000 08:01 1362522 <snippety snip>/cookies.sqlite-shm

affects: libunity-webapps (Ubuntu) → ubuntu
affects: ubuntu → libunity-webapps (Ubuntu)
Alberto Mardegan (mardy) wrote :

Hi Chris! I cannot comment on the libunity-webapps's usage of SQLite -- I'll leave that to the webapps developers.

However, our Online Accounts extension is probably also causing the system libsqlite to be loaded into FF process space: we are opening (via js-ctypes) a library called libwebaccounts.so, which in turn depends on libaccounts-glib, which uses libsqlite. Is this unsafe as well?
I don't think that FF code would have access to the system libsqlite symbols in this case.

Changed in libunity-webapps (Ubuntu Quantal):
status: New → Fix Released
Changed in libunity-webapps (Ubuntu):
status: New → Fix Released
status: Fix Released → New
Changed in libunity-webapps (Ubuntu Quantal):
status: Fix Released → New
Changed in libunity-webapps:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → High
Alex Launi (alexlauni) on 2012-10-26
Changed in libunity-webapps:
status: New → Confirmed
Maxim Ermilov (zaspire) on 2012-12-05
Changed in libunity-webapps:
assignee: Alexandre Abreu (abreu-alexandre) → Maxim Ermilov (zaspire)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libunity-webapps (Ubuntu Quantal):
status: New → Confirmed
Changed in libunity-webapps (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in libunity-webapps (Ubuntu Quantal):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers