unity-webapps-context-daemon crashed with SIGSEGV in g_desktop_app_info_get_filename()

Bug #1064148 reported by Michael Hall on 2012-10-09
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
WebApps: libunity-webapps
Medium
Maxim Ermilov
libunity-webapps (Ubuntu)
Medium
Unassigned

Bug Description

no idea what the trigger was

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: unity-webapps-service 2.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-17.27-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
ApportVersion: 2.6.1-0ubuntu1
Architecture: i386
Date: Mon Oct 8 21:47:36 2012
ExecutablePath: /usr/lib/libunity-webapps/unity-webapps-context-daemon
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcCmdline: /usr/lib/libunity-webapps/unity-webapps-context-daemon Ubuntu\ One\ Music one.ubuntu.com icon://ubuntuone-music [Invalid\ UTF-8] UbuntuOneMusiconeubuntucom.desktop
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0xb6ffcb44 <g_desktop_app_info_get_filename+4>: mov 0x10(%eax),%eax
 PC (0xb6ffcb44) ok
 source "0x10(%eax)" (0x00000010) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: libunity-webapps
StacktraceTop:
 g_desktop_app_info_get_filename () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? ()
 ?? ()
 ?? ()
 g_simple_async_result_complete () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
Title: unity-webapps-context-daemon crashed with SIGSEGV in g_desktop_app_info_get_filename()
UpgradeStatus: Upgraded to quantal on 2012-08-17 (52 days ago)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo

Michael Hall (mhall119) wrote :

StacktraceTop:
 g_desktop_app_info_get_filename (info=info@entry=0x0) at /build/buildd/glib2.0-2.34.0/./gio/gdesktopappinfo.c:623
 unity_webapps_preinstalled_application_info_get_desktop_file_path (application_info=0x9912070) at unity-webapps-preinstalled-application-info.c:116
 unity_webapps_context_daemon_new () at unity-webapps-context-daemon.c:1171
 bus_get_cb (object=0x0, res=0x99120a8, user_data=0x0) at unity-webapps-context-daemon.c:269
 g_simple_async_result_complete (simple=simple@entry=0x99120a8) at /build/buildd/glib2.0-2.34.0/./gio/gsimpleasyncresult.c:775

Changed in libunity-webapps (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
information type: Private → Public
Changed in libunity-webapps:
importance: Undecided → Medium
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Maxim Ermilov (zaspire) on 2012-10-31
Changed in libunity-webapps:
assignee: Alexandre Abreu (abreu-alexandre) → Maxim Ermilov (zaspire)
Maxim Ermilov (zaspire) on 2012-11-02
Changed in libunity-webapps:
status: New → Fix Committed
milestone: none → 2.4.3
Maxim Ermilov (zaspire) on 2012-11-19
Changed in libunity-webapps:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libunity-webapps (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers