Sync libtorrent 0.12.5-2 (universe) from Debian testing (main)

Bug #477971 reported by Scott Kitterman on 2009-11-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libtorrent (Ubuntu)
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/libtorrent
 status confirmed
 importance wishlist
 subscribe ubuntu-archive
 done

Please sync libtorrent 0.12.5-2 (universe) from Debian testing (main)

Explanation of the Ubuntu delta and why it can be dropped:
All Ubuntu changes have been incorporated in Debian.

Changelog entries since current lucid version 0.12.2-0ubuntu2:

libtorrent (0.12.5-2) unstable; urgency=low

  [ Jose Luis Rivas ]
  * Updated debian/ChangeLog for 0.12.5.
  * Updated to Standards-Version 3.8.2 wo/ any change needed.

  [ Rogério Brito ]
  * Prepare for unstable. Thanks to both Dmitry and Jose.

 -- Rogério Brito <email address hidden> Mon, 03 Aug 2009 12:56:17 -0300

libtorrent (0.12.5-1) unstable; urgency=low

  * New upstream version.

 -- Dmitry E. Oboukhov <email address hidden> Tue, 30 Jun 2009 11:07:26 +0400

libtorrent (0.12.4+tit-2) unstable; urgency=low

  * Putting myself as the maintainer. Jose told me that he is busy with
    his duties and he is free to revert this change as he pleases.
  * Ubuntu people: please contribute your changes! Please.
  * debian/control: remove recommends of rtorrent in the package

 -- Rogério Brito <email address hidden> Sun, 17 May 2009 00:51:37 -0300

libtorrent (0.12.4+tit-1) unstable; urgency=low

  * Fixed incorrect merge of previous upload, closes: #527949,
    this version is really 0.12.4.
  * Now we use tar-in-tar build system (added +tit as suffix into version).

 -- Dmitry E. Oboukhov <email address hidden> Sat, 09 May 2009 20:27:09 +0400

libtorrent (0.12.4-2) unstable; urgency=low

  [ Rogério Brito ]
  * debian/changelog:
    + prepare an upload meant to unstable.
  * debian/copyright:
    + fix lintian warning regarding versionless link to GPL.
  * debian/control:
    + add myself as an uploader (discussed with Jose and Adeodato).
    + word-wrap the build dependencies field (for more legibility).
    + include ${misc:Depends} in the binary libtorrent-dev.
    + include comment at the top of the file (policy 3.8.1 allows it).
    + update Standards-Version to 3.8.1.
  * debian/rules:
    + add --as-needed linker option to reduce library dependencies.
    + TODO: create a -dbg package.
    + TODO: create a symbols file.
  * Notice: the library still doesn't provide symbol files because it
    seems to export many private symbols. This will be sent upstream (it
    is better than a Debian specific fix and it has been this way for
    quite some time now).
  * more changes to come in the near future.
  [ Dmitry E. Oboukhov ]
  * debian/control:
    + add myself as an uploader.

 -- Dmitry E. Oboukhov <email address hidden> Fri, 08 May 2009 20:17:41 +0400

libtorrent (0.12.4-1) experimental; urgency=low

  * New Upstream Version
  * Updated debian/ChangeLog file.
  * debian/copyright: Added copyright notice of src/utils/sha_fast.*

 -- Jose Luis Rivas <email address hidden> Wed, 19 Nov 2008 13:54:25 -0430

libtorrent (0.12.3-1) experimental; urgency=low

  * New upstream release.
  * Patches are applied from upstream, deleted.
  * Updated build-depends and added libcurl4-openssl-dev.
  * Bumped to 3.8.0 Standards-Version
  * Bumped libtorrent10 to libtorrent11 by SONAME version.
  * Refreshed debian/copyright.
  * Removed Arnaud Andesi from Uploaders.
  * Removed XS- From Vcs fields and updated these fields.
  * Updated debian/ChangeLog file.

 -- Jose Luis Rivas <email address hidden> Mon, 17 Nov 2008 23:48:01 -0430

libtorrent (0.12.2-1) experimental; urgency=low

  * New upstream release
  * Deleted debian/patches/update-changelog.patch:
   + Now is shipped in a plain text file, easier to maintain.
  * debian/control:
   + Added "by Rakshasa" to the short description of the package.

 -- Jose Luis Rivas <email address hidden> Thu, 08 May 2008 22:51:25 -0430

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (GNU/Linux)

iEYEARECAAYFAkr2H5EACgkQHajaM93NaGpeTgCfXuGr43y1W0sCsksGdSCigSyB
AvMAnjVhbi2H6nobAAoHthR9F1gcMZTz
=rjkA
-----END PGP SIGNATURE-----

Sebastien Bacher (seb128) wrote :

[Updating] libtorrent (0.12.2-0ubuntu2 [Ubuntu] < 0.12.5-2 [Debian])
 * Trying to add libtorrent...
  - <libtorrent_0.12.5-2.dsc: downloading from http://ftp.debian.org/debian/>
  - <libtorrent_0.12.5-2.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <libtorrent_0.12.5.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
I: libtorrent [universe] -> libtorrent-dev_0.12.2-0ubuntu2 [universe].
I: libtorrent [universe] -> libtorrent11_0.12.2-0ubuntu2 [universe].

Changed in libtorrent (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers