link_all_deplibs=no patch no longer working well

Bug #258491 reported by Olly Betts
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libtool (Ubuntu)
Fix Released
Medium
Scott James Remnant (Canonical)
Intrepid
Won't Fix
Medium
Scott James Remnant (Canonical)

Bug Description

Binary package hint: libtool

It appears that the link_all_deplibs=no patch hasn't been correctly updated for libtool 2.2.x.

The binaries in xapian-omega link against libxapian which has a dependency on libz, but the binaries don't require libz themselves. So to avoid explicitly linking with libz, xapian-omega's debian/rules runs autoreconf (which runs libtoolize) to pick up this patch. This works as expected with libtool 1.5.26-4, but with libtool 2.2.4-0ubuntu3 the link command run by libtool contains -lz (and so xapian-omega FTBFS since it doesn't have a build dependency on zlib1g-dev).

The attached patch against ltmain.sh fixes this for me, but I'm not certain if it is the correct fix, or if it is, if more cases should be handled. I added echos to trace how deplibs changes through the execution of the libtool script, and it seems rather complicated.

Revision history for this message
Olly Betts (ojwb) wrote :
Revision history for this message
Olly Betts (ojwb) wrote :

The xapian-omega FTBFS bug is LP257755.

Revision history for this message
Olly Betts (ojwb) wrote :

Hmm, that didn't create a link automatically. See:
https://bugs.launchpad.net/ubuntu/+source/xapian-omega/+bug/257755

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Will review and test patch after Alpha Freeze,

Changed in libtool:
assignee: nobody → scott
importance: Undecided → High
status: New → Confirmed
Revision history for this message
James Westby (james-w) wrote :

Hi Scott,

Do you have time to review this patch?

It's said to be causing a build failure, and I don't want to sponsor
a workaround for that package if this will be fixed soon.

Thanks,

James

Revision history for this message
Olly Betts (ojwb) wrote :

Luca Falavigna has already uploaded a xapian-omega package with a workaround:

https://launchpad.net/ubuntu/+source/xapian-omega

But this is a regression in the debian version of libtool which is likely to make some other packages in intrepid FTBFS in a similar way (if they've not been updated since libtool was updated from 1.5.x to 2.2.x).

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

I have not yet had time to test or review, if anyone else wants to take a look, please be my guest

Changed in libtool:
importance: High → Medium
Revision history for this message
wlx (wangliangxu) wrote :

Just want to know the status of this bug, and this bug maybe caused by it: https://bugs.launchpad.net/ubuntu/+source/gdal/+bug/271670

Revision history for this message
Olly Betts (ojwb) wrote :

wlx: That bug doesn't look connected to me.

This bug is that the patch Debian apply to libtool to stop it explicitly linking with a library's dependencies hasn't been correctly updated to work with libtool >= 2.2. The effect is that more libraries are linked against than would be if the patch worked correctly.

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Shouldn't be release targeted - this should reopen task on development package

Changed in libtool:
status: Confirmed → Won't Fix
Revision history for this message
Sebastien Bacher (seb128) wrote :

the bug is still on the sponsoring list, scott could you review the change?

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

I still have not had time to do so.

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

This is very much still on my radar, I've tested it a couple of times but still need more time to assure its correctness

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

An updated version of the original patch was included in Debian, and is now in the karmic source package

Changed in libtool (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers