libtool and libtool-doc 2.4.6-12 both contain /usr/share/doc/libtool/AUTHORS causing upgrade failures

Bug #1863356 reported by Steve Beattie on 2020-02-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libtool (Debian)
Fix Released
Unknown
libtool (Ubuntu)
Undecided
Unassigned

Bug Description

Unpacking libtool-doc (2.4.6-12) over (2.4.6-11) ...
dpkg: error processing archive /tmp/apt-dpkg-install-tTUGeR/289-libtool-doc_2.4.6-12_all.deb (--unpack):
 trying to overwrite '/usr/share/doc/libtool/AUTHORS', which is also in package libtool 2.4.6-12
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: libtool 2.4.6-12
ProcVersionSignature: Ubuntu 5.4.0-9.12-generic 5.4.3
Uname: Linux 5.4.0-9-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu16
Architecture: amd64
CurrentDesktop: i3
Date: Fri Feb 14 09:04:32 2020
InstallationDate: Installed on 2017-12-15 (790 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
PackageArchitecture: all
ProcEnviron:
 TERM=screen.xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libtool
UpgradeStatus: Upgraded to focal on 2019-09-23 (144 days ago)

Steve Beattie (sbeattie) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libtool (Ubuntu):
status: New → Confirmed
Changed in libtool (Debian):
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

The issue has been fixed in that update, https://launchpad.net/ubuntu/+source/libtool/2.4.6-14

Changed in libtool (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.