This doesn't work: perl -e 'use Template'

Bug #1776705 reported by Martin VanWinkle III on 2018-06-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libtemplate-perl (Ubuntu)
Undecided
Unassigned

Bug Description

Reproducing problem:

$ apt-get install libtemplate-perl
$ perl -e 'use Template'
ListUtil.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xde00080)

1) Release of ubuntu
$ lsb_release -rd
Description: Ubuntu 18.04 LTS
Release: 18.04

2) Version of package:
$ apt-cache policy libtemplate-perl
libtemplate-perl:
  Installed: 2.27-1
  Candidate: 2.27-1
  Version table:
 *** 2.27-1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status

3) What I expected: being able to load the module
4) What happened: Perl exited

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libtemplate-perl 2.27-1
ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
Uname: Linux 4.15.0-23-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Jun 13 12:13:58 2018
InstallationDate: Installed on 2018-06-13 (0 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libtemplate-perl
UpgradeStatus: No upgrade log present (probably fresh install)

This can be closed. I had pulled a ~/perl5 directory from a previous installation that was including libraries compiled for different versions.

Sorry about this.

Changed in libtemplate-perl (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers