FTBFS: libswe-doc 1.80.00.0001-1 build-depends on unavailable package python-uno

Bug #1290037 reported by Hans Joachim Desserud on 2014-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libswe-doc (Ubuntu)
Undecided
Colin Watson

Bug Description

libswe-doc 1.80.00.0001-1 fails to build becaus it depends on python-uno which is not available

Package python-uno is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libreoffice-script-provider-python

E: Package 'python-uno' has no installation candidate
apt-get failed.
Package installation failed

https://launchpad.net/ubuntu/+source/libswe-doc/1.80.00.0001-1/+build/5207509

I briefly looked at this and it turns out that python-uno is offered by the Debian package of LibreOffice[1], but it is not present in the Ubuntu package[2].

[1] http://packages.qa.debian.org/libr/libreoffice.html
[2] https://launchpad.net/ubuntu/+source/libreoffice

Colin Watson (cjwatson) wrote :

It's been removed from libreoffice in Debian experimental too, so this ought to just be fixed in libswe-doc.

no longer affects: libreoffice (Ubuntu)
Changed in libswe-doc (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libswe-doc - 1.80.00.0001-1ubuntu1

---------------
libswe-doc (1.80.00.0001-1ubuntu1) vivid; urgency=medium

  * Port DocumentConverter.py to Python 3 (LP: #1290037).
 -- Colin Watson <email address hidden> Wed, 10 Dec 2014 14:32:53 +0000

Changed in libswe-doc (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers