pkg-config does not find libsvm

Bug #581174 reported by sds on 2010-05-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libsvm (Ubuntu)
Undecided
Unassigned

Bug Description

I don't know why you placed libsvm-dev under pkg-config's provenance (it has nothing to do with gnome!)
but it worked in karmic with
PKG_CHECK_MODULES([LIBSVM],[libsvm],...)
but does not work with lucid

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04 LTS"

$ aptitude show libsvm-dev
Package: libsvm-dev
State: installed
Version: 2.90-1

$ pkg-config libsvm
fails
$ pkg-config --list-all|grep svm
fails
$ ls /usr/include/libsvm-2.0/libsvm/svm.h
4 /usr/include/libsvm-2.0/libsvm/svm.h

Michael Bienia (geser) wrote :

Not surprising as libsvm-dev 2.90-1 (in lucid) doesn't ship a .pc file (for pkg-config) anymore and doesn't depend on pkg-config anymore either. This change was done by the Debian maintainer of libsvm.
From the Debian changelog for libsvm 2.90-1:
 * Removed libsvm.pc from libsvm-dev.

Changed in libsvm (Ubuntu):
status: New → Invalid
sds (sds-gnu) wrote :

in that case you should install svm.h in /usr/include/, not /usr/include/libsvm-2.0/libsvm/
this is still a bug!

Changed in libsvm (Ubuntu):
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers