libspring-2.5-java needs an initial manual build

Bug #642344 reported by Matthias Klose on 2010-09-18
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libhibernate3-java (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
libspring-2.5-java (Ubuntu)
High
LaMont Jones
Maverick
High
LaMont Jones

Bug Description

please build libspring-2.5-java using the binary package libtiles-java 2.2.2-1 from Debian unstable. after the libspring-2.5-java package is built, tiles can be built with the new binary packages.

we missed this for lucid too, please let's do that for maverick.

Matthias Klose (doko) on 2010-09-18
Changed in libspring-2.5-java (Ubuntu):
assignee: nobody → LaMont Jones (lamont)
importance: Undecided → High
milestone: none → ubuntu-10.10
status: New → Confirmed
Matthias Klose (doko) wrote :

need syncs for the following packages from unstable:

 - mojarra
 - geronimo-commonj-spec
 - libhibernate3-java

The first two not in maverick, the last one in universe.

Checked that these packages are buildable with existing build dependencies in maverick

Colin Watson (cjwatson) wrote :

Yes, these syncs look OK to me. Subscribing ubuntu-archive.

Colin Watson (cjwatson) wrote :

[Updating] libhibernate3-java (3.3.2.GA-2 [Ubuntu] < 3.5.4.Final-4 [Debian])
 * Trying to add libhibernate3-java...
2010-09-28 15:52:48 INFO - <libhibernate3-java_3.5.4.Final-4.dsc: downloading from http://ftp.debian.org/debian/>
2010-09-28 15:52:48 INFO - <libhibernate3-java_3.5.4.Final.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-09-28 15:52:50 INFO - <libhibernate3-java_3.5.4.Final-4.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
I: libhibernate3-java [universe] -> libhibernate3-java_3.3.2.GA-2 [universe].
I: libhibernate3-java [universe] -> libhibernate3-java-doc_3.3.2.GA-2 [universe].

Changed in libhibernate3-java (Ubuntu Maverick):
status: New → Fix Released
Matthias Klose (doko) wrote :

more changes required:

 - libcommons-fileupload-java-universe is a copy of libcommons-fileupload-java
   with the filupload portlet classes included (see bug #635895).

 - the libstruts1.2-java_1.2.9-4ubuntu1 and solr_1.4.0+ds1-2ubuntu1 and this
   as an alternative dependency.

 - and libspring-2.5-java only using the libcommons-fileupload-java-universe
   package.

Matthias Klose (doko) wrote :

hmm, tiles needs mvel2, just copied the debian source and renamed it to mvel2 (mvel1 is in main), and made tiles using it.

Scott Kitterman (kitterman) wrote :

mvel2 source accepted.

Matthias Klose (doko) wrote :

now all built, after some three more manual builds and ten other syncs and merges

Changed in libspring-2.5-java (Ubuntu Maverick):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers