[regression] eps file blank in evince 2.24, renders correctly in 2.22

Bug #240644 reported by sam tygier on 2008-06-17
This bug report is a duplicate of:  Bug #552990: evince does not display EPS file. Edit Remove
8
Affects Status Importance Assigned to Milestone
Evince
Unknown
Unknown
libspectre (Ubuntu)
Low
Unassigned

Bug Description

this eps file was created from a png file with "convert hoz_stab.png eps3:hoz_stab-bitmap.eps"

the file seems to render properly in evince 2.22, but not in 2.24 (regression?)

after converting to pdf (ps2pdf), the pdf file is rendered correctly in evince 2.24

sam tygier (samtygier) wrote :
Pedro Villavicencio (pedro) wrote :

thanks for the report, what's the output of gconftool-2 -g /desktop/gnome/thumbnailers/image@x-eps/command ?

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
sam tygier (samtygier) wrote :

evince-thumbnailer -s %s %u %o

Sebastien Bacher (seb128) wrote :

could you attach an example to the bug?

sam tygier (samtygier) wrote :

the eps file is already attached to the first comment

Sebastien Bacher (seb128) wrote :

on intrepid the example is not rendered correctly but as a white page too

Changed in evince:
status: Incomplete → New
Dimitrios Symeonidis (azimout) wrote :

i confirm sebastien's observation: the thumbnail is white, but it also opens as a blank white page in evince. instead, after ps2pdf (see attachment), i can correctly see both the thumbnail and the actual file in evince..

description: updated
Dimitrios Symeonidis (azimout) wrote :

samtygier, can you confirm this in Intrepid?

Changed in evince:
status: New → Confirmed
sam tygier (samtygier) wrote :

on intrepid:
the eps thumbnail is blank, and the eps viewed in evince is blank.
the pdf (either from dimitrios's attachment, or made myself with ps2pdf) the thumbnail contains the graph, and it renders in evince. (though it is badly cropped in both, not sure if this is related)

sam tygier (samtygier) wrote :

also still the case in jaunty

Bartosz Wierzejewski (bartekw) wrote :

I have this same on 2.26.1 :(

Pedro Villavicencio (pedro) wrote :

could somebody having the issue send it upstream to bugzilla.gnome.org ? Thanks!.

Jochen Schroeder (cyco) wrote :

I'm also experiencing this bug with several of my eps files. This seems to be happening mostly with eps files generated with matplotlib. Once the same files are converted to pdf or are included inside latex documents (both ps or pdf output) they display fine. I've filed a bug upstream (bug 604037 on bugzilla.gnome.org).

Ubuntu Karmic
evince --version
GNOME Document Viewer 2.28.1

Dimitrios Symeonidis (azimout) wrote :

thank you cyco. i have added the bug watch. for the future, you can do this by clicking on "also affects project" and pasting the upstream bug url.

Pedro Villavicencio (pedro) wrote :

comment from upstream: "It's a libspectre issue, running the ps scanner with the option to ignore EOF
comments fixes the problem, but I don't know whether it might break other
documents. Could you please forward this bug to freedesktop bugzilla?"

reassigning to libspectre.

affects: evince (Ubuntu) → libspectre (Ubuntu)
Changed in libspectre (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Confirmed → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.