package libsoup2.4-1 2.38.0-1 [modified: usr/share/doc/libsoup2.4-1/changelog.Debian.gz] failed to install/upgrade: libsoup2.4-1:amd64 2.38.0-1 cannot be configured because libsoup2.4-1

Bug #991519 reported by Merid Ljesnjanin on 2012-04-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libsoup2.4 (Ubuntu)
Undecided
Unassigned

Bug Description

meridl@ubuntu:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libsoup-gnome2.4-1 : Breaks: libsoup-gnome2.4-1:i386 (!= 2.38.0-1) but 2.38.0-0ubuntu1 is installed
 libsoup-gnome2.4-1:i386 : Breaks: libsoup-gnome2.4-1 (!= 2.38.0-0ubuntu1) but 2.38.0-1 is installed
 libsoup2.4-1 : Breaks: libsoup2.4-1:i386 (!= 2.38.0-1) but 2.38.0-0ubuntu1 is installed
 libsoup2.4-1:i386 : Breaks: libsoup2.4-1 (!= 2.38.0-0ubuntu1) but 2.38.0-1 is installed
E: Unmet dependencies. Try using -f.
meridl@ubuntu:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libssl1.0.0:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libsoup-gnome2.4-1 libsoup-gnome2.4-1:i386 libsoup2.4-1 libsoup2.4-1:i386
The following packages will be upgraded:
  libsoup-gnome2.4-1 libsoup-gnome2.4-1:i386 libsoup2.4-1 libsoup2.4-1:i386
4 upgraded, 0 newly installed, 0 to remove and 788 not upgraded.
5 not fully installed or removed.
Need to get 0 B/441 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? n
Abort.
meridl@ubuntu:~$ sudo apt-get autoremove\
> sudo apt-get autoremov
E: Invalid operation autoremovesudo
meridl@ubuntu:~$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libsoup-gnome2.4-1 : Breaks: libsoup-gnome2.4-1:i386 (!= 2.38.0-1) but 2.38.0-0ubuntu1 is installed
 libsoup-gnome2.4-1:i386 : Breaks: libsoup-gnome2.4-1 (!= 2.38.0-0ubuntu1) but 2.38.0-1 is installed
 libsoup2.4-1 : Breaks: libsoup2.4-1:i386 (!= 2.38.0-1) but 2.38.0-0ubuntu1 is installed
 libsoup2.4-1:i386 : Breaks: libsoup2.4-1 (!= 2.38.0-0ubuntu1) but 2.38.0-1 is installed
E: Unmet dependencies. Try using -f.
meridl@ubuntu:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libssl1.0.0:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libsoup-gnome2.4-1 libsoup-gnome2.4-1:i386 libsoup2.4-1 libsoup2.4-1:i386
The following packages will be upgraded:
  libsoup-gnome2.4-1 libsoup-gnome2.4-1:i386 libsoup2.4-1 libsoup2.4-1:i386
4 upgraded, 0 newly installed, 0 to remove and 788 not upgraded.
5 not fully installed or removed.
Need to get 0 B/441 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: error processing libsoup2.4-1 (--configure):
 libsoup2.4-1:amd64 2.38.0-1 cannot be configured because libsoup2.4-1:i386 is in a different version (2.38.0-0ubuntu1)
dpkg: error processing libsoup2.4-1:i386 (--configure):
 libsoup2.4-1:i386 2.38.0-0ubuntu1 cannot be configured because libsoup2.4-1:amd64 is in a different version (2.38.0-1)
No apport report written because MaxReports is reached already
                                                              dpkg: error processing libsoup-gnome2.4-1:i386 (--configure):
 libsoup-gnome2.4-1:i386 2.38.0-0ubuntu1 cannot be configured because libsoup-gnome2.4-1:amd64 is in a different version (2.38.0-1)
dpkg: error processing libsoup-gnome2.4-1 (--configure):
 libsoup-gnome2.4-1:amd64 2.38.0-1 cannot be configured because libsoup-gnome2.4-1:i386 is in a different version (2.38.0-0ubuntu1)
dpkg: dependency problems prevent configuration of gstreamer0.10-plugins-good:i386:
 gstreamer0.10-plugins-good:i386 depends on libsoup-gnome2.4-1 (>= 2.27.4); however:
  Package libsoup-gnome2.4-1:i386 is not configured yet.
 gstreamer0.10-plugins-good:i386 depends on libsoup2.4-1 (>= 2.26.1); however:
  Package libsoup2.4-1:i386 is not configured yet.
dpkg: error processing gstreamer0.10-plugins-good:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 libsoup2.4-1
 libsoup2.4-1:i386
 libsoup-gnome2.4-1:i386
 libsoup-gnome2.4-1
 gstreamer0.10-plugins-good:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
meridl@ubuntu:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libssl1.0.0:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libsoup-gnome2.4-1 libsoup-gnome2.4-1:i386 libsoup2.4-1 libsoup2.4-1:i386
The following packages will be upgraded:
  libsoup-gnome2.4-1 libsoup-gnome2.4-1:i386 libsoup2.4-1 libsoup2.4-1:i386
4 upgraded, 0 newly installed, 0 to remove and 788 not upgraded.
5 not fully installed or removed.
Need to get 0 B/441 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? n
Abort.
meridl@ubuntu:~$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libsoup-gnome2.4-1 : Breaks: libsoup-gnome2.4-1:i386 (!= 2.38.0-1) but 2.38.0-0ubuntu1 is installed
 libsoup-gnome2.4-1:i386 : Breaks: libsoup-gnome2.4-1 (!= 2.38.0-0ubuntu1) but 2.38.0-1 is installed
 libsoup2.4-1 : Breaks: libsoup2.4-1:i386 (!= 2.38.0-1) but 2.38.0-0ubuntu1 is installed
 libsoup2.4-1:i386 : Breaks: libsoup2.4-1 (!= 2.38.0-0ubuntu1) but 2.38.0-1 is installed
E: Unmet dependencies. Try using -f.
meridl@ubuntu:~$ sudo apt-get -f autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libsoup-gnome2.4-1 libsoup-gnome2.4-1:i386 libsoup2.4-1 libsoup2.4-1:i386
The following packages will be REMOVED:
  libssl1.0.0:i386
The following packages will be upgraded:
  libsoup-gnome2.4-1 libsoup-gnome2.4-1:i386 libsoup2.4-1 libsoup2.4-1:i386
4 upgraded, 0 newly installed, 1 to remove and 787 not upgraded.
5 not fully installed or removed.
Need to get 0 B/441 kB of archives.
After this operation, 2,742 kB disk space will be freed.
Do you want to continue [Y/n]? y
dpkg: error processing libsoup2.4-1 (--configure):
 libsoup2.4-1:amd64 2.38.0-1 cannot be configured because libsoup2.4-1:i386 is in a different version (2.38.0-0ubuntu1)
dpkg: error processing libsoup2.4-1:i386 (--configure):
 libsoup2.4-1:i386 2.38.0-0ubuntu1 cannot be configured because libsoup2.4-1:amd64 is in a different version (2.38.0-1)
dpkg: error processing libsoup-gnome2.4-1:i386 (--configure):
 libsoup-gnome2.4-1:i386 2.38.0-0ubuntu1 cannot be configured because libsoup-gnome2.4-1:amd64 is in a different version (2.38.0-1)
No apport report written because MaxReports is reached already
                                                              dpkg: error processing libsoup-gnome2.4-1 (--configure):
 libsoup-gnome2.4-1:amd64 2.38.0-1 cannot be configured because libsoup-gnome2.4-1:i386 is in a different version (2.38.0-0ubuntu1)
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 libsoup2.4-1
 libsoup2.4-1:i386
 libsoup-gnome2.4-1:i386
 libsoup-gnome2.4-1
E: Sub-process /usr/bin/dpkg returned an error code (1)
meridl@ubuntu:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libssl1.0.0:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libsoup-gnome2.4-1 libsoup-gnome2.4-1:i386 libsoup2.4-1 libsoup2.4-1:i386
The following packages will be upgraded:
  libsoup-gnome2.4-1 libsoup-gnome2.4-1:i386 libsoup2.4-1 libsoup2.4-1:i386
4 upgraded, 0 newly installed, 0 to remove and 788 not upgraded.
5 not fully installed or removed.
Need to get 0 B/441 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: error processing libsoup2.4-1 (--configure):
 libsoup2.4-1:amd64 2.38.0-1 cannot be configured because libsoup2.4-1:i386 is in a different version (2.38.0-0ubuntu1)
dpkg: error processing libsoup2.4-1:i386 (--configure):
 libsoup2.4-1:i386 2.38.0-0ubuntu1 cannot be configured because libsoup2.4-1:amd64 is in a different version (2.38.0-1)
dpkg: error processing libsoup-gnome2.4-1:i386 (--configure):
 libsoup-gnome2.4-1:i386 2.38.0-0ubuntu1 cannot be configured because libsoup-gnome2.4-1:amd64 is in a different version (2.38.0-1)
E: Sub-process /usr/bin/dpkg returned an error code (1)
meridl@ubuntu:~$

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libsoup2.4-1 2.38.0-1 [modified: usr/share/doc/libsoup2.4-1/changelog.Debian.gz]
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
Date: Mon Apr 30 08:34:24 2012
ErrorMessage: libsoup2.4-1:amd64 2.38.0-1 cannot be configured because libsoup2.4-1
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
SourcePackage: libsoup2.4
Title: package libsoup2.4-1 2.38.0-1 [modified: usr/share/doc/libsoup2.4-1/changelog.Debian.gz] failed to install/upgrade: libsoup2.4-1:amd64 2.38.0-1 cannot be configured because libsoup2.4-1
UpgradeStatus: Upgraded to precise on 2012-04-03 (26 days ago)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers