2.37.91: **: soup_uri_set_path: assertion `path != NULL' failed

Bug #928820 reported by dino99 on 2012-02-08
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libsoup
Fix Released
Medium
libsoup2.4 (Ubuntu)
High
Unassigned
midori (Ubuntu)
Undecided
Unassigned

Bug Description

get this error logged a lot of times on Precise i386 logged as gnome-classic

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libsoup2.4-1 2.37.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-14.23-generic-pae 3.2.3
Uname: Linux 3.2.0-14-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Wed Feb 8 14:05:41 2012
SourcePackage: libsoup2.4
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

dino99 (9d9) wrote :
Dan Winship (danw-gnome) wrote :

what app are the warnings coming from?

Jamie Strandboge (jdstrand) wrote :

I see this with rhythmbox:
(15:13:20) [0x2441460] [libdmapsharing_debug] rb-daap-plugin.c:617: Getting DAAP server info

libsoup-CRITICAL **: soup_uri_new_with_base: assertion `base == NULL || SOUP_URI_IS_VALID (base)' failed
(15:13:20) [0x2441460] [libdmapsharing_debug] rb-daap-plugin.c:617: Error building message for http://192.168.2.2:3689//server-info
(15:13:20) [0x2441460] [libdmapsharing_debug] rb-daap-plugin.c:617: Could not get DAAP connection info

which causes it to fail to load my daap shares.

Jamie Strandboge (jdstrand) wrote :

Err, wrong bug, sorry.

dino99 (9d9) wrote :

xsession-errors does not give info about the app sending this error, but on my system it is logged after i start midori, so it could be one of its dependencies. Strangely the same error is logged repeatly even if i let the system alone without user action, meaning that only the active process in the background can produce this error.

dino99 (9d9) wrote :

In case of possible relationship with internet communication, this system use wicd.

dino99 (9d9) wrote :

** CRITICAL **: midori_browser_notebook_resize: assertion `n > 0' failed

libsoup-CRITICAL **: soup_uri_set_path: assertion `path != NULL' failed

Dan Winship (danw-gnome) wrote :

can someone try building a new package with this patch, and see if it fixes things?

(there will still be warnings, but the code should work despite the warnings now)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libsoup2.4 (Ubuntu):
status: New → Confirmed

The attachment "0001-soup-uri-revert-some-of-the-previously-added-return-.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

The patch fixes my rhythmbox/libdmapsharing bug #929133 (dupe of this one). I uploaded test packages to my ppa: https://launchpad.net/~jdstrand/+archive/ppa (amd64 has started building, i386 hasn't yet) if others want to test.

summary: - libsoup-CRITICAL **: soup_uri_set_path: assertion `path != NULL' failed
+ 2.37.5: **: soup_uri_set_path: assertion `path != NULL' failed
Changed in libsoup2.4 (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Committed

This bug was fixed in the package libsoup2.4 - 2.37.5.1-0ubuntu1

---------------
libsoup2.4 (2.37.5.1-0ubuntu1) precise; urgency=low

  * New upstream version (lp: #928820)
 -- Sebastien Bacher <email address hidden> Fri, 10 Feb 2012 17:26:01 +0100

Changed in libsoup2.4 (Ubuntu):
status: Fix Committed → Fix Released
Changed in libsoup:
importance: Unknown → Medium
status: Unknown → Fix Released

Sadly even with this new 2.37.5.1-0ubuntu1 installed, and a cold boot later, i still get that logged when i use midori. (see xsession-errors attached)

summary: - 2.37.5: **: soup_uri_set_path: assertion `path != NULL' failed
+ 2.37.5.1: **: soup_uri_set_path: assertion `path != NULL' failed
dino99 (9d9) on 2012-02-11
summary: - 2.37.5.1: **: soup_uri_set_path: assertion `path != NULL' failed
+ 2.37.5: **: soup_uri_set_path: assertion `path != NULL' failed

Still not fixed with 2.37.91-0ubuntu1 on Precise i386 (see bug #930630 )

summary: - 2.37.5: **: soup_uri_set_path: assertion `path != NULL' failed
+ 2.37.91: **: soup_uri_set_path: assertion `path != NULL' failed
dino99 (9d9) on 2013-04-26
Changed in midori (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.