Ubuntu

Clock and Weather applet don't show any weather info

Reported by atos on 2009-05-06
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
High
libsoup2.4 (Ubuntu)
Low
Ubuntu Desktop Bugs
Declined for Jaunty by Sebastien Bacher
Nominated for Karmic by Suparshwa Shah

Bug Description

Binary package hint: gnome-applets

It is a freshly installed Ubuntu 9.04 (64 bit) laptop.
On the UI Clock (2.26.0) applet seems to provide more space for the weather info (as it is a bit wider)
but no weather and temperature are displayed.
For a 2nd test I configured Weather Report (2.26.0). Its tooltip says "Updating..." and after a while "Retrieval failed".

- I have already uninstalled gnome-panel (1:2.26.0-0ubuntu7) and installed again.
- I have already tested with a new user account.
- My timezone (Europe/Budapest) is the same as the location set in both applets.
None of these helped.

I moved from a 8.04 desktop where Clock was working perfect...
Any help is highly appreciated.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, can you test with other locations? is only budapest not working?

Changed in gnome-applets (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
tags: added: likely-dup
atos (raczatt) wrote :

I have tested with some other locations in Europe/America/Australia.
None was showing any weather info in both applets.

atos (raczatt) wrote :

One friend just upgraded Ubuntu 8.10 (32 bit) to 9.04 and the weather info in the Clock applet is gone however it was OK on 8.10.

John Franklin (hondaman-nc) wrote :

I have upgraded from 8.10 to 9.04 and the Weather Report 2.26.1 applet does not retrieve the weather. I also get the "Updating..." and "Retrieval failed" tooltips. Also asked in ubuntuforums http://ubuntuforums.org/showthread.php?t=1146941 with no reply. No other cities work for me either. Used with both the LAN and wifi without success. Thanks. John

Sebastien Bacher (seb128) wrote :

could you take a screenshot showing the details of the location properties which doesn't work correctly?

atos (raczatt) wrote :
Sebastien Bacher (seb128) wrote :

could you select the line, click edit and take a screenshot of this dialog?

atos (raczatt) wrote :
John Franklin (hondaman-nc) wrote :
John Franklin (hondaman-nc) wrote :
John Franklin (hondaman-nc) wrote :
Sebastien Bacher (seb128) wrote :

do you get the issue if you add the location on a fresh user account? do you use network manager? is it connected?

John Franklin (hondaman-nc) wrote :

Okay, the problem does go away when creating a new account. Why would that be? Can I delete some weather report applet configuration files within my home directory?

Yes, I do use network manager and it is connected.

Sebastien Bacher (seb128) wrote :

do you still get the issue if you delete the location and add it again?

affects: gnome-applets (Ubuntu) → gnome-panel (Ubuntu)
affects: gnome-panel (Ubuntu) → gnome-applets (Ubuntu)
affects: gnome-applets (Ubuntu) → gnome-panel (Ubuntu)
atos (raczatt) wrote :

I have created a brand new account. No weather info is displayed on Clock and Weather Report.
I have deleted and added again locations. Nothing has changed.

I use network manager and the line is active.

John Franklin (hondaman-nc) wrote :

Nope. Changing the location in weather report applet or deleting and adding the location in the clock applet does not make it work.
However, I did rename ~/.gconf to ~/.gconf.bak and it worked and lost all of my other settings. After renaming ~/.gconf.bak to ~/.gconf the problem persists.

atos (raczatt) wrote :

I have tried on a DSL line without proxy ("Direct Internet connection") and there both applets are showing
weather info. However behind a proxy they are not even if I set the proxy with "Apply System-Wide...".
How does the Clock applet use the network through a proxy?

I have found the Clock applet related files under ~/.gconf/apps/panel/applets/applet_3/ but I guess it's varying.

Sebastien Bacher (seb128) wrote :

there seem to be different issues there, one being a configuration one and one being proxy use, somebody having the issue with the proxy should open the bug on bugzilla.gnome.org where the software writters will read it

John Franklin (hondaman-nc) wrote :

Success! I searched for [ubuntu gnome "weather report" configuration] on Google and returned this page https://bugs.launchpad.net/ubuntu/+source/gnome-applets/+bug/49736. I changed ~/.gconf/system to ~/.gconf/system.bak and logged out and back in. And this resolved it for me.
My ~/.gconf/system (now ~/.gconf/system.bak) had the following directories in it:
gstreamer
http_proxy
networking
proxy
I am going to delete the system.bak directory now. The recreated ~/.gconf/system only has the directory "networking" in it. This might have been due to installing and uninstalling firestarter in the past, I am not sure.
Hope this helps someone.
John

Sebastien Bacher (seb128) wrote :

did you have a proxy configured?

John Franklin (hondaman-nc) wrote :

Not intentionally. I do not need proxy settings, everything thing is taken care of by my firewall/NAT/dhcp server. I may have installed something which uses proxy settings or a proxy configurator in the past and not know what it was. This computer is the first I converted to Ubuntu (started with 8.04) and installed a few things when I first started which have since been removed.
How would I check proxy configurations?

Sebastien Bacher (seb128) wrote :

is there any of those configured in the GNOME proxy dialog?

atos (raczatt) wrote :

I have now Ubuntu
- 9.04 laptop
- 8.10 laptop
- 8.04 desktop
side by side with exactly the same proxy settings.
Clock and Weather Report on 8.04 and 8.10 correctly show weather info but on 9.04 they not.
This is why I think the issue is with the applets (retrieve data through proxy) in 9.04.

John Franklin (hondaman-nc) wrote :

Okay, I found System -> Preferences -> Network Proxy. The settings are the same as my desktop Ubuntu installation. Are this the settings you were referring to?
Also, I have deleted the ~/.gconf/system.bak, so I do not have a means to recreate the problem. I apologize for not keeping it for diagnostic reasons. I also checked the Synaptic Package Manager and found no extra proxy configurations or settings as compared against my desktop. The desktop is a more recent installation, but had it since before December 2008.

Sebastien Bacher (seb128) wrote :

right, those are the GNOME proxy settings

Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gnome-panel (Ubuntu):
status: Incomplete → New
atos (raczatt) wrote :
Changed in gnome-panel (Ubuntu):
status: New → Triaged
Changed in gnome-panel:
status: Unknown → Confirmed
rCX (rcx) wrote :

I had the same problem. John Franklin's suggestion to rename "~/.gconf/system" to "~/.gconf/system.bak" fixed. (Thanks!) I had to reenter my wireless settings though...

Pedro Villavicencio (pedro) wrote :

that's a libsoup issue and should be fixed on karmic, does anybody experience the same there with karmic?

affects: gnome-panel (Ubuntu) → libsoup2.4 (Ubuntu)
Changed in libsoup2.4 (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-panel:
status: Confirmed → Unknown
Changed in gnome-panel:
status: Unknown → Fix Released
Jan Groenewald (jan-aims) wrote :

Confirmed on Jaunty 64bit with backports.

I have several locations on my clock applet. I do not want
a separate weather applet (though forecasts would be nice
in the clock applet that is not the main issue).

My proxy is set system-wide, all other internet is working
in various applications and software updates.

My timezone is Africa/Johannesburg, which is not one of
my locations. These are Cape Town, Cairo, Accra, Dakar, Kampala,
Antananarivo, etc.

I would like to see the weather for all of these in the clock applet.

Cross (strokemeister) wrote :

I'm having this problem too.

My Clock Applet is showing the weather but not changing, well it is just showing the same weather all the day (Moon and 15ºC).

Maybe libsoup is updated soon :\

James Michael Fultz (croooow) wrote :

Running Ubuntu 9.10 RC, packages are up-to-date, no network proxy set. Clock applet in panel does not display weather or temperature information regardless of location setting.

James Michael Fultz, try rewrite your location

Queery1985 (djnoeth) wrote :

In 9.04 I had the problem with my proxy and the applets not connecting through it, the fix was easy. System -> Preferences -> Network Proxy then add the proxy settings in manual proxy configuration, but selected Automatic proxy configuration. It seemed as if the Applets only checked the Manual Proxy Config. But now in 9.04 this does not work any more.

jaybe1966 (jaybe1966) wrote :

The bug still exists in 9.10, see this bug report I created: https://bugs.launchpad.net/ubuntu/+source/gnome-applets/+bug/484105

atos (raczatt) wrote :

It seems to be fixed in 10.04 beta 1 (containing libsoup2.4-1).

Still a problem for me in lucid.

Hi Berend

On Thu, Jun 10, 2010 at 11:22:32AM -0000, Berend De Schouwer wrote:
> Still a problem for me in lucid.

Fixed for me in lucid after a clean install.

Did you dist-upgrade from karmic? Try remove the clock
from the panel, and add it again and reconfigure,
and log out and in to see it is OK.

Removed and added. It's still a problem.

Bowmore (bowmore) wrote :

Doesn't work neither in Lucid nor Maverick.
I've tried all the suggestions with no luck but once.
No proxy is used.

That once when (for the n:th time) I deleted ~/.gconf the weather info popped up again both in the Clock and in the Weather Report. Tested both reboots and logout/login and it still worked. Next day when I colded started the computer again those infos were gone and have never showed up again. It seems that both of them are waiting to get the info, e.g. the Weather Report is kept in status Updating...

So one question is, how do we track this down as we can't use tools like strace?

Bowmore (bowmore) wrote :

More investigations show that in my case (not behind proxy) the problem is that my ISP DNSes bar IWS servers, i.e DNS lookups fail for some reason. Switching e.g to Googles public DNSes makes it work again. Thus, this is my workaround until my ISP fixes this issue.

Cross (strokemeister) wrote :

I'm currently working with Google's DNSs and I don't got problems with weather anymore.

Just try changing your DNS's and watch what happens :)

Changed in gnome-panel:
importance: Unknown → High
Si Dedman (dez93-2000) wrote :

no forecast or radar for Newcastle, UK. Changed DNS (n00bs: system>prefs>network connections>) but no joy. Any thoughts/ideas? cheers

Martin Pitt (pitti) wrote :

Was fixed in 2.27.2, closing.

Changed in libsoup2.4 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.