[intrepid] rhythmbox crashes when iTunes 7.7.1.11 win32 attempts to access DAAP shared library

Bug #272650 reported by Michael DePaulo on 2008-09-21
6
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
libsoup2.4 (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Ubuntu System:
Intrepid Alpha 6 AMD64 with updates since
rhythmbox 0.11.6svn20080916-0ubuntu1
rhythmbox DAAP library sharing plugin enabled

Other System:
Windows XP SP3
iTunes 7.7.1.11

Steps to reproduce:
Open up Rhythmbox. From iTunes on the other system, attempt to access shared library on Ubuntu system. Rhythmbox then crashes and iTunes reports that the other system timed out.

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.11.6svn20080916-0ubuntu1
ProcAttrCurrent: unconfined
ProcCmdline: rhythmbox
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 ?? () from /usr/lib/libsoup-2.4.so.1
 g_closure_invoke ()
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist ()
 g_signal_emit () from /usr/lib/libgobject-2.0.so.0
Title: rhythmbox crashed with SIGSEGV in g_closure_invoke()
Uname: Linux 2.6.27-3-generic x86_64
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

Michael DePaulo (mikedep333) wrote :

StacktraceTop:IA__g_closure_invoke (closure=0x1fbd350, return_value=0x0, n_param_values=1,
signal_emit_unlocked_R (node=0x1f4d4f0, detail=0, instance=0x21bd0e0,
IA__g_signal_emit_valist (instance=0x21bd0e0, signal_id=<value optimized out>,
IA__g_signal_emit (instance=0x1, signal_id=80, detail=8667824)
io_read (sock=0x7ff3bc03ef00, msg=0x21bd0e0) at soup-message-io.c:740

Changed in rhythmbox:
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=553466

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: New → Triaged
Changed in rhythmbox:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :

according to upstream it's a libsoup issue :

"the DAAP plugin is busted with libsoup 2.23.92 and libsoup
2.24.0 due to the fix for http://bugzilla.gnome.org/show_bug.cgi?id=528882"

Pedro Villavicencio (pedro) wrote :

fixed upstream with libsoup 2.24.0.1

Changed in libsoup:
status: Triaged → Fix Committed
Changed in rhythmbox:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the bug is fixed in intrepid now

Changed in libsoup:
status: Fix Committed → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.