libsoup should support ntlmv2

Bug #1817537 reported by Lars Behrens on 2019-02-25
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libsoup2.4 (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned

Bug Description

* Impact
Without NTLMv2 support evolution-ews can't connect to some exchange servers

* Test case
Try connecting from evolution-ews to an exchange server which enforces NTLMV2

* Regression potential
The change adds extra cases in the ntlm handling support, it should impact existing feature but check out for any potential regression in libsoup user (check at least evolution and epiphany-browser).
Note that the patch include additional code tests

-------------------

Our Exchange admins recently made NTLMv2 obligatory. Since then interaction with Exchange through Evolution isn't possible anymore.

In newer versions of libsoup that has been implemented, see
https://gitlab.gnome.org/GNOME/evolution-ews/issues/38

Could that be backported to Ubuntu 18.04?

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libsoup2.4-1 2.62.1-1ubuntu0.1
ProcVersionSignature: Ubuntu 4.15.0-45.48-generic 4.15.18
Uname: Linux 4.15.0-45-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon Feb 25 12:10:26 2019
SourcePackage: libsoup2.4
UpgradeStatus: Upgraded to bionic on 2018-09-27 (150 days ago)

Lars Behrens (lars-behrens-u) wrote :
Sebastien Bacher (seb128) wrote :

The issue is fixed in the current Ubuntu version, closing for the current serie.

The commit looks like it's not too complex and could probably be backported to 18.04
https://gitlab.gnome.org/GNOME/libsoup/commit/0e7b2c14
(and https://gitlab.gnome.org/GNOME/libsoup/commit/7e4b94cd)

Changed in libsoup2.4 (Ubuntu):
importance: Undecided → High
status: New → Fix Released

Am Montag, den 25.02.2019, 15:29 +0000 schrieb Sebastien Bacher:
> The issue is fixed in the current Ubuntu version, closing for the
> current serie.

Hm, cannot confirm. At least evolution-ews fron cosmic cannot connect
to our server with ntlm selected.

description: updated
Sebastien Bacher (seb128) wrote :

I've uploaded a backport for the NTLMv2 support to Bionic now

Hello Lars, or anyone else affected,

Accepted libsoup2.4 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libsoup2.4/2.62.1-1ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libsoup2.4 (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

All autopkgtests for the newly accepted libsoup2.4 (2.62.1-1ubuntu0.2) for bionic have finished running.
There have been regressions in tests triggered by the package. Please visit the sru report page and investigate the failures.

https://people.canonical.com/~ubuntu-archive/pending-sru.html#bionic

Sorry to say that unfortunately it's not working here. Authentication
through ntlm still not working:

- installed package from proposed:

-----------------------------------------------------------------------
libsoup2.4 (2.62.1-1ubuntu0.2) bionic; urgency=medium

  * debian/patches/git_ntlmv2_support.patch,
    debian/patches/git_ntlmv2_test.patch:
    - include upstream changes for NTLMv2 responses support, that's
      required for evolution-ews to be able to connect some exchange
      servers, also include corresponding code tests
      (lp: #1817537)

 -- Sebastien Bacher <email address hidden> Tue, 09 Jul 2019 17:00:43
+0200
-----------------------------------------------------------------------

- rebooted

- same problem: using ntlm in Evolution still not possible,
authentication not working.

Thanks for your work!

Sebastien Bacher (seb128) wrote :

The changes fix some cases but seems like some servers require an extra change
https://gitlab.gnome.org/GNOME/libsoup/commit/c51f9f63

Hello Lars, or anyone else affected,

Accepted libsoup2.4 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libsoup2.4/2.62.1-1ubuntu0.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Lars Behrens (lars-behrens-u) wrote :

Still no luck here, not able to authenticate.

Shawn J Davidson (sjd4-g) wrote :

I tested the proposed package and it worked for me. I connected via NTLM.

Shawn J Davidson (sjd4-g) wrote :

To clarify, it resolved the issue for me. I was previously unable to connect because NTLMv1 was turned off where I work. Now I can connect.

Sebastien Bacher (seb128) wrote :

Thanks Shawn, I'm going to mark it as verified since it's an improvement and resolve some cases. It looks like more work is needed but there is no reason to block the current round on that, we can reopen and look to cases still not working then.

Lars, maybe it would be a good idea to report the issue also upstream on https://gitlab.gnome.org/GNOME/evolution-exchange if you could do that

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Shawn J Davidson (sjd4-g) wrote :

Quick question. Will this be added to the regular updates? I'm still using proposed for this update in bionic.

All autopkgtests for the newly accepted libsoup2.4 (2.62.1-1ubuntu0.3) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

gvfs/1.36.1-0ubuntu1.3.3 (ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#libsoup2.4

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsoup2.4 - 2.62.1-1ubuntu0.3

---------------
libsoup2.4 (2.62.1-1ubuntu0.3) bionic; urgency=medium

  * debian/patches/git_ntlmv2_support.patch:
    - update with an extra upstream tweak

libsoup2.4 (2.62.1-1ubuntu0.2) bionic; urgency=medium

  * debian/patches/git_ntlmv2_support.patch,
    debian/patches/git_ntlmv2_test.patch:
    - include upstream changes for NTLMv2 responses support, that's
      required for evolution-ews to be able to connect some exchange
      servers, also include corresponding code tests
      (lp: #1817537)

 -- Sebastien Bacher <email address hidden> Tue, 16 Jul 2019 20:36:23 +0200

Changed in libsoup2.4 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libsoup2.4 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Shawn J Davidson (sjd4-g) wrote :

Awesome! I revert back to stable and it's continuing to work for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers