Some radio streams which used to play OK don't play after updating to rhythmbox 2.98 or higher due a libsoup bug

Bug #1153934 reported by Walter Garcia-Fontes on 2013-03-12
722
This bug affects 150 people
Affects Status Importance Assigned to Milestone
libsoup
Fix Released
Medium
libsoup2.4 (Ubuntu)
High
Unassigned

Bug Description

The following stream, which I have saved in "Radio":

http://radioclasica.rtve.stream.flumotion.com/rtve/radioclasica.mp3.m3u

used to play perfectly (heard it daily) with the previous version of rhythmbox, but after upgrading to Ubuntu 13.04 which brought a new version does not play any more. Some other streams still play perfectly, for instance:

http://www.catmusica.cat/directes/catmusica_wm.m3u

After clicking the radio nothing happens, it doesn't play the stream or produces any other message whatsoever

WORKAROUND: Run the command "sudo killall gvfsd-http" after playing a station.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: libgstreamer0.10-0 0.10.36-1ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-11.20-generic 3.8.2
Uname: Linux 3.8.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.9.1-0ubuntu1
Architecture: amd64
Date: Tue Mar 12 08:22:27 2013
InstallationDate: Installed on 2010-10-25 (868 days ago)
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MarkForUpload: True
SourcePackage: gstreamer0.10
UpgradeStatus: Upgraded to raring on 2013-03-01 (10 days ago)

affects: gstreamer0.10 (Ubuntu) → rhythmbox (Ubuntu)
summary: - Some radio streams which used to play no don't after updating to
+ Some radio streams which used to play OK don't play after updating to
rhythmbox 2.98
Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → Incomplete

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
affects: rhythmbox (Ubuntu) → totem-pl-parser (Ubuntu)
affects: rhythmbox → totem-pl-parser
Changed in totem-pl-parser:
status: Incomplete → New
Changed in totem-pl-parser:
status: New → Confirmed
no longer affects: totem-pl-parser
affects: totem-pl-parser → gvfs
affects: totem-pl-parser (Ubuntu) → gvfs (Ubuntu)
Lukas (lukas-ribisch) wrote :

Worse yet: The streams that do not play seem to continue being downloaded in the background!

lsof -i showed a large number of gvfsd-http processes, each receiving one HTTP icecast radio stream, many of them duplicated (since I tried opening the streams multiple times).

I had to kill all of them manually; closing rhythmbox alone was not enough.

Hopefully, if I'm understand correctly, a fix has been committed upstream so that the parser does not trigger this gvfs bug, and I hope the gvfs bug will also be taken care afterwards. Let's see if this fixes this rhythmbox problem when this fix arrives to our updates.

Lukas (lukas-ribisch) wrote :

Good to hear that it is being fixed.

One more thing, maybe it'll help:
When starting one of the broken streams in Rhythmbox, a workaround is to immediately kill the new gvfsd-http process. As soon as that is gone, the stream starts to play without any issues and can be stopped from Rhythmbox.

Changed in gvfs:
importance: Unknown → Medium
status: Unknown → Confirmed

Thanks Lukas, your workaround is very useful

HKM (hkmouyabi) wrote :

I'll just wanna confirm what Lukas said. Killing the new 'gvfsd-http' process also helped in my case.

Romantic (zaharenkovroman) wrote :

Hey! Confirm that killing of 'gvfsd-http' works.

David M (theexternvoid) wrote :

Not that it needs more confirming, but yeah, the killing of gvfsd-http worked for me, too. If it's a bug in Rhythmbox itself then I'd be happy to attempt a fix it if a maintainer or other expert in the source code can give me pointers to get started. I was recently hacking the Rhythmbox source, so it's still fresh in my head.

Jan Wagner (waja) wrote :

Got rhytmbox working correct again after disabling the last-fm plugin.

Yann (yourfrenchman) wrote :

For me it's the same, when i kill the gvfsd-http, the streaming radios work again !

tags: added: i386
Patrick (patrickstar777) wrote :

same here

Frans Ojala (virta) wrote :

I would also like to confirm the bug. The same behavior repeated on all streams: player "pauses" and stop responding. Killing the gvfsd-http did not help. I tried not using LastFM plugin without success.

I was able to get things working by disabling crossfade altogether. I enabled it yesterday and today Rhythmbox stopped working. I did play some music, but did not restart streams or the player after enabling until today.

Ubuntu 13.04 (raring) 64bit
Rhythmbox 2.98
GCC 4.7 (x86_64-linux-gnu)

tags: added: saucy

This also affects Ubuntu 13.10 Saucy Salamander which is currently in development (Rhythmbox 2.99.1).

w-sky (w-sky) wrote :

The workarounds described above do not work for me (2.98 with Raring). Neither deactivating the Last.fm plugin nor killing the gvfsd-http process.

When I kill gvfsd-http though, one more notification pop up is displayed showing the name of the radio station, then another gvfsd-http process appears and then Rhythmbox freezes.

:(

w-sky (w-sky) wrote :

Also I can not agree that just *some* radio streams do not play; I tried several (and also checked the urls by playing them with VLC without problems) - but none plays in Rhythmbox.

For instance this one works for me:

http://www.catradio.cat/directes/catinfo_wm.m3u

Achim Vogel (achim-r-vogel) wrote :

I tried that address, it didn't work with my sytem

summary: Some radio streams which used to play OK don't play after updating to
- rhythmbox 2.98
+ rhythmbox 2.98 or higher due a gvfs bug

When adding a new radio stream to Rhythmbox, the new stream will not play until gvfsd-http is killed.
If Rhythmbox is restarted no stream will play until gvfsd-http is killed again.

lol medium priority for such basic tasks with a preinstalled appication with preinstalled radio stations....

Jenske (radiostermino) wrote :

This bug has been reported for quite some time now, but doesn't seem to be solved. Maybe because in the meanwhile a lot of people would have noticed that streaming audio _does_ work in VLC.

Jenske, the main reason is that it depends from upstream development in gvfs, and not from Ubuntu (not that if depended from Ubuntu would be resolved much faster, but at least we would have somebody around to ask). In any case I'm still using Rhythmbox daily to hear my preferred radios using the workaround mentioned in #5 .

Achim Vogel (achim-r-vogel) wrote :

Walter, that might be a quick solution but it is not very comfortable. I'm using Clementine instead of Rhythmbox in the meantime, which is a good alternative in my opinion.

That's why I like Linux: A bug in your favourite tool encourages you to try out another one. Nevertheless I hope that the gvfs bug will be fixed soon.

The bug was reported here the first time in December 2012 here. (https://bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/1087997).

Also confirmed for Fedora:
https://bugzilla.gnome.org/show_bug.cgi?id=695652#c31

Walter completely right what you say, but I would have hoped that here could have been a better solution for all users in the upcoming releases of their Distributions. And maybe our Desktop Team could support us a little bit.

But just that you understand me, I don't want to blame anyone, just maybe to think about how we handle bugs with many users affected.

Wishing you all a nice weekend :)

Thanks, killing gvfsd-http worked for me too!

Elbarbudo (patricearnal) wrote :

Thanks
Killing gvfsd-http worked for me too!

Colan Schwartz (colan) wrote :
description: updated

Am 22.07.2013 17:21, schrieb Colan Schwartz:
> + WORKAROUND: Run the command "sudo killall gvfsd-http" after playing a
> + station.

Privileged permissions are not needed, it just workes without as long as
you kill the processe(s) with the same user who runs rhythmbox!

@cyco: In my case, I keep getting new processes after killing them unprivileged. They only stay dead when running as root.

If someone can confirm that it works without sudo, please update the workaround saying that it should be tried first without it.

Changed in gvfs:
status: Confirmed → Incomplete
lively (doratheexplorer) wrote :

http://playerservices.streamtheworld.com/pls/CBC_R1_WDR_L.pls used to play before 13.04 upgrade but now exhibits behaviour described above. Other radio stations play without an issue

lively (doratheexplorer) wrote :

Confirm this link works in VLC http://playerservices.streamtheworld.com/pls/CBC_R1_WDR_L.pls, just not Rhythmbox. The error box after using the work-around (sudo killall gvfsd-http) indicates that the stream is bbeing recognized as text.

Colan Schwartz (colan) wrote :

@lively: That's another bug, but I can't find it right now. Use the direct URL in the PLS file as the station URL.

Changed in gvfs:
status: Incomplete → Confirmed
Timo Aaltonen (tjaalton) on 2013-08-15
Changed in gvfs (Ubuntu):
importance: Undecided → High
Kurt Burger (kurt-burger1) wrote :

Thanks
Killing gvfsd-http worked for me too!

ubuntu 13.04/32 Bit
3,9 GiB
Intel® Core™2 CPU 6600 @ 2.40GHz × 2
Gallium 0.4 on NV49

Jenske (radiostermino) wrote :

Unfortunately, having had this problem several months and _not_ having found any solution -- the killing of gvfsd-http did not work for me -- I almost accidentaly bumped into Clementine.

This program works perfectly for me and so I've threwn away Rhythmbox. I'll be using Clementine for the future. Clementine does play the audiostreams I'm used to listen to (e.g. http://217.23.7.117:8128 and http://mp3.streampower.be/klaracontinuo-high).

So in a sens killing Rhythmbox did the job for me ;)

no longer affects: gvfs
summary: Some radio streams which used to play OK don't play after updating to
- rhythmbox 2.98 or higher due a gvfs bug
+ rhythmbox 2.98 or higher due a libsoup bug
affects: gvfs (Ubuntu) → libsoup (Ubuntu)
Changed in libsoup:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in libsoup (Ubuntu):
status: Confirmed → Fix Committed
Andrew Springer (e10byagrue) wrote :

Any guess as to how long it will take for the update to reach me as a user? (I only ask to know if it is worth it to install a different player, which it wouldn't be if it was only a couple of days)

Timo Aaltonen (tjaalton) wrote :

nothing is committed to ubuntu, resetting back to triaged

affects: libsoup (Ubuntu) → libsoup2.4 (Ubuntu)
Changed in libsoup2.4 (Ubuntu):
status: Fix Committed → Triaged

In my opinion this bug should critical blocker and 13.10 milestone. Its a regression in usability

Timo Aaltonen (tjaalton) wrote :

meh, I have a build here:

https://launchpad.net/~tjaalton/+archive/ppa

but now it fails to play certain streams completely, and killing gvfs-http crashes rhythmbox, so it's not a complete solution yet..

Changed in libsoup2.4 (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: Triaged → In Progress
Adam Niedling (krychek) wrote :

Rhythmbox can't play this m3u file in Ubuntu 13.10.

zniavre (zniavre2048-gmail) wrote :

i was affected with this bug since long time, today i hav made a new user to test a new config and rhythmbox played normally the stream it does not since year (at least this bug is open)
so i tried to understand wich config files it was, i saw in /home some .gvfs folder i deleted also in .cache .config .local/... all gvfs from home deleted and after relog rhythmbox is playing all stream as it must

hope this is as simple for most of you.

Achim Vogel (achim-r-vogel) wrote :

@zniavre:

Just for better understanding: What did you delete exactly: All the mentioned .gvfs folders or just their content?

Many thanks in advance.

Lukas (lukas-ribisch) wrote :

The bug still occurs in 13.10 :(

zniavre (zniavre2048-gmail) wrote :

@Achim Vogel every folder with .gvfs inside /home first was .gvfs and i found two others in .config and .cache i did not touch the .gvfs-metadata inside .local/share

Deleting the folder .gvfs didn't solve the issue for me.

Doug McMahon (mc3man) wrote :

This is fixed in 14.04 (libsoup2.4-2.44.1

great! ... what about 13.10?

Treesong (treesong) wrote :

This bug also affects me for some streams but not all. Killing gvfsd-http works for me too. I'm glad to hear that it's fixed in 14.04 but concerned that we may be out of luck until 14.04 is released. Thanks for mentioning the workaround! It helped me confirm that this is indeed a bug and not a problem with my local community radio station's streaming service.

rrich1974 (richardsdma) wrote :

here we are in january 2014 and the bug is still live and well.
killing the gvfsd-http plays the stream right away.
i am very sad!

rrich1974, the bug has been fixed upstream, and it seems that the updated package is already available in the development version of Ubuntu (14.04, to release in April). It's not immediate to update a library like the one responsible of this bug in a stable release because you never know what type of secondary effects it may have and you don't want to fix one thing and break others in a stable release.

But if you think that the fix does not have secondary effects and there is a case for bringing it to a stable Ubuntu release, you can apply for a stable release updage (SRU). The instructions are here:

https://wiki.ubuntu.com/StableReleaseUpdates

Timo Aaltonen (tjaalton) wrote :

yep, fixed in trusty, good enough for me

Changed in libsoup2.4 (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → nobody
status: In Progress → Fix Released

I went ahead and switched to Bashee player, since I won't be upgrading
to Trusty until I absolutely have to.

Adam Niedling (krychek) on 2014-05-04
tags: added: trusty
Dan Kegel (dank) wrote :

Not fixed in trusty?
On a fresh vanilla trusty, clicking on http://www.radioberlin.de/live.m3u
brings up rhythmbox but it fails to play, complaining "could not determine type of stream".

I killed gvfsd-http and clicked on the new station in Radio, and this time it installed the needed plugins and started playing,
but I didn't try clicking on the new station in Radio without killing first.

Adam Niedling (krychek) wrote :

This is not fixed!
http://www.radioberlin.de/live.m3u does not play in rhythmbox!

Totem plays it fine!

Elbarbudo (patricearnal) wrote :

http://www.radioberlin.de/live.m3u plays in rhythmbox on my computer....

http://www.radioberlin.de/live.m3u plays also fine in my system:

$ apt-cache policy rhythmbox
rhythmbox:
  Installed: 3.2.1-1ubuntu3
  Candidate: 3.2.1-1ubuntu3
  Version table:
 *** 3.2.1-1ubuntu3 0
        500 http://ftp.caliu.cat/pub/distribucions/ubuntu/archive/ wily/main amd64 Packages
        100 /var/lib/dpkg/status

I'm using Ubuntu 13.10 development version, but this has been fixed for a couple of versions already.

@krychek, if you think this is an issue for you try to file a bug with the information of your system, following the instructions in https://help.ubuntu.com/community/ReportingBugs

Adam Niedling (krychek) wrote :

Elbarbudo, Walter: try to download that m3u file, then open it with rhythmbox. It won't play it for me.
I've figured out how to add its url in the radio section of rhythmbox and it plays fine. But it won't do anything with that m3u file.

@krycheck, I don't understand much about those formats, but are "m3u" files not supposed to be "playlist" files? I mean, it is supposed to be for playing radio streams and not as standalone music files. Maybe Totem opens those files and then opens the stream, but in Rhythmbox adding the link as a radio station maybe the way it is supposed to be done. Podcasts in any case are downloaded as mp3 files usually, and this is a radio stream.

Adam Niedling (krychek) wrote :

Walter: So do you think it's correct behaviour that Ubuntu lets you open an m3u file with Rhythmbox (as default?) and absolutely nothing happens? Come on now...

Anyway, I've found a separate bug report for this: Bug #62430.

@krycheck, what's sure is that this bug report is unrelated to your problem, so you should continue in the other (very old) report. It looks like it never got attention from upstream, nor there is any intention in upstream on paying attention to it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.