/usr/lib/x86_64-linux-gnu/libsndfile.so.1: undefined symbol: vorbis_version_string

Bug #999994 reported by Chelmite on 2012-05-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libsndfile (Ubuntu)
Undecided
Unassigned

Bug Description

When I try to run virtualbox, I get the message:
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/x86_64-linux-gnu/libsndfile.so.1: undefined symbol: vorbis_version_string

I have tried installing and re-installing libsndfile1 and anything "vorbis" that seems like it might have a positive influence on this file.

I initially thought the problem was with virtualbox, but after filing a bug with virtualbox (https://www.virtualbox.org/ticket/10567), they claim it's not with virtualbox. I have tried both the ubuntu version of virtualbox and the one from the virtualbox.org site that's built for ubuntu 12.04. Both fail with the same error message.

Help!!!
(The annoying thing is that I don't use the sound in virtualbox, but I'm being prevented from working because of this bug/dependency with libsndfile!)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libsndfile1 1.0.25-4
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Tue May 15 16:49:15 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/tcsh
SourcePackage: libsndfile
UpgradeStatus: No upgrade log present (probably fresh install)

Chelmite (steve-kelem) wrote :
Chelmite (steve-kelem) wrote :

I ended up downloading the source for libsndfile and some of its dependencies and recompiling.
After over-writing the distributed library with the recompiled one, it works again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers