libslirp 4.1.0-2ubuntu1 source package in Ubuntu

Changelog

libslirp (4.1.0-2ubuntu1) focal; urgency=medium

  * SECURITY UPDATE: buffer overflow via incorrect snprintf return codes
    - debian/patches/ubuntu/CVE-2020-8608-1.patch: add slirp_fmt() helpers
      to src/util.c, src/util.h.
    - debian/patches/ubuntu/CVE-2020-8608-2.patch: fix unsafe snprintf()
      usages in src/tcp_subr.c.
    - CVE-2020-8608

 -- Marc Deslauriers <email address hidden>  Wed, 19 Feb 2020 08:57:46 -0500

Upload details

Uploaded by:
Marc Deslauriers on 2020-02-19
Uploaded to:
Focal
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
misc
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
libslirp_4.1.0.orig.tar.bz2 90.9 KiB f423c54c96eb3310bf9519abc8c9c11539801a14327b48b8f36acf407584bbd1
libslirp_4.1.0-2ubuntu1.debian.tar.xz 6.9 KiB 3189f1978b859429adf79cebc5a6aecef25ab5e80e7de0909360d4d3665925ea
libslirp_4.1.0-2ubuntu1.dsc 2.1 KiB b38e8d460b7f769a79498b6edca1508e37b89b6e77ec6ae4801b60ec191f59b0

View changes file

Binary packages built by this source

libslirp-dev: General purpose TCP-IP emulator library (development files)

 libslirp is a user-mode networking library used by virtual machines,
 containers or various tools.
 .
 This package contains the header files and other files
 needed to compile applications which uses libslirp.

libslirp0: General purpose TCP-IP emulator library

 libslirp is a user-mode networking library used by virtual machines,
 containers or various tools.
 .
 This package contains the library itself.

libslirp0-dbgsym: debug symbols for libslirp0