Wrong package section, should be in "introspection"

Bug #1639050 reported by Michael Biebl
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
webapps-sprint
Medium
Alberto Mardegan
libsignon-glib (Ubuntu)
Medium
Alberto Mardegan

Bug Description

Packages shipping gobject introspection should be in the dedicated section "introspection". This archive section was added a while ago, see also the corresponding entry in the debian policy 3.9.3.0:

2.6. Version 3.9.3.0
--------------------

     Released February, 2012.

     2.4
          New archive sections _education_, _introspection_, and
          _metapackages_ added.

Packages shipping gobject introspection should be named gir1.2-NAMESPACE-VERSION.

Based on the output of apt-cache, the following packages are in the wrong section. I didn't file a separate bug for all of them. I would appreciate if you can adjust the archive section for all the following packages in one go.

#!/bin/bash

while read pkg ; do
       apt-cache show $pkg | grep Section | grep -v introspection -q && echo $pkg
done < <( apt-cache search -n ^gir1.2 | cut -f1 -d' ' )

gir1.2-accounts-1.0
gir1.2-accountsservice-1.0
gir1.2-appindicator-0.1
gir1.2-appindicator3-0.1
gir1.2-atk-1.0
gir1.2-atspi-2.0
gir1.2-bamf-3
gir1.2-cheese-3.0
gir1.2-clutter-1.0
gir1.2-cogl-1.0
gir1.2-coglpango-1.0
gir1.2-colord-1.0
gir1.2-dbusmenu-glib-0.4
gir1.2-dbusmenu-gtk-0.4
gir1.2-dbusmenu-gtk3-0.4
gir1.2-dee-1.0
gir1.2-ebook-1.2
gir1.2-edataserver-1.2
gir1.2-fcitx-1.0
gir1.2-freedesktop
gir1.2-gconf-2.0
gir1.2-gdata-0.0
gir1.2-gdesktopenums-3.0
gir1.2-gdkpixbuf-2.0
gir1.2-gkbd-3.0
gir1.2-glib-2.0
gir1.2-gmenu-3.0
gir1.2-gnomebluetooth-1.0
gir1.2-gnomedesktop-3.0
gir1.2-goa-1.0
gir1.2-gtk-2.0
gir1.2-gtk-3.0
gir1.2-gtkclutter-1.0
gir1.2-gtksource-3.0
gir1.2-gtop-2.0
gir1.2-gucharmap-2.90
gir1.2-gudev-1.0
gir1.2-gweather-3.0
gir1.2-hud-2
gir1.2-hud-client-2
gir1.2-ido3-0.1
gir1.2-json-1.0
gir1.2-lightdm-1
gir1.2-messagingmenu-1.0
gir1.2-nautilus-3.0
gir1.2-networkmanager-1.0
gir1.2-notify-0.7
gir1.2-packagekitglib-1.0
gir1.2-pango-1.0
gir1.2-peas-1.0
gir1.2-polkit-1.0
gir1.2-rb-3.0
gir1.2-rest-0.7
gir1.2-rest-extras-0.7
gir1.2-rsvg-2.0
gir1.2-signon-1.0
gir1.2-soup-2.4
gir1.2-telepathyglib-0.12
gir1.2-timezonemap-1.0
gir1.2-totem-1.0
gir1.2-totem-plparser-1.0
gir1.2-unity-5.0
gir1.2-upowerglib-1.0
gir1.2-wnck-3.0
gir1.2-evince-3.0
gir1.2-geocodeglib-1.0
gir1.2-libertine
gir1.2-nmgtk-1.0
gir1.2-ubuntu-app-launch-2
gir1.2-anjuta-3.0
gir1.2-atril
gir1.2-caja
gir1.2-caribou-1.0
gir1.2-champlain-0.12
gir1.2-cryptui-0.0
gir1.2-diodon-1.0
gir1.2-eom
gir1.2-evd-0.1
gir1.2-folks-0.6
gir1.2-gdl-3
gir1.2-gssdp-1.0
gir1.2-gtk-vnc-2.0
gir1.2-gtkchamplain-0.12
gir1.2-gupnp-1.0
gir1.2-gupnp-av-1.0
gir1.2-gupnpigd-1.0
gir1.2-indicate-0.7
gir1.2-itl-1.0
gir1.2-keybinder-3.0
gir1.2-maliit-1.0
gir1.2-mate-menu
gir1.2-mate-panel
gir1.2-mate-polkit
gir1.2-matekbd
gir1.2-mutter-3.0
gir1.2-spice-client-glib-2.0
gir1.2-spice-client-gtk-3.0
gir1.2-telepathylogger-0.2
gir1.2-urfkill-glib0
gir1.2-v-sim-1.0
gir1.2-gladeui-2.0
gir1.2-grip
gir1.2-javascriptcoregtk-3.0
gir1.2-libvirt-glib-1.0
gir1.2-nemo-3.0
gir1.2-snapd-1
gir1.2-webkit-3.0

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: gir1.2-accounts-1.0 1.22+16.10.20160520.2-0ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-26.28-generic 4.8.0
Uname: Linux 4.8.0-26-generic x86_64
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Nov 3 22:02:42 2016
InstallationDate: Installed on 2011-11-10 (1819 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: libaccounts-glib
UpgradeStatus: Upgraded to yakkety on 2016-11-03 (0 days ago)

Related branches

Revision history for this message
Michael Biebl (mbiebl) wrote :
Alberto Mardegan (mardy)
Changed in libaccounts-glib (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Alberto Mardegan (mardy)
Changed in webapps-sprint:
milestone: none → sprint-27
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → Medium
Alberto Mardegan (mardy)
affects: libaccounts-glib (Ubuntu) → libsignon-glib (Ubuntu)
Revision history for this message
Alberto Mardegan (mardy) wrote :

I'm a bit confused. I thought that the section information was stored in debian/control, but I see that while I have had (since 2014) "Section: introspection" in libaccounts-glib's debian/control [1], "apt-cache show" claims that the section is "libs".

So, where does apt-cache get the information from?

BTW, I might not be the best person to take care of this bug, since I'm not even an Ubuntu developer. I can take care of my own packages (libaccounts-glib, libsignon-glib) but I don't have the power to push packages to the archive.

[1] http://bazaar.launchpad.net/~online-accounts/libaccounts-glib/trunk/view/head:/debian/control#L56

Revision history for this message
Michael Biebl (mbiebl) wrote :

In Debian, the values in debian/control are only used when the package is uploaded intially to the archive. The override entry is created from that.
Changing the contents of the archive override is done by the ftp-masters. If you later change the contents of debian/control does not have an influence on the override file.

So, this needs to be assigned to your ftp masters, they need to fix the overrides and should be able to do that in one go.

Revision history for this message
Martin Pitt (pitti) wrote :

> I'm a bit confused. I thought that the section information was stored in debian/control, but I see that while I have had (since 2014) "Section: introspection" in libaccounts-glib's debian/control [1], "apt-cache show" claims that the section is "libs".

No, you don't. debian/control says

Package: gir1.2-signon-1.0
Section: libs

So this does need to be fixed.

Meanwhile I can change the archive overrides correspondingly.

Revision history for this message
Martin Pitt (pitti) wrote :

I changed the overrides of all the gir* packages in zesty, so that the archive now has the correct ones. The sources should still be updated to follow suit at some point, though.

Alberto Mardegan (mardy)
Changed in webapps-sprint:
status: New → In Progress
Changed in libsignon-glib (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsignon-glib - 1.14+17.04.20161117-0ubuntu1

---------------
libsignon-glib (1.14+17.04.20161117-0ubuntu1) zesty; urgency=medium

  * debian/control:
    - GIR package should be in "introspection" section (LP: #1639050)

 -- Alberto Mardegan <email address hidden> Thu, 17 Nov 2016 09:02:13 +0000

Changed in libsignon-glib (Ubuntu):
status: In Progress → Fix Released
Alberto Mardegan (mardy)
Changed in webapps-sprint:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers