libsepol 2.2-1ubuntu0.1 source package in Ubuntu

Changelog

libsepol (2.2-1ubuntu0.1) trusty; urgency=medium

  [ Laurent Bigonville ]
  * Drop debian/libsepol1.postinst: Which had unguarded `telinit u' call,
    which is not strictly needed and otherwise causes unwatned side
    effects to the init process. (Closes: #753727) (LP: #1331555)
 -- Dimitri John Ledkov <email address hidden>   Wed, 26 Nov 2014 00:26:53 +0000

Upload details

Uploaded by:
Dimitri John Ledkov on 2014-11-26
Uploaded to:
Trusty
Original maintainer:
Debian SELinux maintainers
Architectures:
linux-any
Section:
misc
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Trusty updates on 2014-12-09 main misc

Downloads

File Size SHA-256 Checksum
libsepol_2.2.orig.tar.gz 204.7 KiB 77a4b27006295805bdbd7f240038cb32a49be1d60847d413899501702933fc0f
libsepol_2.2-1ubuntu0.1.debian.tar.xz 12.7 KiB 5a901f01f3f03b110bee09ca0813f5e3afc308744778604004166869b08c5cc7
libsepol_2.2-1ubuntu0.1.dsc 1.8 KiB e9b32bf57f6e1c0f4eafa75dcdf2e682c52f70978d76789a994fab5f3ce544b4

Available diffs

View changes file

Binary packages built by this source

libsepol1: SELinux library for manipulating binary security policies

 Security-enhanced Linux is a patch of the Linux kernel and a number
 of utilities with enhanced security functionality designed to add
 mandatory access controls to Linux. The Security-enhanced Linux
 kernel contains new architectural components originally developed to
 improve the security of the Flask operating system. These
 architectural components provide general support for the enforcement
 of many kinds of mandatory access control policies, including those
 based on the concepts of Type EnforcementĀ®, Role-based Access
 Control, and Multi-level Security.
 .
 libsepol provides an API for the manipulation of SELinux binary policies.
 It is used by checkpolicy (the policy compiler) and similar tools, as well
 as by programs like load_policy that need to perform specific transformations
 on binary policies such as customizing policy boolean settings.

libsepol1-dev: SELinux binary policy manipulation library and development files

 libsepol allows programs to easily modify SELinux binary policies. This
 means changing the default values for booleans, or reading the policy for
 analysis.
 .
 This package contains the headers and archives used for linking it into your
 programs.

sepol-utils: Security Enhanced Linux policy utility programs

 This package provides a utility for a Security-enhanced
 Linux system to rewrite existing mandatory access control policy with
 different boolean setting, generating a new policy. Security-enhanced
 Linux is a patch of the Linux kernel and a number of utilities with
 enhanced security functionality designed to add mandatory access
 controls to Linux. This package provides utility programs to get and
 set process and file security contexts and to obtain security policy
 decisions.