[needs-packaging] libsecret

Bug #1018630 reported by Robert Ancell on 2012-06-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libsecret (Ubuntu)
Wishlist
Unassigned

Bug Description

https://live.gnome.org/Libsecret
Replacing libgnome-keyring

Robert Ancell (robert-ancell) wrote :

Latest seahorse currently uses libsecret, other GNOME apps will be migrated to it:
https://live.gnome.org/Libsecret/Migration

Changed in ubuntu:
status: New → Triaged
importance: Undecided → Wishlist
tags: added: desktop-upgrade
tags: added: needs-packaging
Robert Ancell (robert-ancell) wrote :

Blocking gnome-online-accounts update (bug #1025533)

Robert Ancell (robert-ancell) wrote :

Blocking seahorse update (bug #1025540)

description: updated
Robert Ancell (robert-ancell) wrote :

Tests work when run from git build, but not from packaging so the packaging in lp:~robert-ancell/libsecret/ubuntu has the tests disabled.

Not sure what to do with the translations - they come from both the tool and the library but the library neither initialises gettext. So I suspect the library either needs to be updated or it shouldn't provide translated strings (they're only in errors). The translations are currently packaged with the libsecret-tools binary package (unsure if this is a good name).

Robert Ancell (robert-ancell) wrote :

Talked with upstream and the translations can be shipped with the library - the tool requires the library to be installed so both will work.

Sebastien Bacher (seb128) wrote :

Thanks Robert, I just had a look to your vcs, it seems mostly fine

you need a -common for the library for the translations ideal, it doesn't matter much on Ubuntu because we strip them but having them with the lib means different soname versions would conflict at the packaging level and multiarch wouldn't work ... we can ignore that bug knowing it might create issues for e.g ppa builds and that Debian will need the -common we might as well do that from the start

did you talk to Debian about adding it there, can you just commit it to the pkg-gnome vcs so they base their work on that version later?

tags: added: upgrade-software-version
removed: desktop-upgrade
tags: removed: upgrade-software-version
Robert Ancell (robert-ancell) wrote :

Blocking gnome-disk-utility update (bug #1030269)

Robert Ancell (robert-ancell) wrote :

Branch updated with changes and it is already in the Debian svn.

affects: ubuntu → libsecret (Ubuntu)
Changed in libsecret (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers