libsdl2 No longer works with MIR 0.14 and greater (ABI/API break)

Bug #1513241 reported by Brandon Schaefer
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libsdl2 (Ubuntu)
Fix Released
High
Brandon Schaefer

Bug Description

libsdl2 no longer works with mir 0.14 and greater. Due to ABI/API breakage. SDL2 should just be updated to the new ABI/API,

Related branches

Changed in libsdl2 (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
summary: - libsdl2 No longer works with mir 0.14 and greater (ABI/API break)
+ libsdl2 No longer works with MIR 0.14 and greater (ABI/API break)
Changed in libsdl2 (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Hi, is this still needed with the new SDL2 2.0.4?

Revision history for this message
Brandon Schaefer (brandontschaefer) wrote :

Yup, since SDL upstream follows LTS, soo cant merge my changes until 16.04 (though i should poke them to check :)

Current branch:
https://code.launchpad.net/~brandontschaefer/+junk/SDL2-new-mir-ABI

Which Ill be making a patch once 2.0.4 gets synced with ubuntu!

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Hi, since I did the sync of sdl 2.0.4, I'm proposing a tweak of your patch against the new release.

Problem:
2.0.4 didn't have MIR enabled, because the sync dropped the rules part when it had been forcibly enabled.
so it got syncd and built wrongly.

the root of the cause was a bad configure.ac script, checking for a removed API.
"MirMotionToolType tool = mir_motion_tool_type_mouse;"

solution: I took your patch, rebased on top of the new 2.0.4 in xenial, and attached to this message.

With your blessing I can upload (after updating the changelog timestamp of course)
(note: I also dropped a little part of the patch, because you were changing the copyright year, but it was already changed in the new release)

do you prefer to have MIR disabled, this patch applied and uploaded or whatever?
(sorry for the troubles I have caused)

Changed in libsdl2 (Ubuntu):
importance: Medium → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsdl2 - 2.0.4+dfsg1-2ubuntu1

---------------
libsdl2 (2.0.4+dfsg1-2ubuntu1) xenial; urgency=medium

  * debian/patches/mir_new_abi_api.diff: New Mir ABI/API update
    to work with MIR 0.14 and greater (lp: #1513241)
  * Add libmirclient-dev as build-dependency.

 -- Brandon Schaefer <email address hidden> Wed, 20 Jan 2016 12:03:45 -0600

Changed in libsdl2 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Patches