The function X11_KeyToUnicode is missing in libsdl in Edgy ( dapper ok)

Bug #66217 reported by philippe-c on 2006-10-15
4
Affects Status Importance Assigned to Milestone
libsdl1.2 (Debian)
Fix Released
Unknown
libsdl1.2 (Ubuntu)
Undecided
Colin Watson

Bug Description

This function is used by game build on SDL library in order to transform input of the keyboard into Unicode characters.
There is a risk that a lot of game build on SDL does not work with Edgy.
For instance all the games based on Torque will not work with edgy : http://www.garagegames.com/

This function has been removed in the current package libsdl 1.2( 1.2.10.3) .provided with edgy ( it works with dapper).

For your information a patch has been provided with libsdl1.2 (1.2.11-3), have a look on :
http://packages.debian.org/changelogs/pool/main/libs/libsdl1.2/libsdl1.2_1.2.11-3/changelog

Warning : all the libraries linked to libsdl should be updated in the same way.

How to reproduce :
1/ download the demo of torque available at : http://demos.garagegames.com/tge/TorqueGameEngineDemo-1.4.2-RC1.bin

2/ install it , launch in a console window : TorqueGameEngineDemo-1.4.2-RC1.bin

3/ follow the installation procedure : click on next

4/ go to the installation directory and launch : demo.bin

You get the folowing errors message and demo.bin crashes:
"demo.bin: symbol lookup error: demo.bin: undefined symbol: X11_KeyToUnicode"

This demo works with dapper.

philippe-c (phc-cai) on 2006-10-15
description: updated
Ronny Bangsund (ronnyb) wrote :

I have the same problem on Edgy i386. I consider it quite critical,
since I can't code without it.

Colin Watson (cjwatson) wrote :

Fixed in Feisty by merging this change from Debian:

libsdl1.2 (1.2.11-3) unstable; urgency=low

  * debian/rules:
    + Factored the udeb rules.

  * debian/patches/017_x11_keytounicode.diff:
    + New patch. Export X11_KeyToUnicode() to legacy applications, but warn
      about such usage to stderr (Closes: #376560).

 -- Sam Hocevar (Debian packages) <email address hidden> Sun, 13 Aug 2006 19:03:51 +0200

Note, as mentioned in the Debian bug, that this is an internal function which should not be used by new SDL-using code.

Changed in libsdl1.2:
assignee: nobody → kamion
status: Unconfirmed → Fix Released
Changed in libsdl1.2:
status: Unknown → Fix Released
philippe-c (phc-cai) wrote :

Thanks a lot

Philippe C

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.